summaryrefslogtreecommitdiff
path: root/games-emulation/generator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/generator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/Manifest1
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-configure.patch94
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-execstacks.patch12
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-underlink.patch11
-rw-r--r--games-emulation/generator/generator-0.35_p4.ebuild52
-rw-r--r--games-emulation/generator/metadata.xml8
6 files changed, 178 insertions, 0 deletions
diff --git a/games-emulation/generator/Manifest b/games-emulation/generator/Manifest
new file mode 100644
index 00000000000..28137ed91b4
--- /dev/null
+++ b/games-emulation/generator/Manifest
@@ -0,0 +1 @@
+DIST generator-0.35-cbiere-r4.tar.bz2 435289 SHA256 54f3a94ed441cfd05d66e7730126c65287f3c1503f13987653c6db84739a79b6 SHA512 73fd36d8004135c172025b3eb3385f731e294935413d7ac905672f1a88434ca332325821c5f15d5ae83fb1385fcde9f1e7f32242f8ac175bb96bd535b5d91620 WHIRLPOOL 446345f838f6c79a31434eda2bb29ff8169036dc6fb26ee11b7adcdb4e7932c62f02fdb468c7a5125b0245b1eae6ffad34ec0d239702e5e1d975504efb7d190b
diff --git a/games-emulation/generator/files/generator-0.35_p4-configure.patch b/games-emulation/generator/files/generator-0.35_p4-configure.patch
new file mode 100644
index 00000000000..72ed087bd29
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-configure.patch
@@ -0,0 +1,94 @@
+--- configure.ac.original 2008-03-17 13:07:48.000000000 -0400
++++ configure.ac 2008-03-17 13:08:03.000000000 -0400
+@@ -28,15 +28,12 @@
+ AC_ARG_WITH(tcltk,
+ AS_HELP_STRING(--with-tcltk,Create tcltk version),
+ MY_PROG="generator-tcltk")
+- AC_ARG_WITH(gtk,
+- AS_HELP_STRING(--with-gtk,Create gtk version),
+- MY_PROG="generator-gtk")
+ AC_ARG_WITH(sdl,
+ AS_HELP_STRING(--with-sdl,Create SDL version),
+ [MY_PROG="generator-sdl"; USE_SDL_AUDIO=yes])
+ if [[ "x$MY_PROG" = "x" ]]; then
+ AC_MSG_ERROR(You must select a user interface type:
+- svgalib allegro tcltk gtk sdl)
++ svgalib allegro tcltk sdl)
+ fi
+ if [[ "x$MY_PROG" = "xgenerator-allegro" ]]; then
+ AC_DEFINE(ALLEGRO, 1, [Allegro version])
+@@ -202,50 +199,6 @@
+ CFLAGS="$CFLAGS -Wstrict-prototypes -Wunused"
+ fi
+ fi
+- if [[ "x$DEBUG" != "xno" ]]; then
+- AC_MSG_RESULT(Turning on debug flags)
+- CFLAGS="$CFLAGS -g -O"
+- optimum=no
+- else
+- if [[ "x$GCCVER" != "xno" ]]; then
+- AC_MSG_RESULT(Turning on gcc optimisations)
+- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer"
+- if [[ "x$GCCVER" = "x3" ]]; then
+- AC_MSG_RESULT(Turning on gcc 3 optimisations)
+- CFLAGS="$CFLAGS -fno-math-errno"
+- fi
+- case "$CFLAGS" in
+- *mcpu*|*march*) AC_MSG_RESULT(Skipping target optimisations)
+- ;;
+- *) case "$target_cpu" in
+- i386) AC_MSG_RESULT(Turning on i386 optimisations)
+- CFLAGS="$CFLAGS -march=i386 -ffast-math"
+- ;;
+- i486) AC_MSG_RESULT(Turning on i486 optimisations)
+- CFLAGS="$CFLAGS -march=i486 -ffast-math"
+- ;;
+- i586) AC_MSG_RESULT(Turning on pentium optimisations)
+- # cannot do malign-double as we link to other libraries and
+- # it would break binary compatibility
+- CFLAGS="$CFLAGS -march=pentium -ffast-math"
+- ;;
+- i?86) AC_MSG_RESULT(Turning on i686 optimisations)
+- # cannot do malign-double as we link to other libraries and
+- # it would break binary compatibility
+- CFLAGS="$CFLAGS -march=i686 -ffast-math"
+- ;;
+- alpha*) AC_MSG_RESULT(Adding -mieee for Alpha)
+- CFLAGS="$CFLAGS -mieee"
+- ;;
+- *) AC_MSG_RESULT(Sorry unknown target CPU)
+- ;;
+- esac
+- esac
+- else
+- AC_MSG_WARN(You did not opt for gcc optimisations!)
+- optimum=no
+- fi
+- fi
+ AC_CHECK_LIB(jpeg, jpeg_start_compress,
+ [ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])
+
+@@ -272,14 +225,7 @@
+
+ AC_PATH_XTRA
+
+- if [[ "x$MY_PROG" = "xgenerator-gtk" ]]; then
+- MY_SUBDIRS="glade gtkopts $MY_SUBDIRS"
+- AM_PATH_GTK(1.2.10,,AC_MSG_ERROR(Generator needs gtk 1.2.10 or later))
+- AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))
+-
+- MY_LIBS="$MY_LIBS $X_PRE_LIBS $X_LIBS $X_EXTRA_LIBS"
+- CFLAGS="$CFLAGS $X_CFLAGS"
+- elif [[ "x$MY_PROG" = "xgenerator-sdl" ]]; then
++ if [[ "x$MY_PROG" = "xgenerator-sdl" ]]; then
+ MY_SUBDIRS="gtkopts $MY_SUBDIRS"
+ AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))
+
+@@ -305,6 +251,7 @@
+ AC_CHECK_SIZEOF(unsigned long, 4)
+ AC_CHECK_SIZEOF(unsigned long long, 8)
+ AC_CHECK_HEADERS(sys/param.h)
++ AC_CHECK_HEADERS(sys/time.h)
+ AC_CHECK_HEADERS(bzlib.h)
+ AC_CHECK_HEADERS(zlib.h)
+ AC_CHECK_HEADERS(tcl8.0.h)
diff --git a/games-emulation/generator/files/generator-0.35_p4-execstacks.patch b/games-emulation/generator/files/generator-0.35_p4-execstacks.patch
new file mode 100644
index 00000000000..f92ef6121f5
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-execstacks.patch
@@ -0,0 +1,12 @@
+--- raze/Makefile.am.old 2006-09-03 03:17:39.000000000 +0200
++++ raze/Makefile.am 2006-09-03 03:16:36.000000000 +0200
+@@ -343,6 +343,10 @@
+ raze: raze.o
+ raze.o: raze.asm raze.reg
+ nasm -e raze.asm -o raze2.asm
++ echo "%ifidn __OUTPUT_FORMAT__,elf" >> raze2.asm
++ echo "section .note.GNU-stack noalloc noexec nowrite progbits" \
++ >> raze2.asm
++ echo "%endif" >> raze2.asm
+ nasm -f @ASMOUTPUT@ raze2.asm -o raze.o -praze.reg
+
diff --git a/games-emulation/generator/files/generator-0.35_p4-underlink.patch b/games-emulation/generator/files/generator-0.35_p4-underlink.patch
new file mode 100644
index 00000000000..964a6bea088
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-underlink.patch
@@ -0,0 +1,11 @@
+--- main/Makefile.am.old 2011-06-20 21:35:25.832460030 +0200
++++ main/Makefile.am 2011-06-20 21:36:29.490503981 +0200
+@@ -7,7 +7,7 @@
+ bin_PROGRAMS = @PROGRAM@
+ EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
+ generator-gtk generator-sdl
+-LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ \
++LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ -lm \
+ ../sn76496/libsn76496.a
+
+ ## this should be generator_tcltk_DATA but it won't let me do that
diff --git a/games-emulation/generator/generator-0.35_p4.ebuild b/games-emulation/generator/generator-0.35_p4.ebuild
new file mode 100644
index 00000000000..03e2cf9e0ff
--- /dev/null
+++ b/games-emulation/generator/generator-0.35_p4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs games
+
+MY_P=${PN}-${PV/_p/-cbiere-r}
+DESCRIPTION="Sega Genesis / Mega Drive emulator"
+HOMEPAGE="http://www.squish.net/generator/"
+SRC_URI="http://www.squish.net/generator/cbiere/generator/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="+sdlaudio"
+
+DEPEND="virtual/jpeg:0
+ media-libs/libsdl[joystick,video]
+ sdlaudio? ( media-libs/libsdl[sound] )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+
+ sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-cmz80 \
+ --with-sdl \
+ --without-tcltk \
+ --with-gcc=$(gcc-major-version) \
+ $(use_with sdlaudio sdl-audio)
+}
+
+src_compile() {
+ [[ -f Makefile ]] && emake clean
+ emake -j1
+}
+
+src_install() {
+ dogamesbin main/generator-sdl
+ dodoc AUTHORS ChangeLog NEWS README TODO docs/*
+ prepgamesdirs
+}
diff --git a/games-emulation/generator/metadata.xml b/games-emulation/generator/metadata.xml
new file mode 100644
index 00000000000..b21068e12a9
--- /dev/null
+++ b/games-emulation/generator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="sdlaudio">Enable SDL Audio</flag>
+ </use>
+</pkgmetadata>