summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-core
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 08:27:16 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 08:27:16 +0200
commitec5cf3687347e890de8079d48ecdaa73240cb3e7 (patch)
tree549bd468d18133daf484fd50d697bfeadad7e9fb /games-emulation/mupen64plus-core
parent16d7381d2608ef02c492fb989d95f756de2e1d2d (diff)
downloadgentoo-ec5cf3687347e890de8079d48ecdaa73240cb3e7.tar.gz
gentoo-ec5cf3687347e890de8079d48ecdaa73240cb3e7.tar.xz
games-emulation/mupen64plus-core: Drop old
Package-Manager: portage-2.3.1
Diffstat (limited to 'games-emulation/mupen64plus-core')
-rw-r--r--games-emulation/mupen64plus-core/Manifest1
-rw-r--r--games-emulation/mupen64plus-core/mupen64plus-core-2.0-r1.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/games-emulation/mupen64plus-core/Manifest b/games-emulation/mupen64plus-core/Manifest
index 4a2a712aa45..becbd3d17f7 100644
--- a/games-emulation/mupen64plus-core/Manifest
+++ b/games-emulation/mupen64plus-core/Manifest
@@ -1,2 +1 @@
-DIST mupen64plus-core-src-2.0.tar.gz 1127862 SHA256 7e98795dbe4646b858919078f58a6ed94f7cfa30867df6cf44ef33da6aaa7a28 SHA512 6f7391536c23b465af737b3b64f3488bc0275c472e27f97f1d8be61e917c6772cad2c747db8ffa251ba88ba4f4c0d29de2451325f3ea4bcc6049534ef1dac41e WHIRLPOOL c32c97071d911696c9b24a931287ba7da1bdb29434300d984926a2a1b0541660022b6a811f616e8ed18de8d59fdafd168a571b248165c950d80f4e045e25aa53
DIST mupen64plus-core-src-2.5.tar.gz 895890 SHA256 59e99a79e7f862517232e3115bd1f72377e3e34da795c118ba617c478c839578 SHA512 1bf643798de4f17e2ce4f2a67dfd242a8b24d873c413b49cbcb280e4264131222e3f3bc02c46111868102b0b5174d117ababceab66551cb38b76b22b3a94f697 WHIRLPOOL 3ea76e1bd914c9f8f2857976df7ab1ee6cc8d41e7b34f2fc832e0f4030b139b702b0295fca157f475b90245dbfe93aaab05ec5677cd676010b69af873b5f8840
diff --git a/games-emulation/mupen64plus-core/mupen64plus-core-2.0-r1.ebuild b/games-emulation/mupen64plus-core/mupen64plus-core-2.0-r1.ebuild
deleted file mode 100644
index c2f1ca6bf63..00000000000
--- a/games-emulation/mupen64plus-core/mupen64plus-core-2.0-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MY_P=${PN}-src-${PV}
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, core library"
-HOMEPAGE="http://www.mupen64plus.org/"
-SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0/2"
-KEYWORDS="~amd64 ~x86"
-IUSE="lirc new-dynarec +osd cpu_flags_x86_sse"
-
-RDEPEND="media-libs/libpng:0=
- media-libs/libsdl:0=[joystick,opengl,video]
- sys-libs/zlib:0=[minizip]
- lirc? ( app-misc/lirc:0 )
- osd? (
- media-fonts/ttf-bitstream-vera
- media-libs/freetype:2=
- virtual/opengl:0=
- virtual/glu:0=
- )
- !<games-emulation/mupen64plus-2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# block versions using games.eclass
-RDEPEND="${RDEPEND}
- !<games-emulation/m64py-0.2.1-r1
- !<games-emulation/mupen64plus-audio-sdl-2.0-r1
- !<games-emulation/mupen64plus-input-sdl-2.0-r1
- !<games-emulation/mupen64plus-rsp-hle-2.0-r1
- !<games-emulation/mupen64plus-ui-console-2.0-r1
- !<games-emulation/mupen64plus-video-glide64mk2-2.0-r1
- !<games-emulation/mupen64plus-video-rice-2.0-r1"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch_user
-
- # avoid implicitly appending CPU flags
- sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
-}
-
-src_compile() {
- MAKEARGS=(
- # Note: please keep this in sync in all of mupen64plus-* packages
-
- -C projects/unix
-
- # this basically means: GNU userspace
- UNAME=Linux
-
- # verbose output
- V=1
-
- CROSS_COMPILE="${CHOST}-"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
- # so we can leave OPTFLAGS empty
- OPTFLAGS=
-
- # paths, some of them are used at compile time
- PREFIX=/usr
- LIBDIR=/usr/$(get_libdir)
-
- # disable unwanted magic
- LDCONFIG=:
- INSTALL_STRIP_FLAG=
-
- # Package-specific stuff
-
- # CROSS_COMPILE causes it to look for ${CHOST}-sdl-config...
- SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl)"
- SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl)"
-
- OSD=$(usex osd 1 0)
- NO_ASM=$(usex cpu_flags_x86_sse 0 1)
- LIRC=$(usex lirc 1 0)
- # (it does not build)
- # DEBUGGER=$(usex debug 1 0)
- NEW_DYNAREC=$(usex new-dynarec 1 0)
- )
-
- use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
- use x86 && MAKEARGS+=( HOST_CPU=i386 )
-
- emake "${MAKEARGS[@]}" all
-}
-
-src_install() {
- emake "${MAKEARGS[@]}" DESTDIR="${D}" install
- einstalldocs
- dodoc -r doc/{emuwiki-api-doc,new_dynarec.txt}
-
- # replace bundled font with a symlink
- # TODO: fix the code to not rely on it
- local font_path=/usr/share/mupen64plus/font.ttf
- rm "${D%/}/${font_path}" || die
- if use osd; then
- dosym /usr/share/fonts/ttf-bitstream-vera/Vera.ttf "${font_path}"
- fi
-}