summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:18:31 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:22 +0200
commit6df74d977628749843781897fb1c6139cc30e5c0 (patch)
treef640632768608b4f036862b463e43c9008d8b3a9 /games-emulation
parent5e2a03877a1d861a33fef173c274b3ccee5f2820 (diff)
downloadgentoo-6df74d977628749843781897fb1c6139cc30e5c0.tar.gz
gentoo-6df74d977628749843781897fb1c6139cc30e5c0.tar.xz
games-emulation/fakenes: Drop old
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fakenes/fakenes-0.5.8-r2.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild b/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild
deleted file mode 100644
index eafa57d654f..00000000000
--- a/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs gnome2-utils games
-
-DESCRIPTION="portable, Open Source NES emulator which is written mostly in C"
-HOMEPAGE="http://fakenes.sourceforge.net/"
-SRC_URI="mirror://sourceforge/fakenes/${P}.tar.bz2"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="openal opengl zlib"
-
-RDEPEND=">=media-libs/allegro-4.4.1.1:0[opengl?]
- dev-games/hawknl
- openal? (
- media-libs/openal
- media-libs/freealut
- )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i \
- -e "s:openal-config:pkg-config openal:" \
- build/openal.cbd || die
-
- sed -i \
- -e "s:LIBAGL = agl:LIBAGL = alleggl:" \
- build/alleggl.cbd || die
- epatch "${FILESDIR}"/${P}-{underlink,zlib}.patch
-}
-
-src_compile() {
- local myconf
-
- append-ldflags -Wl,-z,noexecstack
-
- echo "$(tc-getBUILD_CC) cbuild.c -o cbuild"
- $(tc-getBUILD_CC) cbuild.c -o cbuild || die "cbuild build failed"
-
- use openal || myconf="$myconf -openal"
- use opengl || myconf="$myconf -alleggl"
- use zlib || myconf="$myconf -zlib"
-
- LD="$(tc-getCC) ${CFLAGS}" ./cbuild ${myconf} --verbose || die "cbuild failed"
-}
-
-src_install() {
- dogamesbin fakenes
- insinto "${GAMES_DATADIR}/${PN}"
- doins support/*
- dodoc docs/{CHANGES,README}
- dohtml docs/faq.html
-
- newicon -s 32 support/icon-32x32.png ${PN}.png
- make_desktop_entry ${PN} "FakeNES"
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}