summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:38:18 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:37 +0200
commit9f88f5db5b127935744d3f310f6e1023f3439c69 (patch)
tree5b0041382cac4cac04cb5c7960ea587cc430be17 /games-emulation
parent1d4bf242850b54b935760e55fbfad16c67e6c42d (diff)
downloadgentoo-9f88f5db5b127935744d3f310f6e1023f3439c69.tar.gz
gentoo-9f88f5db5b127935744d3f310f6e1023f3439c69.tar.xz
games-emulation/gcube: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gcube/files/gcube-0.4-gcc47.patch4
-rw-r--r--games-emulation/gcube/files/gcube-0.4-ldflags.patch4
-rw-r--r--games-emulation/gcube/files/gcube-0.4-underlink.patch4
-rw-r--r--games-emulation/gcube/gcube-0.4-r2.ebuild50
4 files changed, 56 insertions, 6 deletions
diff --git a/games-emulation/gcube/files/gcube-0.4-gcc47.patch b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
index b459a4e2403..48ac167a1f0 100644
--- a/games-emulation/gcube/files/gcube-0.4-gcc47.patch
+++ b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
@@ -1,5 +1,5 @@
---- Makefile.rules.old 2012-10-23 14:06:54.417782365 +0200
-+++ Makefile.rules 2012-10-23 14:07:11.516377033 +0200
+--- a/Makefile.rules.old 2012-10-23 14:06:54.417782365 +0200
++++ b/Makefile.rules 2012-10-23 14:07:11.516377033 +0200
@@ -1,6 +1,6 @@
SDL_CONFIG=sdl-config
diff --git a/games-emulation/gcube/files/gcube-0.4-ldflags.patch b/games-emulation/gcube/files/gcube-0.4-ldflags.patch
index 169472ee185..b4a64f16aed 100644
--- a/games-emulation/gcube/files/gcube-0.4-ldflags.patch
+++ b/games-emulation/gcube/files/gcube-0.4-ldflags.patch
@@ -1,5 +1,5 @@
---- Makefile.rules.old 2010-10-01 07:16:16.000000000 +0200
-+++ Makefile.rules 2010-10-01 07:18:04.000000000 +0200
+--- a/Makefile.rules.old 2010-10-01 07:16:16.000000000 +0200
++++ b/Makefile.rules 2010-10-01 07:18:04.000000000 +0200
@@ -88,22 +88,22 @@
profiler: default
diff --git a/games-emulation/gcube/files/gcube-0.4-underlink.patch b/games-emulation/gcube/files/gcube-0.4-underlink.patch
index f1cff91cb15..f4b3d5b6969 100644
--- a/games-emulation/gcube/files/gcube-0.4-underlink.patch
+++ b/games-emulation/gcube/files/gcube-0.4-underlink.patch
@@ -1,5 +1,5 @@
---- Makefile.rules.old 2011-06-10 14:14:08.372105234 +0200
-+++ Makefile.rules 2011-06-10 14:14:18.504746649 +0200
+--- a/Makefile.rules.old 2011-06-10 14:14:08.372105234 +0200
++++ b/Makefile.rules 2011-06-10 14:14:18.504746649 +0200
@@ -1,6 +1,6 @@
SDL_CONFIG=sdl-config
diff --git a/games-emulation/gcube/gcube-0.4-r2.ebuild b/games-emulation/gcube/gcube-0.4-r2.ebuild
new file mode 100644
index 00000000000..6194fc6a210
--- /dev/null
+++ b/games-emulation/gcube/gcube-0.4-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Gamecube emulator"
+HOMEPAGE="http://gcube.exemu.net/"
+SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ virtual/jpeg:0
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}"
+
+src_prepare() {
+ default
+
+ sed -i -e '/^CFLAGS=-g/d' Makefile.rules || die
+
+ eapply "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i -e '/^CC=/d' Makefile || die
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #570504)
+}
+
+src_install() {
+ local x
+
+ dobin gcmap gcube
+ for x in bin2dol isopack thpview tplx ; do
+ newbin ${x} ${PN}-${x}
+ done
+
+ einstalldocs
+}