summaryrefslogtreecommitdiff
path: root/games-fps/etqw-data
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/etqw-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/etqw-data')
-rw-r--r--games-fps/etqw-data/etqw-data-1.0.ebuild64
-rw-r--r--games-fps/etqw-data/metadata.xml9
2 files changed, 73 insertions, 0 deletions
diff --git a/games-fps/etqw-data/etqw-data-1.0.ebuild b/games-fps/etqw-data/etqw-data-1.0.ebuild
new file mode 100644
index 00000000000..55eccee77b6
--- /dev/null
+++ b/games-fps/etqw-data/etqw-data-1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils cdrom games
+
+DESCRIPTION="Enemy Territory: Quake Wars data files"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI=""
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="videos"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/etqw
+
+ cdrom_get_cds Setup/Data/base/DEU:Setup/Data/base/POL:Setup/Data/base
+
+ cd "${CDROM_ROOT}"/Setup/Data/base
+ insinto "${dir}"/base
+ doins pak00{0..4}.pk4 || die "doins pak failed"
+ doins -r megatextures || die "doins megatextures failed"
+
+ case ${CDROM_SET} in
+ 0)
+ doins \
+ zpak_english000.pk4 \
+ DEU/zpak_german000.pk4 \
+ ESP/zpak_spanish000.pk4 \
+ FRA/zpak_french000.pk4 \
+ || die "doins zpak failed"
+ ;;
+ 1)
+ doins \
+ POL/zpak_polish000.pk4 \
+ RUS/zpak_russian000.pk4 \
+ || die "doins zpak failed"
+ ;;
+ 2)
+ doins zpak_english000.pk4 || die "doins zpak failed"
+ ;;
+ esac
+
+ if use videos ; then
+ case ${CDROM_SET} in
+ 0|2)
+ doins -r video || die "doins video failed"
+ ;;
+ esac
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-fps/etqw-bin to play it."
+}
diff --git a/games-fps/etqw-data/metadata.xml b/games-fps/etqw-data/metadata.xml
new file mode 100644
index 00000000000..668ca6c7066
--- /dev/null
+++ b/games-fps/etqw-data/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>tristan@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>