summaryrefslogtreecommitdiff
path: root/games-fps/soldieroffortune-demo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/soldieroffortune-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/soldieroffortune-demo')
-rw-r--r--games-fps/soldieroffortune-demo/Manifest1
-rw-r--r--games-fps/soldieroffortune-demo/metadata.xml8
-rw-r--r--games-fps/soldieroffortune-demo/soldieroffortune-demo-0.57-r1.ebuild67
3 files changed, 76 insertions, 0 deletions
diff --git a/games-fps/soldieroffortune-demo/Manifest b/games-fps/soldieroffortune-demo/Manifest
new file mode 100644
index 00000000000..e9de29ba058
--- /dev/null
+++ b/games-fps/soldieroffortune-demo/Manifest
@@ -0,0 +1 @@
+DIST sof-demo.run 92496052 SHA256 30f671a7e53c9005fea8ef5760e4174e7f7a31114ed5bfd6c8525ceb1bb6d929 SHA512 d285cffe5ed9017409737120d63f1bb14a4ae2f54a83bc2b4d838e82440f43fe430ea63b7765496121633e6fbf40053fe2c5bbda37e48e6da8b18aaa2ff540a6 WHIRLPOOL f1744b789eb7818753e4287e60ec2ad0359697f622fb8a043a4d4ab8cec64f2f77150a81865d87b769ed4650e0bb1588a8364aa471f7b6a0881d8d958442309e
diff --git a/games-fps/soldieroffortune-demo/metadata.xml b/games-fps/soldieroffortune-demo/metadata.xml
new file mode 100644
index 00000000000..6f23b775286
--- /dev/null
+++ b/games-fps/soldieroffortune-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Soldier of Fortune is a first-person 3-D shooter based on the mercenary trade. You play as John, an ex-military mercinary who still has plenty of good friends on the inside. For a wad of bucks, you'll do the job -- no cares, no worries. Just get the gun, play for keeps, get paid, on to the next one -- that's your life. That's what you do. And you're good at it, one of the best even. But now is the time for your biggest challenge ever. This is the demo version of the game.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/soldieroffortune-demo/soldieroffortune-demo-0.57-r1.ebuild b/games-fps/soldieroffortune-demo/soldieroffortune-demo-0.57-r1.ebuild
new file mode 100644
index 00000000000..162f12720b3
--- /dev/null
+++ b/games-fps/soldieroffortune-demo/soldieroffortune-demo-0.57-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PN=${PN/soldieroffortune/sof}
+
+DESCRIPTION="First-person shooter based on the mercenary trade"
+HOMEPAGE="http://www.lokigames.com/products/sof/"
+SRC_URI="mirror://lokigames/loki_demos/${MY_PN}.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="virtual/opengl[abi_x86_32(-)]
+ media-libs/libsdl[X,opengl,sound,abi_x86_32(-)]
+ x11-libs/libXrender[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ media-libs/smpeg[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/* ${dir:1}/base/*so"
+
+src_install() {
+ local demo="data/demos/sof_demo"
+ local exe="sof-bin.x86"
+
+ loki_patch patch.dat data/ || die "loki patch failed"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ # Replace bad library
+ dosym /usr/$(use amd64 && echo lib32 || echo lib)/libSDL.so "${dir}"/libSDL-1.1.so.0
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}" "${dir}"
+
+ # fix buffer overflow
+ sed -i -e '/^exec/i \
+export MESA_EXTENSION_MAX_YEAR=2003 \
+export __GL_ExtensionStringVersion=17700' "${ED}"/usr/games/bin/${PN}
+
+ newicon "${demo}"/launch/box.png ${PN}.png
+ make_desktop_entry ${PN} "Soldier of Fortune (Demo)"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "This game requires OSS sound device /dev/dsp ; make sure the module"
+ ewarn "snd_pcm_oss is loaded and/or built into your kernel or there will be no sound"
+ elog
+ elog "Run '${PN}' to start the game"
+}