summaryrefslogtreecommitdiff
path: root/games-fps/turtlearena
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/turtlearena
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/turtlearena')
-rw-r--r--games-fps/turtlearena/Manifest2
-rw-r--r--games-fps/turtlearena/files/turtlearena-0.6.1-build.patch201
-rw-r--r--games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch17
-rw-r--r--games-fps/turtlearena/metadata.xml10
-rw-r--r--games-fps/turtlearena/turtlearena-0.6.1.ebuild126
5 files changed, 356 insertions, 0 deletions
diff --git a/games-fps/turtlearena/Manifest b/games-fps/turtlearena/Manifest
new file mode 100644
index 00000000000..fa098b2f29e
--- /dev/null
+++ b/games-fps/turtlearena/Manifest
@@ -0,0 +1,2 @@
+DIST turtlearena-0.6.1-0-src.tar.bz2 33355448 SHA256 82a16aabab30b2f77e7541ec9bf0d946207b82cce49d2ef5c1d4e9b11e287c98 SHA512 aa11f66a9ec584226267d34ecd637245a068c3c13ffc49fe0ff1ca16699b3eebf6435255ad68b953fbf02f25c807833830eb76497d53bcff977814e87b804edf WHIRLPOOL 89505581cb80e744657d83e81009461131c9bb898994c51e66b3ebe442de691d871fcb5aa63042d662a537d43dac920831291861db803d01b19067cfd0aaf595
+DIST turtlearena-0.6.1-0.zip 73713016 SHA256 99dfc41e1f00c860f8f0ceb222128cc9c363f20e7bd9e830e47c4c0aceed2a09 SHA512 83c96e572687bbdc6183393d21435806b1032295156c1905d82b300bcb6e00a34cd247731f6958e65f085c4c022fc52195313bc0f44edc7a726f04367483a378 WHIRLPOOL 666582948843469cb051dcec3e3404707b7ee9a8a047bf73b6f2948a0ca4da2ab6446ea228927f8173d6fda0ca8d051738fe58f45824056dcd0a5a4336682268
diff --git a/games-fps/turtlearena/files/turtlearena-0.6.1-build.patch b/games-fps/turtlearena/files/turtlearena-0.6.1-build.patch
new file mode 100644
index 00000000000..76843b08ebf
--- /dev/null
+++ b/games-fps/turtlearena/files/turtlearena-0.6.1-build.patch
@@ -0,0 +1,201 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Apr 27 20:53:37 UTC 2013
+
+* use PKG_CONFIG var (used in cross compiling scripts, does
+ cross compiling even work?)
+* consistently use pkg-config where possible, define proper fallbacks
+* unbundle the unzip.c properly and fix headers
+* make -m* flags depend on CROSS_COMPILING var
+
+--- engine/Makefile
++++ engine/Makefile
+@@ -346,27 +346,31 @@
+
+ bin_path=$(shell which $(1) 2> /dev/null)
+
++PKG_CONFIG ?= pkg-config
++SDL_CONFIG ?= sdl-config
++
+ # We won't need this if we only build the server
+ ifneq ($(BUILD_CLIENT),0)
+- # set PKG_CONFIG_PATH to influence this, e.g.
+- # PKG_CONFIG_PATH=/opt/cross/i386-mingw32msvc/lib/pkgconfig
+- ifneq ($(call bin_path, pkg-config),)
+- CURL_CFLAGS=$(shell pkg-config --silence-errors --cflags libcurl)
+- CURL_LIBS=$(shell pkg-config --silence-errors --libs libcurl)
+- OPENAL_CFLAGS=$(shell pkg-config --silence-errors --cflags openal)
+- OPENAL_LIBS=$(shell pkg-config --silence-errors --libs openal)
+- SDL_CFLAGS=$(shell pkg-config --silence-errors --cflags sdl|sed 's/-Dmain=SDL_main//')
+- SDL_LIBS=$(shell pkg-config --silence-errors --libs sdl)
+- FREETYPE_CFLAGS=$(shell pkg-config --silence-errors --cflags freetype2)
+- endif
+- # Use sdl-config if all else fails
+- ifeq ($(SDL_CFLAGS),)
+- ifneq ($(call bin_path, sdl-config),)
+- SDL_CFLAGS=$(shell sdl-config --cflags)
+- SDL_LIBS=$(shell sdl-config --libs)
+- endif
+- endif
+-endif
++ CURL_CFLAGS=$(shell $(PKG_CONFIG) --cflags libcurl 2>/dev/null)
++ CURL_LIBS=$(shell $(PKG_CONFIG) --libs libcurl 2>/dev/null || echo "-lcurl")
++ OPENAL_CFLAGS=$(shell $(PKG_CONFIG) --cflags openal 2>/dev/null || echo "-I/usr/include/AL")
++ OPENAL_LIBS=$(shell $(PKG_CONFIG) --libs openal 2>/dev/null || echo "-lopenal")
++ SDL_CFLAGS=$(shell $(PKG_CONFIG) --cflags sdl 2>/dev/null || $(SDL_CONFIG) --cflags 2>/dev/null || echo "-I/usr/include/SDL")
++ SDL_LIBS=$(shell $(PKG_CONFIG) --libs sdl 2>/dev/null || $(SDL_CONFIG) --libs 2>/dev/null || echo "-lsdl")
++ FREETYPE_CFLAGS=$(shell $(PKG_CONFIG) --cflags freetype2 2>/dev/null || echo "-I/usr/include/freetype2")
++ FREETYPE_LIBS=$(shell $(PKG_CONFIG) --libs freetype2 2>/dev/null || echo "-lfreetype")
++ OPENGL_LIBS=$(shell $(PKG_CONFIG) --libs gl 2>/dev/null || echo "-lGL")
++ VORIBS_CFLAGS=$(shell $(PKG_CONFIG) --cflags vorbis vorbisfile 2>/dev/null)
++ VORBIS_LIBS=$(shell $(PKG_CONFIG) --libs vorbis vorbisfile 2>/dev/null || echo "-lvorbis -lvorbisfile -logg")
++ THEORA_CFLAGS=$(shell $(PKG_CONFIG) --cflags theora 2>/dev/null)
++ THEORA_LIBS=$(shell $(PKG_CONFIG) --libs theora 2>/dev/null || echo "-ltheora")
++ SPEEX_CFLAGS=$(shell $(PKG_CONFIG) --cflags speex speexdsp 2>/dev/null)
++ SPEEX_LIBS=$(shell $(PKG_CONFIG) --libs speex speexdsp 2>/dev/null || echo "-lspeex")
++endif
++
++# common deps
++ZLIB_CFLAGS=$(shell $(PKG_CONFIG) --cflags zlib minizip 2>/dev/null || echo "-I/usr/include/minizip")
++ZLIB_LIBS=$(shell $(PKG_CONFIG) --libs zlib minizip 2>/dev/null || echo "-lz -lminizip")
+
+ ifneq ($(BUILD_FINAL),1)
+ # Add svn version info
+@@ -421,7 +425,7 @@
+ endif
+
+ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
+- -pipe -DUSE_ICON
++ -DUSE_ICON
+ CLIENT_CFLAGS += $(SDL_CFLAGS)
+
+ OPTIMIZEVM = -O3 -funroll-loops -fomit-frame-pointer
+@@ -470,25 +474,29 @@
+ LIBS=-ldl -lm
+
+ CLIENT_LIBS=$(SDL_LIBS)
+- RENDERER_LIBS = $(SDL_LIBS) -lGL
++ RENDERER_LIBS = $(SDL_LIBS) $(OPENGL_LIBS)
+
+ ifeq ($(USE_OPENAL),1)
+ ifneq ($(USE_OPENAL_DLOPEN),1)
+- CLIENT_LIBS += -lopenal
+- endif
++ CLIENT_CFLAGS += $(OPENAL_CFLAGS)
++ CLIENT_LIBS += $(OPENAL_LIBS)
++ endif
+ endif
+
+ ifeq ($(USE_CURL),1)
+ ifneq ($(USE_CURL_DLOPEN),1)
+- CLIENT_LIBS += -lcurl
++ CLIENT_CFLAGS += $(CURL_CFLAGS)
++ CLIENT_LIBS += $(CURL_LIBS)
+ endif
+ endif
+
+ ifeq ($(USE_CODEC_VORBIS),1)
+- CLIENT_LIBS += -lvorbisfile -lvorbis -logg
++ CLIENT_CFLAGS += $(VORBIS_CFLAGS)
++ CLIENT_LIBS += $(VORBIS_LIBS)
+ endif
+ ifeq ($(USE_CODEC_THEORA),1)
+- CLIENT_LIBS += -ltheora
++ CLIENT_CFLAGS += $(THEORA_CFLAGS)
++ CLIENT_LIBS += $(THEORA_LIBS)
+ endif
+
+ ifeq ($(USE_MUMBLE),1)
+@@ -503,14 +511,18 @@
+ BASE_CFLAGS += $(FREETYPE_CFLAGS)
+ endif
+
++ # cross-compiling tweaks
+ ifeq ($(ARCH),i386)
+- # linux32 make ...
+- BASE_CFLAGS += -m32
+- else
+- ifeq ($(ARCH),ppc64)
+- BASE_CFLAGS += -m64
++ ifeq ($(CROSS_COMPILING),1)
++ BASE_CFLAGS += -m32
++ endif
+ endif
++ ifeq ($(ARCH),amd64)
++ ifeq ($(CROSS_COMPILING),1)
++ BASE_CFLAGS += -m64
++ endif
+ endif
++
+ else # ifeq Linux
+
+ #############################################################################
+@@ -1155,7 +1167,8 @@
+ ifeq ($(USE_INTERNAL_SPEEX),1)
+ CLIENT_CFLAGS += -DFLOATING_POINT -DUSE_ALLOCA -I$(SPEEXDIR)/include
+ else
+- CLIENT_LIBS += -lspeex -lspeexdsp
++ CLIENT_CFLAGS += $(SPEEX_CFLAGS)
++ CLIENT_LIBS += $(SPEEX_LIBS)
+ endif
+ endif
+
+@@ -1163,7 +1176,8 @@
+ BASE_CFLAGS += -DNO_GZIP
+ BASE_CFLAGS += -I$(ZDIR)
+ else
+- LIBS += -lz
++ BASE_CFLAGS += $(ZLIB_CFLAGS)
++ LIBS += $(ZLIB_LIBS)
+ endif
+
+ ifeq ($(USE_INTERNAL_JPEG),1)
+@@ -1177,7 +1191,8 @@
+ BASE_CFLAGS += -I$(FTDIR)/include \
+ -DFT2_BUILD_LIBRARY
+ else
+- RENDERER_LIBS += -lfreetype
++ BASE_CFLAGS += $(FREETYPE_CFLAGS)
++ RENDERER_LIBS += $(FREETYPE_LIBS)
+ endif
+
+ ifeq ("$(CC)", $(findstring "$(CC)", "clang" "clang++"))
+@@ -1650,8 +1665,6 @@
+ $(B)/client/q_math.o \
+ $(B)/client/q_shared.o \
+ \
+- $(B)/client/unzip.o \
+- $(B)/client/ioapi.o \
+ $(B)/client/puff.o \
+ $(B)/client/vm.o \
+ $(B)/client/vm_interpreted.o \
+@@ -2076,8 +2089,6 @@
+ $(B)/ded/q_math.o \
+ $(B)/ded/q_shared.o \
+ \
+- $(B)/ded/unzip.o \
+- $(B)/ded/ioapi.o \
+ $(B)/ded/vm.o \
+ $(B)/ded/vm_interpreted.o \
+ \
+--- engine/code/qcommon/files.c
++++ engine/code/qcommon/files.c
+@@ -31,7 +31,7 @@ Foundation, Inc., 51 Franklin St, Fifth
+
+ #include "q_shared.h"
+ #include "qcommon.h"
+-#include "unzip.h"
++#include <minizip/unzip.h>
+
+ /*
+ =============================================================================
+--- engine/code/renderer/tr_public.h
++++ engine/code/renderer/tr_public.h
+@@ -25,7 +25,7 @@
+ #include "tr_types.h"
+
+ #ifdef IOQ3ZTM // PNG_SCREENSHOTS
+-#include "../zlib/zlib.h"
++#include <zlib.h>
+ #endif
+
+ #define REF_API_VERSION 8
diff --git a/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch b/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch
new file mode 100644
index 00000000000..563a9d0d704
--- /dev/null
+++ b/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/show_bug.cgi?id=479822#c3
+http://github.com/ioquake/ioq3/commit/ab4c602374caa0f520b3a0801d384a73e29e0bc7
+
+--- engine/code/renderer/tr_font.c
++++ engine/code/renderer/tr_font.c
+@@ -47,10 +47,10 @@
+ #include "../qcommon/qcommon.h"
+
+ #include <ft2build.h>
++#include FT_FREETYPE_H
+ #include FT_ERRORS_H
+ #include FT_SYSTEM_H
+ #include FT_IMAGE_H
+-#include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+
+ #define _FLOOR(x) ((x) & -64)
diff --git a/games-fps/turtlearena/metadata.xml b/games-fps/turtlearena/metadata.xml
new file mode 100644
index 00000000000..4b3e94fddae
--- /dev/null
+++ b/games-fps/turtlearena/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="mumble">Adds player-location (positional audio) support to VoIP</flag>
+ <flag name="server">Build server target</flag>
+ <flag name="voice">Adds VoIP support</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-fps/turtlearena/turtlearena-0.6.1.ebuild b/games-fps/turtlearena/turtlearena-0.6.1.ebuild
new file mode 100644
index 00000000000..7f670c83721
--- /dev/null
+++ b/games-fps/turtlearena/turtlearena-0.6.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+MY_P=${PN/-/}-${PV}
+
+DESCRIPTION="A turtle featuring free and open source third-person action game (ioq3 engine)"
+HOMEPAGE="http://ztm.x10host.com/ta/index.htm"
+SRC_URI="http://turtlearena.googlecode.com/files/${MY_P}-0-src.tar.bz2
+ http://turtlearena.googlecode.com/files/${MY_P}-0.zip"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0 mplus-fonts lcc"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+curl debug dedicated mumble openal server theora voice vorbis"
+
+RDEPEND="
+ sys-libs/zlib[minizip]
+ !dedicated? (
+ media-libs/freetype:2
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ virtual/jpeg:0
+ virtual/opengl
+ curl? ( net-misc/curl )
+ openal? ( media-libs/openal )
+ theora? ( media-libs/libtheora )
+ voice? (
+ media-libs/speex
+ mumble? ( media-sound/mumble )
+ )
+ vorbis? ( media-libs/libvorbis )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}-0-src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freetype.patch
+
+ sed -i \
+ -e 's:JPEG_LIB_VERSION < 80:JPEG_LIB_VERSION < 62:' \
+ engine/code/renderer/tr_image_jpg.c || die #479822
+
+ rm -r engine/code/{AL,libcurl,libogg,libspeex,libtheora,libvorbis,SDL12,zlib} \
+ engine/code/freetype* engine/code/jpeg-* \
+ engine/code/qcommon/unzip.{c,h} || die
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ nobuildit() { use $1 && echo 0 || echo 1 ; }
+
+ myarch=$(usex amd64 "x86_64" "x86")
+ emake -C engine \
+ Q="" \
+ ARCH=${myarch} \
+ CROSS_COMPILING=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_CLIENT=$(nobuildit dedicated) \
+ BUILD_SERVER=$(usex dedicated "1" "$(buildit server)") \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ GENERATE_DEPENDENCIES=0 \
+ OPTIMIZEVM="" \
+ OPTIMIZE="" \
+ DEBUG_CFLAGS="" \
+ USE_MUMBLE=$(buildit mumble) \
+ USE_VOIP=$(buildit voice) \
+ USE_INTERNAL_SPEEX=0 \
+ USE_INTERNAL_OGG=0 \
+ USE_INTERNAL_ZLIB=0 \
+ USE_INTERNAL_JPEG=0 \
+ USE_INTERNAL_FREETYPE=0 \
+ USE_CODEC_VORBIS=$(buildit vorbis) \
+ USE_INTERNAL_VORBIS=0 \
+ USE_CODEC_THEORA=$(buildit theora) \
+ USE_OPENAL=$(buildit openal) \
+ USE_OPENAL_DLOPEN=0 \
+ USE_CURL=$(buildit curl) \
+ USE_CURL_DLOPEN=0 \
+ USE_LOCAL_HEADERS=0 \
+ $(usex debug "debug" "release")
+}
+
+src_install() {
+ dodoc engine/{ChangeLog,BUGS,TODO}
+ use voice && dodoc engine/voip-readme.txt
+
+ if ! use dedicated ; then
+ newgamesbin engine/build/$(usex debug "debug" "release")-linux-${myarch}/turtlearena.${myarch} turtlearena
+ newicon -s scalable engine/misc/quake3-tango.svg ${PN}.svg
+ newicon -s 256 engine/misc/quake3-tango.png ${PN}.png
+ make_desktop_entry ${PN}
+ fi
+
+ if use dedicated || use server ; then
+ newgamesbin engine/build/$(usex debug "debug" "release")-linux-${myarch}/turtlearena-server.${myarch} turtlearena-server
+ fi
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r "${WORKDIR}"/${MY_P}-0/base
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ use dedicated || gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use dedicated || gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use dedicated || gnome2_icon_cache_update
+}