summaryrefslogtreecommitdiff
path: root/games-fps/ut2003-demo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2003-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2003-demo')
-rw-r--r--games-fps/ut2003-demo/Manifest3
-rw-r--r--games-fps/ut2003-demo/files/benchmark37
-rw-r--r--games-fps/ut2003-demo/files/results.py61
-rw-r--r--games-fps/ut2003-demo/files/results.sh79
-rw-r--r--games-fps/ut2003-demo/files/ut2003-demo30
-rw-r--r--games-fps/ut2003-demo/metadata.xml8
-rw-r--r--games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild128
7 files changed, 346 insertions, 0 deletions
diff --git a/games-fps/ut2003-demo/Manifest b/games-fps/ut2003-demo/Manifest
new file mode 100644
index 00000000000..6bd01130353
--- /dev/null
+++ b/games-fps/ut2003-demo/Manifest
@@ -0,0 +1,3 @@
+DIST UT2003CrashFix.zip 2764 SHA256 df1a6fdf81f388486b20abf301ef86fb72b0b12d96bec789d7cb7103da579813 SHA512 24fdaac873b08a0860c23f66b9bd93922fc4f64486adbe9bfefeb340f9d9374778b5e7bacd0e12cc79d819fb340e007ab2a7f1f45c9e4f27ab3ab6b11033d444 WHIRLPOOL ddea25bf472d5ca7f9c9dca1346820045504c10be90e914cd0c000a04c48ad4765e4b283a35cd91c2cb9f4cd8e1d2cabac660c2bfeccff05ecc42b1379242ff5
+DIST ut2003-demo-misc.tar.bz2 31851 SHA256 215a82cc4768c93a979771b1abf6250bcbe36be466d119df41acd041ac189ced SHA512 9a1e154aac7a8ccd043135e2a617a19203f6942e8e152d06ec8ed1e6877118cfb3ddbeab7ec2617670e26f13c0e394b8b8dbc747688b8b0b244a8c404f33d7f0 WHIRLPOOL 5597c0c4444de2e50cf87c23cbe4c863258da761645d41f4693a7aa774bb68cb8f8a4bf5c8b3b4e8a670f7c8ce616728d1223dd18b20c59fde60462e413db9f0
+DIST ut2003demo-lnx-2206.sh.bin 137253079 SHA256 e7664d20d6364e4f151199e3f7e111888abeb63e1d93146c88d932c6a2b94173 SHA512 8018d58999010c17198185838e42f7cbda0f55476f1e6065b4b2957db3652fe9c1af39ba65451565f54d41507413f4e0b1edf2678c9cc7c221f2ca278ec655be WHIRLPOOL b4bd520a60385d803d7d44247a48ca80a1116d9a3b9ea9f1dcdf2d1114bcc42e8705f00e228fe50fedc95d1d1c130ceaceb0c54210f51fb03da0672d13c35758
diff --git a/games-fps/ut2003-demo/files/benchmark b/games-fps/ut2003-demo/files/benchmark
new file mode 100644
index 00000000000..2047897da9a
--- /dev/null
+++ b/games-fps/ut2003-demo/files/benchmark
@@ -0,0 +1,37 @@
+#!/bin/sh
+# Originally from linuxforen.de
+# Modified by phoen][x <phoenix@gentoo.org>, Sep/19/2002
+# Modifications, enhancements or bugs? Mail me.
+
+# Tweaks by Daniel Robbins <drobbins@gentoo.org> 25 Feb 2003
+
+STUFF=GAMES_PREFIX_OPT/ut2003-demo/Benchmark/Stuff
+MYPATH=${HOME}/.ut2003/Benchmark
+TEMPLOG=${MYPATH}/benchmark.log
+LOG=${MYPATH}/bench.log
+
+[ -d ${MYPATH} ] || mkdir -p ${MYPATH}
+
+rm -f ${TEMPLOG} ${LOG}
+touch ${TEMPLOG} ${LOG}
+
+date > $LOG
+
+echo ">> Starting benchmark"
+cd GAMES_PREFIX_OPT//ut2003-demo/System
+for BENCH in GAMES_PREFIX_OPT//ut2003-demo/Benchmark/*-*.sh
+do
+ echo "Running ${BENCH} with MinDetail"
+ ${BENCH} -ini=${STUFF}/MinDetail.ini -userini=${STUFF}/MinDetailUser.ini &> /dev/null
+ echo -n "${BENCH} / MinDetail / " >> ${LOG}
+ cat ${TEMPLOG} | tail -n1 >> ${LOG}
+
+ echo "Running ${BENCH} with MaxDetail"
+ ${BENCH} -ini=${STUFF}/MaxDetail.ini -userini=${STUFF}/MaxDetailUser.ini &> /dev/null
+ echo -n "${BENCH} / MaxDetail / " >> ${LOG}
+ cat ${TEMPLOG} | tail -n1 >> ${LOG}
+done
+
+echo ">> Benchmark complete"
+GAMES_PREFIX_OPT/ut2003-demo/Benchmark/results.sh
+echo ">> Use 'ut2003-demo --results' to show these results again (without benchmarking)"
diff --git a/games-fps/ut2003-demo/files/results.py b/games-fps/ut2003-demo/files/results.py
new file mode 100644
index 00000000000..3e626239129
--- /dev/null
+++ b/games-fps/ut2003-demo/files/results.py
@@ -0,0 +1,61 @@
+#!/usr/bin/env python
+# Written by phoen][x <phoenix@gentoo.org>, Sep/19/2002
+# Modifications, enhancements or bugs? Mail me.
+import sys
+
+def help():
+ print "Usage"
+ print " results.py logfile"
+
+def stats(data,mode):
+ print(
+""">> Score for %s
+MinDetail: %f (%d tests)
+MaxDetail: %f (%d tests)
+Average : %f (%d tests)
+""" % (mode,data[0][0]/data[0][1],data[0][1],data[1][0]/data[1][1],data[1][1],
+ (data[0][0]+data[1][0])/(data[0][1]+data[1][1]),data[0][1]+data[1][1]))
+
+args = sys.argv[1:]
+if "--help" in args:
+ help()
+else:
+ if len(args):
+ file = args[0]
+ else:
+ import user
+ file = "%s/.ut2003/Benchmark/bench.log" % user.home
+ try:
+ myfile = open(file)
+ date = myfile.readline()
+ print(">> Results of the UT2003-demo benchmark")
+ print(">> created on %s" % date)
+
+ botmatch = ([0,0],[0,0])
+ flyby = ([0,0],[0,0])
+
+ for line in myfile.readlines():
+ results = line.split()
+ category = results[0].split("-")[0]
+
+ if results[2] == "MinDetail":
+ detail = 0
+ elif results[2] == "MaxDetail":
+ detail = 1
+ else:
+ assert "Neither MinDetail nor MaxDetail?"
+
+ if category == "botmatch":
+ botmatch[detail][0] += float(results[13])
+ botmatch[detail][1] += 1
+ elif category == "flyby":
+ flyby[detail][0] += float(results[13])
+ flyby[detail][1] += 1
+ else:
+ assert "Neither botmach nor flyby?"
+
+ stats(botmatch,"Botmatch")
+ stats(flyby,"FlyBy")
+
+ except IOError:
+ print("Unable to open file %s" % file)
diff --git a/games-fps/ut2003-demo/files/results.sh b/games-fps/ut2003-demo/files/results.sh
new file mode 100644
index 00000000000..a74cf909c9a
--- /dev/null
+++ b/games-fps/ut2003-demo/files/results.sh
@@ -0,0 +1,79 @@
+#!/bin/bash
+# Written by phoen][x <phoenix@gentoo.org>, Sep/21/2002
+# Modifications, enhancements or bugs? Contact games@gentoo.org
+
+[[ -z "${1}" ]] \
+ && FILE="${HOME}/.ut2003/Benchmark/bench.log" \
+ || FILE="${1}"
+
+CURLINE=0
+
+BM_MIN_SCORE=0
+BM_MIN_COUNT=0
+BM_MAX_SCORE=0
+BM_MAX_COUNT=0
+
+FB_MIN_SCORE=0
+FB_MIN_COUNT=0
+FB_MAX_SCORE=0
+FB_MAX_COUNT=0
+
+while read LINE ; do
+ CURLINE=`expr $CURLINE + 1`
+ if [[ ${CURLINE} -eq 1 ]] ; then
+ echo ">> Results of the UT2003-demo benchmark"
+ echo ">> Created on ${LINE}"
+ continue
+ fi
+
+ set -- ${LINE}
+ TYPE=$(echo $(basename ${1}) | cut -d- -f1)
+ DETAIL=${3}
+ SCORE=${14}
+
+ case ${TYPE} in
+ "botmatch")
+ case ${DETAIL} in
+ "MinDetail")
+ BM_MIN_SCORE=`echo ${BM_MIN_SCORE} + ${SCORE} | bc`
+ BM_MIN_COUNT=`expr ${BM_MIN_COUNT} + 1`
+ ;;
+ "MaxDetail")
+ BM_MAX_SCORE=`echo ${BM_MAX_SCORE} + ${SCORE} | bc`
+ BM_MAX_COUNT=`expr ${BM_MAX_COUNT} + 1`
+ ;;
+ esac
+ ;;
+ "flyby")
+ case ${DETAIL} in
+ "MinDetail")
+ FB_MIN_SCORE=`echo ${FB_MIN_SCORE} + ${SCORE} | bc`
+ FB_MIN_COUNT=`expr ${FB_MIN_COUNT} + 1`
+ ;;
+ "MaxDetail")
+ FB_MAX_SCORE=`echo ${FB_MAX_SCORE} + ${SCORE} | bc`
+ FB_MAX_COUNT=`expr ${FB_MAX_COUNT} + 1`
+ ;;
+ esac
+ ;;
+ esac
+done < ${FILE}
+
+BM_MIN_AVG=`echo "scale=6; ${BM_MIN_SCORE} / ${BM_MIN_COUNT}" | bc`
+BM_MAX_AVG=`echo "scale=6; ${BM_MAX_SCORE} / ${BM_MAX_COUNT}" | bc`
+BM_ALL_AVG=`echo "scale=6; (${BM_MIN_SCORE} + ${BM_MAX_SCORE}) / (${BM_MIN_COUNT} + ${BM_MAX_COUNT})" | bc`
+
+FB_MIN_AVG=`echo "scale=6; ${FB_MIN_SCORE} / ${FB_MIN_COUNT}" | bc`
+FB_MAX_AVG=`echo "scale=6; ${FB_MAX_SCORE} / ${FB_MAX_COUNT}" | bc`
+FB_ALL_AVG=`echo "scale=6; (${FB_MIN_SCORE} + ${FB_MAX_SCORE}) / (${FB_MIN_COUNT} + ${FB_MAX_COUNT})" | bc`
+
+echo "
+>> Score for Botmatch
+MinDetail: ${BM_MIN_AVG} (${BM_MIN_COUNT} tests)
+MaxDetail: ${BM_MAX_AVG} (${BM_MAX_COUNT} tests)
+Average : ${BM_ALL_AVG} (`expr ${BM_MIN_COUNT} + ${BM_MAX_COUNT}` tests)
+
+>> Score for FlyBy
+MinDetail: ${FB_MIN_AVG} (${FB_MIN_COUNT} tests)
+MaxDetail: ${FB_MAX_AVG} (${FB_MAX_COUNT} tests)
+Average : ${FB_ALL_AVG} (`expr ${FB_MIN_COUNT} + ${FB_MAX_COUNT}` tests)"
diff --git a/games-fps/ut2003-demo/files/ut2003-demo b/games-fps/ut2003-demo/files/ut2003-demo
new file mode 100644
index 00000000000..56d7e10e6a7
--- /dev/null
+++ b/games-fps/ut2003-demo/files/ut2003-demo
@@ -0,0 +1,30 @@
+#!/bin/bash
+# Written by phoen][x <phoenix@gentoo.org>, Sep/19/2002
+# Modifications, enhancements or bugs? Mail me.
+
+INSTALL="GAMES_PREFIX_OPT//ut2003-demo"
+
+case ${1} in
+ "--results")
+ pushd ${INSTALL}/Benchmark &> /dev/null
+ ./results.sh
+ popd &> /dev/null
+ ;;
+ "--bench")
+ pushd ${INSTALL}/Benchmark &> /dev/null
+ ./benchmark
+ popd &> /dev/null
+ ;;
+ "--help")
+ echo "Usage:"
+ echo " ut2003-demo [--bench] || [--results]"
+ echo " Optional parameters, only one at a time."
+ echo " --bench : starts ut2003-demo in benchmark mode"
+ echo " --results : outputs the results of your last benchmark"
+ ;;
+ *)
+ pushd ${INSTALL} &> /dev/null
+ ./ut2003_demo
+ popd &> /dev/null
+ ;;
+esac
diff --git a/games-fps/ut2003-demo/metadata.xml b/games-fps/ut2003-demo/metadata.xml
new file mode 100644
index 00000000000..d577ee65eb6
--- /dev/null
+++ b/games-fps/ut2003-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Unreal Tounament 2003 is a first-person 3-D shooter and sequel to the 1999 Game of the Year, Unreal Tournament. The game was ported to Linux by Ryan "icculus" Gordon under contract from Epic Games and the Linux installer was released in the retail box. This game is a playable demo of the full commercial version.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild b/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild
new file mode 100644
index 00000000000..f5f6748086a
--- /dev/null
+++ b/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils unpacker games
+
+DESCRIPTION="Demo for the sequel to the 1999 Game of the Year multi-player first-person shooter"
+HOMEPAGE="http://www.ut2003.com/"
+SRC_URI="http://unreal.epicgames.com/linux/ut2003/ut2003demo-lnx-${PV}.sh.bin
+ http://download.factoryunreal.com/mirror/UT2003CrashFix.zip
+ http://dev.gentoo.org/~wolf31o2/sources/${PN}/${PN}-misc.tar.bz2"
+
+LICENSE="ut2003-demo"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ sys-devel/bc
+ virtual/libstdc++:3.3
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself "${DISTDIR}"/ut2003demo-lnx-${PV}.sh.bin \
+ || die "unpacking demo"
+ unzip "${DISTDIR}"/UT2003CrashFix.zip \
+ || die "unpacking crash-fix"
+ cd "${S}"
+ unpack ./setupstuff.tar.gz || die
+ unpack ./ut2003lnx_demo.tar.bz2 || die
+ unpack ${PN}-misc.tar.bz2 || die
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+ dodir "${dir}"
+
+ local i
+ for i in Animations Benchmark Help KarmaData Maps Music Sounds \
+ StaticMeshes System Textures Web extras
+ do
+ dodir "${dir}"/${i}
+ cp -pPR "${S}"/${i}/* "${Ddir}"/${i}
+ done
+
+ # Fix the benchmark configurations to use SDL rather than the Windows driver
+ local f
+ for f in MaxDetail.ini MinDetail.ini
+ do
+ sed -i \
+ -e 's/RenderDevice=D3DDrv.D3DRenderDevice/\;RenderDevice=D3DDrv.D3DRenderDevice/' \
+ -e 's/ViewportManager=WinDrv.WindowsClient/\;ViewportManager=WinDrv.WindowsClient/' \
+ -e 's/\;RenderDevice=OpenGLDrv.OpenGLRenderDevice/RenderDevice=OpenGLDrv.OpenGLRenderDevice/' \
+ -e 's/\;ViewportManager=SDLDrv.SDLClient/ViewportManager=SDLDrv.SDLClient/' \
+ "${Ddir}"/Benchmark/Stuff/${f} \
+ || die "sed ${dir}/Benchmark/Stuff/${f} failed"
+ done
+
+ # Have the benchmarks run the nifty wrapper script rather than
+ # ../System/ut2003-bin directly
+ for f in "${Ddir}"/Benchmark/*-*.sh ; do
+ sed -i \
+ -e 's:\.\./System/ut2003-bin:../ut2003_demo:' "${f}" \
+ || die "sed ${f} failed"
+ done
+
+ # Wrapper and benchmark-scripts
+ dogamesbin "${FILESDIR}"/ut2003-demo || die "dogamesbin failed"
+ exeinto "${dir}"/Benchmark
+ doexe "${FILESDIR}/"{benchmark,results.sh}
+ sed -i -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" \
+ "${ED}/${GAMES_BINDIR}/${PN}" "${ED}/${dir}"/Benchmark/benchmark \
+ || die "sed GAMES_PREFIX_OPT"
+
+ # Here we apply DrSiN's crash patch
+ cp "${S}"/CrashFix/System/crashfix.u "${Ddir}"/System \
+ || die "CrashFix failed"
+
+ed "${Ddir}"/System/Default.ini >/dev/null 2>&1 <<EOT
+$
+?Engine.GameInfo?
+a
+AccessControlClass=crashfix.iaccesscontrolini
+.
+w
+q
+EOT
+
+ exeinto "${dir}"
+ insinto "${dir}"
+ doins DemoLicense.int README.linux
+ doexe ucc ut2003_demo
+ newicon Unreal.xpm ut2003-demo.xpm
+ make_desktop_entry ut2003-demo "Unreal Tournament 2003 (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You can run benchmarks by typing 'ut2003-demo --bench' (MinDetail seems"
+ elog "to not be working for some unknown reason :/)"
+ echo
+ elog "Read ${dir}/README.linux for instructions on how to run a"
+ elog "dedicated server."
+ echo
+ ewarn "If you are not installing for the first time and you plan on running"
+ ewarn "a server, you will probably need to edit your"
+ ewarn "~/.ut2003demo/System/UT2003.ini file and add a line that says"
+ ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
+ ewarn "[Engine.GameInfo] section to close a security issue."
+ echo
+ elog "To play the demo run:"
+ elog " ut2003-demo"
+ echo
+}