summaryrefslogtreecommitdiff
path: root/games-fps/xonotic
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 15:09:26 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 19:39:26 -0500
commit430ae049c98b52999c2263c249a29caab3af193c (patch)
tree050702ff39fc6c88c85f4f1d4e019217d4cd9eb9 /games-fps/xonotic
parent817fa3898eff9e86c0b3c8984df297ebde78ae0c (diff)
downloadgentoo-430ae049c98b52999c2263c249a29caab3af193c.tar.gz
gentoo-430ae049c98b52999c2263c249a29caab3af193c.tar.xz
clean old
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/Manifest1
-rw-r--r--games-fps/xonotic/xonotic-0.8.0.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index 5dcf3afea85..79b609af77e 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,2 +1 @@
-DIST xonotic-0.8.0.zip 999151784 SHA256 0a87c808827a8b234f2324b468ecb643aa48a6fd43322a29e616610dca316370 SHA512 49ae728f9269ff642540ec8a7ab52fb9624f3d05cab2b07c5a1aa87d4103d3acffad4e2a1f266d3976cd457e742a3a7a1fd4a774cbcde934b123ae3baa747332 WHIRLPOOL 85e747bb2fb5ad5394896a08055028439a2f1a154305d7101be8cb5a44a1e50bdb9b36fac526ff12c9db93915a8b5253a40cf7dc654271f20240e1f92e0b4cb5
DIST xonotic-0.8.1.zip 984854761 SHA256 be8bcc41e2993a2f26d4d04c65a7eab810443bd98b11b45e482ffdbbf284c46f SHA512 adfce546257bdc7cfebe94f53eaa9cc9b19eaa546c6405e31ed6af080e3948732c960a024126202e5853cb98b955daadeeb5a96c602a6d4d83e284d3540214a4 WHIRLPOOL 4359263c98352a8b5d169147d9bfecb4258628f212d9a965f0d1577d0a8b2469648ae1ce21d8dc0ff622d20e126ea52e1464363f69fcf514991aefad71c1bee7
diff --git a/games-fps/xonotic/xonotic-0.8.0.ebuild b/games-fps/xonotic/xonotic-0.8.0.ebuild
deleted file mode 100644
index 4fa4fedf5e3..00000000000
--- a/games-fps/xonotic/xonotic-0.8.0.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils check-reqs games
-
-# Switch to ^ when we switch to EAPI=6.
-MY_PN="X${PN:1}"
-DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
-HOMEPAGE="http://www.xonotic.org/"
-SRC_URI="http://dl.xonotic.org/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="alsa debug dedicated doc ode sdl"
-
-UIRDEPEND="
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/libmodplug
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXpm
- x11-libs/libXext
- x11-libs/libXdmcp
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- virtual/opengl
- media-libs/freetype:2
- alsa? ( media-libs/alsa-lib )
- ode? ( dev-games/ode[double-precision] )
- sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
-UIDEPEND="
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto"
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg
- media-libs/libpng
- net-misc/curl
- ~dev-libs/d0_blind_id-0.5
- !dedicated? ( ${UIRDEPEND} )"
-DEPEND="${RDEPEND}
- !dedicated? ( ${UIDEPEND} )"
-
-CHECKREQS_DISK_BUILD="1200M"
-CHECKREQS_DISK_USR="950M"
-
-S=${WORKDIR}/${MY_PN}
-
-pkg_pretend() {
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- check-reqs_pkg_setup
- games_pkg_setup
-}
-
-src_prepare() {
- sed -i \
- -e "/^EXE_/s:darkplaces:${PN}:" \
- -e "s:-O3:${CFLAGS}:" \
- -e "/-lm/s:$: ${LDFLAGS}:" \
- -e '/^STRIP/s/strip/true/' \
- source/darkplaces/makefile.inc || die
-
- if ! use alsa; then
- sed -i \
- -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
- source/darkplaces/makefile || die
- fi
-}
-
-src_compile() {
- local t="$(use debug && echo debug || echo release)"
- local i
-
- # use a for-loop wrt bug 473352
- for i in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") ; do
- emake \
- -C source/darkplaces \
- DP_LINK_TO_LIBJPEG=1 \
- DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- ${i}
- done
-}
-
-src_install() {
- if ! use dedicated; then
- dogamesbin source/darkplaces/${PN}-glx
- newicon misc/logos/${PN}_icon.svg ${PN}.svg
- make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
-
- if use sdl; then
- dogamesbin source/darkplaces/${PN}-sdl
- make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
- fi
- fi
- dogamesbin source/darkplaces/${PN}-dedicated
-
- dodoc Docs/*.txt
- use doc && dohtml -r Docs
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r key_0.d0pk server data
- prepgamesdirs
-
- elog "If you are using opensource drivers you should consider installing: "
- elog " media-libs/libtxc_dxtn"
-}