summaryrefslogtreecommitdiff
path: root/games-fps/yamagi-quake2
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2018-07-21 01:24:09 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-07-21 23:56:00 +0200
commit0e19dc2e1726a8030992ead1dafdacfcdbca0cd2 (patch)
treeee4956674b25aee68a56641b3fa730032e4d8394 /games-fps/yamagi-quake2
parenta032c2d8c8da689843f1e1a6f56accb28ca101c9 (diff)
downloadgentoo-0e19dc2e1726a8030992ead1dafdacfcdbca0cd2.tar.gz
gentoo-0e19dc2e1726a8030992ead1dafdacfcdbca0cd2.tar.xz
games-fps/yamagi-quake2: optionally build software renderer.
Diffstat (limited to 'games-fps/yamagi-quake2')
-rw-r--r--games-fps/yamagi-quake2/metadata.xml1
-rw-r--r--games-fps/yamagi-quake2/yamagi-quake2-7.21.ebuild15
2 files changed, 11 insertions, 5 deletions
diff --git a/games-fps/yamagi-quake2/metadata.xml b/games-fps/yamagi-quake2/metadata.xml
index c573477de06..d965a72ff59 100644
--- a/games-fps/yamagi-quake2/metadata.xml
+++ b/games-fps/yamagi-quake2/metadata.xml
@@ -16,6 +16,7 @@
<flag name="client">Build client</flag>
<flag name="ctf">Build support for the 'Capture The Flag' addon</flag>
<flag name="rogue">Build support for the 'Ground Zero' Mission Pack</flag>
+ <flag name="softrender">Build software renderer</flag>
<flag name="xatrix">Build support for the 'The Reckoning' Mission Pack</flag>
</use>
</pkgmetadata>
diff --git a/games-fps/yamagi-quake2/yamagi-quake2-7.21.ebuild b/games-fps/yamagi-quake2/yamagi-quake2-7.21.ebuild
index 779346e191f..70d72875290 100644
--- a/games-fps/yamagi-quake2/yamagi-quake2-7.21.ebuild
+++ b/games-fps/yamagi-quake2/yamagi-quake2-7.21.ebuild
@@ -19,19 +19,22 @@ SRC_URI="https://deponie.yamagi.org/quake2/quake2-${PV}.tar.xz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+client ctf dedicated ogg openal rogue xatrix"
-REQUIRED_USE="|| ( client dedicated )"
+IUSE="+client ctf dedicated ogg openal +opengl rogue softrender xatrix"
+REQUIRED_USE="|| ( client dedicated ) client? ( || ( opengl softrender ) )"
RDEPEND="sys-libs/zlib:0=
client? (
- media-libs/libsdl2[opengl,video]
- virtual/opengl
+ media-libs/libsdl2[video]
ogg? (
media-libs/libogg
media-libs/libvorbis
)
openal? ( media-libs/openal )
!openal? ( media-libs/libsdl2[sound] )
+ opengl? (
+ media-libs/libsdl2[opengl]
+ virtual/opengl
+ )
)
"
@@ -73,8 +76,10 @@ src_prepare() {
src_compile() {
local targets=( game )
- use client && targets+=( client ref_gl1 ref_gl3 )
+ use client && targets+=( client )
use dedicated && targets+=( server )
+ use opengl && targets+=( ref_gl1 ref_gl3 )
+ use softrender && targets+=( ref_soft )
mymake config
mymake "${targets[@]}"