summaryrefslogtreecommitdiff
path: root/games-kids
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-06 17:17:12 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-06 17:21:08 -0400
commitfffbb9b328e5cc47b3a0c24a71474a41e74e8280 (patch)
treee38da995b9f4dd5380d29bca25318de4248a2a0e /games-kids
parent5b4d63fd3807d122c1f4dc55bada8a989bc85793 (diff)
downloadgentoo-fffbb9b328e5cc47b3a0c24a71474a41e74e8280.tar.gz
gentoo-fffbb9b328e5cc47b3a0c24a71474a41e74e8280.tar.xz
games-kids/tuxmath: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/tuxmath/Manifest1
-rw-r--r--games-kids/tuxmath/tuxmath-2.0.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/games-kids/tuxmath/Manifest b/games-kids/tuxmath/Manifest
index 564780819f8..3a7aee1b1a0 100644
--- a/games-kids/tuxmath/Manifest
+++ b/games-kids/tuxmath/Manifest
@@ -1 +1,2 @@
+DIST tuxmath_2.0.3.orig.tar.gz 10396696 SHA256 eec49c296d41df39a6474d94ba4e3334e4c16dc180d3ea4a6defc2debfc39887 SHA512 dd7af90f3b1bd637f2f1639a3877d1a9950c95e60b1a71633998e2b0a654bb8015c4bf83540a9af092fe054d468035d0de5f3ddc7d54b17c3235f794a6108fbe WHIRLPOOL ed356ba9e4bc8bf9bd51496ad987befc14cf30a8ff52818c2f7e77278b0ed15bcf06dc9d699ddb5553cb7f20d8e30011b575bdb2cb9dd2ea840b70611670440a
DIST tuxmath_w_fonts-2.0.1.tar.gz 10448109 SHA256 6d26c08672edf5cce0ef2f685555867a7016c8a186282518276378b6c58774f4 SHA512 04f6c347a5eecca7790b5577a9dcb3ea7bf444e19614b468ba6902e37c25aa7de22c62f7ab34e6bd282326f443496aa1d8320f13c4d12ec7e14c118e519e4dc7 WHIRLPOOL a4749d547651ccc9ddd6a36bdf928e751e36ec03678e4955a80fb24a45a466a1c390dcd0ddb8e006437c1c5e6a2c27e4b47cca0da86a484bde292e4699ce50d7
diff --git a/games-kids/tuxmath/tuxmath-2.0.3.ebuild b/games-kids/tuxmath/tuxmath-2.0.3.ebuild
new file mode 100644
index 00000000000..b500ac3726c
--- /dev/null
+++ b/games-kids/tuxmath/tuxmath-2.0.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_PN="${PN}_w_fonts"
+DESCRIPTION="Educational arcade game where you have to solve maths problems"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/"
+SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls svg"
+
+RDEPEND="dev-games/t4k-common[svg?]
+ dev-libs/libxml2:2
+ media-libs/libsdl:0[video]
+ media-libs/sdl-pango
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-net
+ nls? ( virtual/libintl )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i -e '/\bdoc\b/d' Makefile.in || die
+}
+
+src_configure() {
+ egamesconf \
+ --localedir=/usr/share/locale \
+ $(use_enable nls) \
+ $(usex svg "" "--without-rsvg")
+}
+
+src_install() {
+ default
+ doicon -s scalable data/images/icons/${PN}.svg
+ make_desktop_entry ${PN} "TuxMath"
+ dodoc doc/{README,TODO,changelog}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}