summaryrefslogtreecommitdiff
path: root/games-misc/papers-please
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/papers-please
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/papers-please')
-rw-r--r--games-misc/papers-please/Manifest1
-rw-r--r--games-misc/papers-please/metadata.xml5
-rw-r--r--games-misc/papers-please/papers-please-1.1.65.ebuild71
3 files changed, 77 insertions, 0 deletions
diff --git a/games-misc/papers-please/Manifest b/games-misc/papers-please/Manifest
new file mode 100644
index 00000000000..68d9493fe9c
--- /dev/null
+++ b/games-misc/papers-please/Manifest
@@ -0,0 +1 @@
+DIST papers-please_1.1.65_i386.tar.gz 31566799 SHA256 50562ad2b01cb7558147cd05de4dc37c02deb2e66fc5d3bff77994785f9551d7 SHA512 093990a61c1b61d2999e6484335f4deddfecd3d66b7a5e29555c3170e890f6049f7d42a83529dcd993439de940b5dc96b8485d30ab46995d0f6814d5282669e0 WHIRLPOOL 8da4e0d3720159637bf8248cf53c2d7e6388bb3234469da71ae22720c6c76f0ba26a5ebbd116664f217165dc3cd06dd55cf001fd8203469f285570494eea95fc
diff --git a/games-misc/papers-please/metadata.xml b/games-misc/papers-please/metadata.xml
new file mode 100644
index 00000000000..cad5a2aa177
--- /dev/null
+++ b/games-misc/papers-please/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
diff --git a/games-misc/papers-please/papers-please-1.1.65.ebuild b/games-misc/papers-please/papers-please-1.1.65.ebuild
new file mode 100644
index 00000000000..56e52008b6b
--- /dev/null
+++ b/games-misc/papers-please/papers-please-1.1.65.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="A Dystopian Document Thriller"
+HOMEPAGE="http://papersplea.se"
+SRC_URI="papers-please_${PV}_i386.tar.gz"
+
+LICENSE="PAPERS-PLEASE"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+RESTRICT="fetch bindist"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/*"
+
+RDEPEND="
+ amd64? (
+ >=x11-libs/libX11-1.6.2[abi_x86_32]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32]
+ >=x11-libs/libXext-1.3.2[abi_x86_32]
+ >=x11-libs/libXxf86vm-1.1.3[abi_x86_32]
+ >=x11-libs/libdrm-2.4.46[abi_x86_32]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32]
+ >=virtual/opengl-7.0-r1[abi_x86_32]
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libdrm
+ x11-libs/libxcb
+ virtual/opengl
+ )"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_prepare() {
+ rm -v launch.sh LICENSE || die
+ mv README "${T}"/README || die
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r *
+ fperms +x "${dir}"/PapersPlease
+
+ games_make_wrapper ${PN} "./PapersPlease" "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Papers, Please"
+
+ dodoc "${T}"/README
+
+ prepgamesdirs
+}