summaryrefslogtreecommitdiff
path: root/games-misc/ponysay
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-12-18 12:52:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-12-18 13:00:27 +0000
commit803ddbcb6f67c28f676148293b9bf9037020ddda (patch)
treeb32bedf75280293b6cf6921e2489a5125cfe9095 /games-misc/ponysay
parentab146b0cb173db0b72c0ee3a9b76a5680538d962 (diff)
downloadgentoo-803ddbcb6f67c28f676148293b9bf9037020ddda.tar.gz
gentoo-803ddbcb6f67c28f676148293b9bf9037020ddda.tar.xz
games-misc/ponysay: New package to supersede one from aidstu-overlay
zsh-completion is broken in the latest release but I have included it anyway. Package-Manager: portage-2.3.3
Diffstat (limited to 'games-misc/ponysay')
-rw-r--r--games-misc/ponysay/Manifest1
-rw-r--r--games-misc/ponysay/metadata.xml12
-rw-r--r--games-misc/ponysay/ponysay-3.0.2.ebuild60
3 files changed, 73 insertions, 0 deletions
diff --git a/games-misc/ponysay/Manifest b/games-misc/ponysay/Manifest
new file mode 100644
index 00000000000..d4de299a834
--- /dev/null
+++ b/games-misc/ponysay/Manifest
@@ -0,0 +1 @@
+DIST ponysay-3.0.2.tar.gz 2110382 SHA256 69e98a7966353de2f232cbdaccd8ef7dbc5d0bcede9bf7280a676793e8625b0d SHA512 47d5c584b3b8c233567eff534b5109548c92075f69776703bc303929ba4278f67fd599987ef4a098aa871c2af0efd89186f96fa28565e73b4672abeb0c23fa45 WHIRLPOOL 9ba79521c95948498cffb3fa8c921dfeab9188d215ddd57c777517e54453979ea4f40ec1faea894a8a967fce78fe08767bf915d7bdeca4807a337099e7d8c265
diff --git a/games-misc/ponysay/metadata.xml b/games-misc/ponysay/metadata.xml
new file mode 100644
index 00000000000..c45d7ecdc90
--- /dev/null
+++ b/games-misc/ponysay/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="non-free">Install non-free ponies (i.e. from the MLP franchise)</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-misc/ponysay/ponysay-3.0.2.ebuild b/games-misc/ponysay/ponysay-3.0.2.ebuild
new file mode 100644
index 00000000000..96176900063
--- /dev/null
+++ b/games-misc/ponysay/ponysay-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="cowsay reimplemention for ponies"
+HOMEPAGE="https://github.com/erkin/ponysay"
+SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +non-free bash-completion fish-completion zsh-completion"
+
+DEPEND="${PYTHON_DEPS}
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${PYTHON_DEPS}
+ fish-completion? ( app-shells/fish )
+ zsh-completion? ( app-shells/zsh )"
+
+setup_py() {
+ "${PYTHON}" setup.py \
+ --prefix="${EPREFIX}"/usr \
+ --everything \
+ --without-info-compression \
+ --without-man-compression \
+ --without-pdf-compression \
+ --without-shared-cache \
+ --freedom=$(usex non-free no yes) \
+ $(use_with fish-completion) \
+ $(use_with zsh-completion) \
+ $(use_with doc info) \
+ $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
+ "${@}" || die
+}
+
+src_compile() {
+ setup_py \
+ $(use_with bash-completion) \
+ build
+}
+
+src_install() {
+ setup_py \
+ --without-bash-completion \
+ --destdir="${D}" \
+ prebuilt
+
+ python_fix_shebang "${ED}"/usr/bin/${PN}
+
+ rm -rv "${ED}"/usr/share/licenses || die
+ dodoc CHANGELOG CONTRIBUTING CREDITS README.md
+
+ use bash-completion &&
+ newbashcomp completion/bash-completion.${PN}.install ${PN}
+}