summaryrefslogtreecommitdiff
path: root/games-misc
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-12-26 01:37:36 +0300
committerLars Wendler <polynomial-c@gentoo.org>2016-12-26 18:04:44 +0100
commit54ccd93f6d01ee6bb5fa312b38d4127440ce9869 (patch)
tree74e9fdadbe0e966387e565e73d2d35386ca2e44f /games-misc
parent1c7ef6b6bc70db1f1abf899373f4b37284309fcf (diff)
downloadgentoo-54ccd93f6d01ee6bb5fa312b38d4127440ce9869.tar.gz
gentoo-54ccd93f6d01ee6bb5fa312b38d4127440ce9869.tar.xz
games-misc/opengfx: EAPI=6
Closes: https://github.com/gentoo/gentoo/pull/3242
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/opengfx-0.5.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.5.4-r1.ebuild b/games-misc/opengfx/opengfx-0.5.4-r1.ebuild
new file mode 100644
index 00000000000..35894956904
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+)
+
+src_compile() {
+ emake GIMP="" help # print out the env to make bug reports better
+ emake GIMP="" _V="" bundle_tar
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+}