summaryrefslogtreecommitdiff
path: root/games-mud/tkmoo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-mud/tkmoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-mud/tkmoo')
-rw-r--r--games-mud/tkmoo/Manifest1
-rw-r--r--games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch15
-rw-r--r--games-mud/tkmoo/files/0.3.32-keys-workaround.patch13
-rw-r--r--games-mud/tkmoo/metadata.xml5
-rw-r--r--games-mud/tkmoo/tkmoo-0.3.32.ebuild48
5 files changed, 82 insertions, 0 deletions
diff --git a/games-mud/tkmoo/Manifest b/games-mud/tkmoo/Manifest
new file mode 100644
index 00000000000..1dfbe220d4a
--- /dev/null
+++ b/games-mud/tkmoo/Manifest
@@ -0,0 +1 @@
+DIST tkMOO-light-0.3.32.tar.gz 95332 SHA256 8e5f5e2ed756587bf3f4687c574df3111bf77eff153f17fe1800ef98662c4b5b SHA512 59543692900613eae77b73f5f88a2380a77d1be38d486dc0461d0990ccb941497dd0d35aa109a5697dba3b92157d9943b540a73fe4fc0d519e144f65620443d2 WHIRLPOOL accbf77c88e403d0170856ce1356d15c49584f50da17afc568cae8cc1b36c597dcd64f965672164021d49800125bf39666e773db340c47ba7e3f0cabab196377
diff --git a/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch b/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
new file mode 100644
index 00000000000..c61a29df0ac
--- /dev/null
+++ b/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
@@ -0,0 +1,15 @@
+--- Makefile.orig 2003-07-12 03:04:24.000000000 -0400
++++ Makefile 2003-07-12 03:04:32.000000000 -0400
+@@ -32,11 +32,8 @@
+
+ # some shells are set 'noclobber', so force overwriting of the
+ # executable and installation
+-clean:
+- \rm -f $(EXECUTABLE)
+- \rm -f $(TKMOO_BIN_DIR)/$(EXECUTABLE)
+
+-executable: clean
++executable:
+ if [ ! -e $(WISH) ]; then \
+ echo "***"; \
+ echo "*** Can't find executable '$(WISH)', building anyway..."; \
diff --git a/games-mud/tkmoo/files/0.3.32-keys-workaround.patch b/games-mud/tkmoo/files/0.3.32-keys-workaround.patch
new file mode 100644
index 00000000000..d70e017f09e
--- /dev/null
+++ b/games-mud/tkmoo/files/0.3.32-keys-workaround.patch
@@ -0,0 +1,13 @@
+--- source.tcl.orig 2004-12-28 23:36:47.000000000 -0800
++++ source.tcl 2004-12-28 23:37:09.000000000 -0800
+@@ -51,6 +51,10 @@
+ #
+ #
+
++tk::unsupported::ExposePrivateCommand tkTextSetCursor
++tk::unsupported::ExposePrivateCommand tkTextScrollPages
++tk::unsupported::ExposePrivateCommand tkTextInsert
++
+ proc db.set { id field val args } {
+ global db
+ if { $args == {} } {
diff --git a/games-mud/tkmoo/metadata.xml b/games-mud/tkmoo/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-mud/tkmoo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-mud/tkmoo/tkmoo-0.3.32.ebuild b/games-mud/tkmoo/tkmoo-0.3.32.ebuild
new file mode 100644
index 00000000000..7e187456e13
--- /dev/null
+++ b/games-mud/tkmoo/tkmoo-0.3.32.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+MY_PN=${PN/moo/MOO-light}
+MY_P=${P/moo/MOO-light}
+DESCRIPTION="MOO Client written in Tcl/Tk"
+HOMEPAGE="http://www.awns.com/tkMOO-light/"
+SRC_URI="http://www.awns.com/tkMOO-light/Source/${MY_P}.tar.gz"
+
+LICENSE="tkMOO"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.3.3:0=
+ >=dev-lang/tk-8.3.3:0="
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PV}-Makefile-noclean.patch" \
+ "${FILESDIR}/${PV}-keys-workaround.patch"
+}
+
+src_compile() {
+ emake \
+ WISH="$(type -P wish)" \
+ TKMOO_LIB_DIR="$(games_get_libdir)/${MY_PN}" \
+ TKMOO_BIN_DIR="${GAMES_BINDIR}"
+}
+
+src_install() {
+ emake \
+ TKMOO_LIB_DIR="${D}/$(games_get_libdir)/${MY_PN}" \
+ TKMOO_BIN_DIR="${D}/${GAMES_BINDIR}" \
+ install
+ dodoc README dot.tkmoolightrc bugsmail.txt
+ dosym tkMOO-lite "${GAMES_BINDIR}/tkmoo"
+ make_desktop_entry tkmoo "tkMOO"
+ prepgamesdirs
+}