summaryrefslogtreecommitdiff
path: root/games-puzzle/jools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/jools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/jools')
-rw-r--r--games-puzzle/jools/Manifest2
-rw-r--r--games-puzzle/jools/jools-0.20-r2.ebuild57
-rw-r--r--games-puzzle/jools/metadata.xml12
3 files changed, 71 insertions, 0 deletions
diff --git a/games-puzzle/jools/Manifest b/games-puzzle/jools/Manifest
new file mode 100644
index 00000000000..c2b3d5de84b
--- /dev/null
+++ b/games-puzzle/jools/Manifest
@@ -0,0 +1,2 @@
+DIST jools-0.20.tar.gz 1710143 SHA256 50f5c23491e45b4658baecdb774ba071000f4c9a1164b77c95cbfe711f3e36c8 SHA512 11eadceb8208a72846a9e16a2dae0a1b1d7f8995d5ff2487ee03dd62811f3a232c0d08dc044c351f44c120e6e75eba11df1a727a9d5c6c57ce5e2ef8ee4d0986 WHIRLPOOL 7c84e67e4c1b1ced837f8295bd8333bf511f526494d0cf1d9f75f97bc675955aa91aa5f49ef452fc45e5f596fc22d904b90113409f66877c0f2140f730ff2fd1
+DIST jools-musicpack-1.0.tar.gz 4447501 SHA256 baf3bd24a65508868b13b6224a0661dc4b8616eb8d70fab04a9e732d32983c84 SHA512 1773beb8cd7df756cb4f7ba55729a6dfa995ca860f3381e2fed3884f42227d19955e13f8be9b2f6f64d4d86e452be9fe876963e24c85cd2c3cc42df62804b9c2 WHIRLPOOL 0b3cfc8c115919c375132150a5bb5fd861d592f8ae6de75e9fe00b835ebdbcd4988a8187499bc50049931b2a2651113f24de84ff240082961197a6dd9328cdae
diff --git a/games-puzzle/jools/jools-0.20-r2.ebuild b/games-puzzle/jools/jools-0.20-r2.ebuild
new file mode 100644
index 00000000000..ce1b2dab851
--- /dev/null
+++ b/games-puzzle/jools/jools-0.20-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MUS_P=${PN}-musicpack-1.0
+DESCRIPTION="clone of Bejeweled, a popular pattern-matching game"
+HOMEPAGE="http://pessimization.com/software/jools/"
+SRC_URI="http://pessimization.com/software/jools/${P}.tar.gz
+ http://pessimization.com/software/jools/${MUS_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${P}/jools
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/music
+ unpack ${MUS_P}.tar.gz
+}
+
+src_prepare() {
+ echo "MEDIAROOT = \"${GAMES_DATADIR}/${PN}\"" > config.py
+ python_fix_shebang .
+}
+
+src_install() {
+ games_make_wrapper ${PN} "${EPYTHON} ./__init__.py" "$(games_get_libdir)"/${PN}
+ insinto "$(games_get_libdir)"/${PN}
+ doins *.py
+ python_optimize "${D}$(games_get_libdir)/${PN}"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r fonts images music sounds
+
+ newicon images/ruby/0001.png ${PN}.png
+ make_desktop_entry ${PN} Jools
+ dodoc ../{ChangeLog,doc/{POINTS,TODO}}
+ dohtml ../doc/manual.html
+ prepgamesdirs
+}
diff --git a/games-puzzle/jools/metadata.xml b/games-puzzle/jools/metadata.xml
new file mode 100644
index 00000000000..7b0afd17516
--- /dev/null
+++ b/games-puzzle/jools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Jools is a graphical puzzle game in the tradition of Tetris. It has begun as
+a clone of Bejeweled, which is currently available for Windows, Mac, and
+Palm/Pocket PC devices. In a nutshell, the goal is to swap adjacent jools
+(jewels) within a grid, in order to create rows of three or more of a kind.
+These jools will then disappear, and more will fall to fill their places.
+</longdescription>
+</pkgmetadata>