summaryrefslogtreecommitdiff
path: root/games-puzzle/kiki/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/kiki/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/kiki/files')
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-build.patch45
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch19
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch10
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc43.patch56
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch22
5 files changed, 152 insertions, 0 deletions
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-build.patch b/games-puzzle/kiki/files/kiki-1.0.2-build.patch
new file mode 100644
index 00000000000..b3798678f81
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-build.patch
@@ -0,0 +1,45 @@
+--- kodilib/linux/Makefile
++++ kodilib/linux/Makefile
+@@ -21,7 +21,7 @@
+
+ INCLUDES = $(KODI_INCLUDES) $(X11_INCLUDES) $(SDL_INCLUDES)
+
+-CXXFLAGS = $(INCLUDES) $(SDL_CFLAGS)
++CXXFLAGS += $(INCLUDES) $(SDL_CFLAGS)
+
+ src = \
+ $(KODISRCDIR)/handler/KEventHandler.cpp \
+--- linux/Makefile
++++ linux/Makefile
+@@ -14,11 +14,7 @@
+
+ GLLIBS = -lglut -lGLU -lGL
+
+-PYTHONHOME = /usr/lib/python$(PYTHON_VERSION)/
+-PYTHONLIBS = $(PYTHONHOME)/config/libpython$(PYTHON_VERSION).a -lutil \
+- $(PYTHONHOME)/lib-dynload/math.so \
+- $(PYTHONHOME)/lib-dynload/time.so \
+- $(PYTHONHOME)/lib-dynload/_random.so
++PYTHONLIBS = -lpython$(PYTHON_VERSION) -lutil
+
+ # change this, if the kodilib directory isn't parallel to the kiki directory
+
+@@ -46,7 +42,7 @@
+
+ INCLUDES = $(KIKI_INCLUDES) $(X11_INCLUDES) $(PYTHON_INCLUDES)
+
+-CXXFLAGS = $(INCLUDES) $(SDLCFLAGS)
++CXXFLAGS += $(INCLUDES) $(SDLCFLAGS)
+
+ src = \
+ $(KIKISRC)/base/KikiAction.cpp \
+@@ -105,8 +101,7 @@
+ obj = $(src:.cpp=.o)
+
+ kiki: $(KIKISRC)/../SWIG/KikiPy_wrap.cpp $(obj)
+- -(cd ../SWIG; swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i; cp kiki.py ../py)
+- $(CXX) $(obj) $(KODILIB) -o kiki $(GLLIBS) $(SDLLIBS) $(PYTHONLIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(obj) $(KODILIB) -o kiki $(GLLIBS) $(SDLLIBS) $(PYTHONLIBS)
+
+ obj-clean:
+ $(RM) -f $(obj)
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
new file mode 100644
index 00000000000..aab70ba69b7
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
@@ -0,0 +1,19 @@
+--- src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
++++ src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
+@@ -9,6 +9,7 @@
+ #include <math.h>
+
+ #include <SDL.h>
++#include <GL/glut.h>
+ #include "KikiController.h"
+
+ // __________________________________________________________________________________________________
+@@ -19,6 +20,8 @@
+ int width, height;
+ SDL_Surface * screen;
+
++ glutInit(&argc, argv);
++
+ // initialize SDL
+ if ( SDL_Init(SDL_INIT_VIDEO | SDL_INIT_VIDEO) < 0 ) // SDL_INIT_TIMER
+ {
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
new file mode 100644
index 00000000000..05bdd3707ec
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
@@ -0,0 +1,10 @@
+--- src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
++++ src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include "KikiPos.h"
+ #include <KTextField.h>
+
++class KikiPython;
+ class KikiPythonWidget : public KTextField
+ {
+ friend class KikiPython;
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc43.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc43.patch
new file mode 100644
index 00000000000..baa04f2ff98
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc43.patch
@@ -0,0 +1,56 @@
+--- kiki/kodilib/src/handler/KPickable.h.orig 2003-04-09 05:56:01.000000000 +0300
++++ kiki/kodilib/src/handler/KPickable.h 2008-10-18 17:23:42.000000000 +0300
+@@ -9,6 +9,8 @@
+ #include "KIntrospection.h"
+ #include <vector>
+
++#include <limits.h>
++
+ #define DEBUG_PICKING false
+
+ class KPickable;
+--- kiki/kodilib/src/tools/KIntrospection.h.orig 2003-04-09 05:56:03.000000000 +0300
++++ kiki/kodilib/src/tools/KIntrospection.h 2008-10-18 17:22:03.000000000 +0300
+@@ -11,6 +11,7 @@
+ #endif
+
+ #include <string>
++#include <cstring>
+
+ // --------------------------------------------------------------------------------------------------------
+ class KClassInfo
+--- kiki/kodilib/src/tools/KStringTools.cpp.orig 2003-04-14 00:42:13.000000000 +0300
++++ kiki/kodilib/src/tools/KStringTools.cpp 2008-10-18 17:25:48.000000000 +0300
+@@ -6,9 +6,10 @@
+ #include "KStringTools.h"
+ #include "KVector.h"
+
+-#include <sys/types.h> // INT_MAX
+ #include <stdio.h>
+
++#include <limits.h> // INT_MAX
++
+ // --------------------------------------------------------------------------------------------------------
+ void kStringInsertStringBehindTags ( std::string & str, const std::string & insertString,
+ const std::string & tag )
+--- kiki/kodilib/src/tools/KStringTools.h.orig 2003-04-09 05:56:04.000000000 +0300
++++ kiki/kodilib/src/tools/KStringTools.h 2008-10-18 17:22:49.000000000 +0300
+@@ -7,6 +7,7 @@
+ #define __KStringTools
+
+ #include <string>
++#include <cstring>
+ #include <vector>
+ #include <stdarg.h>
+
+--- kiki/kodilib/src/tools/KXMLTools.cpp.orig 2003-04-14 00:42:13.000000000 +0300
++++ kiki/kodilib/src/tools/KXMLTools.cpp 2008-10-18 17:26:42.000000000 +0300
+@@ -8,6 +8,8 @@
+ #include "KSeparatedMatrix.h"
+ #include <stdio.h>
+
++#include <cstdlib>
++
+ // --------------------------------------------------------------------------------------------------------
+ std::string kXMLTag ( const std::string & name, const std::string & attributes, int depth )
+ {
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch
new file mode 100644
index 00000000000..457c6d68ae0
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch
@@ -0,0 +1,22 @@
+--- SWIG/KikiPy_wrap.cpp.old 2011-04-20 14:48:38.000000000 +0200
++++ SWIG/KikiPy_wrap.cpp 2011-04-20 15:15:08.000000000 +0200
+@@ -12968,7 +12968,7 @@
+ void *argp1 = 0 ;
+ int res1 = 0 ;
+ PyObject * obj0 = 0 ;
+- std::string *result = 0 ;
++ std::string result ;
+
+ if (!PyArg_ParseTuple(args,(char *)"O:KikiText_getText",&obj0)) SWIG_fail;
+ res1 = SWIG_ConvertPtr(obj0, &argp1,SWIGTYPE_p_KikiText, 0 | 0 );
+@@ -12976,8 +12976,8 @@
+ SWIG_exception_fail(SWIG_ArgError(res1), "in method '" "KikiText_getText" "', argument " "1"" of type '" "KikiText const *""'");
+ }
+ arg1 = reinterpret_cast< KikiText * >(argp1);
+- result = (std::string *) &((KikiText const *)arg1)->getText();
+- resultobj = SWIG_From_std_string(static_cast< std::string >(*result));
++ result = ((KikiText const *)arg1)->getText();
++ resultobj = SWIG_From_std_string(static_cast< std::string >(result));
+ return resultobj;
+ fail:
+ return NULL;