summaryrefslogtreecommitdiff
path: root/games-puzzle/pipepanic
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/pipepanic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/pipepanic')
-rw-r--r--games-puzzle/pipepanic/Manifest1
-rw-r--r--games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch21
-rw-r--r--games-puzzle/pipepanic/metadata.xml5
-rw-r--r--games-puzzle/pipepanic/pipepanic-0.1.3.ebuild42
4 files changed, 69 insertions, 0 deletions
diff --git a/games-puzzle/pipepanic/Manifest b/games-puzzle/pipepanic/Manifest
new file mode 100644
index 00000000000..3e26879a73c
--- /dev/null
+++ b/games-puzzle/pipepanic/Manifest
@@ -0,0 +1 @@
+DIST pipepanic-0.1.3-source.tar.gz 232200 SHA256 4b02249c92228b03f4cc3c1d999cacf3fe52c16df53c6bf76fc6c1e2caa74318 SHA512 468f3194976c7030c2fa3d8f30eaa13cc25e0b04feeb48a5d1267d119eb991618bad14ddba0a8268e6b92f38f2a17bc5b119728b222b0ee50494807832ad2ab7 WHIRLPOOL bdbef665dcee14b1360d1726701986991f8adbfe4da1a4f429af725bfa74232efc9736ced944ecbd7a6b216a7af39d698a591fa48d2d279875f953f024020af4
diff --git a/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch b/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch
new file mode 100644
index 00000000000..1366b7d341c
--- /dev/null
+++ b/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch
@@ -0,0 +1,21 @@
+diff -ru pipepanic-0.1.3-source.orig/Makefile pipepanic-0.1.3-source/Makefile
+--- pipepanic-0.1.3-source.orig/Makefile 2006-05-16 16:11:29.000000000 -0400
++++ pipepanic-0.1.3-source/Makefile 2009-11-03 13:38:52.109137983 -0500
+@@ -3,15 +3,12 @@
+ TARGET=pipepanic
+
+ # Settings for x86.
+-CC=gcc
+-CFLAGS=-O2 -Wall -pedantic `sdl-config --cflags`
+-LINK=gcc
+-LDFLAGS=
++CFLAGS+=`sdl-config --cflags`
+ LIBS=`sdl-config --libs`
+
+ all:
+ $(CC) $(CFLAGS) -c $(SOURCES)
+- $(LINK) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $(TARGET)
++ $(CC) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $(TARGET)
+
+ .PHONY: clean
+
diff --git a/games-puzzle/pipepanic/metadata.xml b/games-puzzle/pipepanic/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-puzzle/pipepanic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/pipepanic/pipepanic-0.1.3.ebuild b/games-puzzle/pipepanic/pipepanic-0.1.3.ebuild
new file mode 100644
index 00000000000..e9e4a3b93e4
--- /dev/null
+++ b/games-puzzle/pipepanic/pipepanic-0.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A simple pipe connecting game"
+HOMEPAGE="http://www.users.waitrose.com/~thunor/pipepanic/"
+SRC_URI="http://www.users.waitrose.com/~thunor/pipepanic/dload/${P}-source.tar.gz"
+
+LICENSE="GPL-2 FreeArt"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ # change harcoded data paths to match the install directory
+ sed -i \
+ -e "s:/opt/QtPalmtop/share/pipepanic/:${GAMES_DATADIR}/${PN}/:" \
+ main.h \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin "${PN}"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins *.bmp
+ newicon PipepanicIcon64.png ${PN}.png
+ make_desktop_entry ${PN} "Pipepanic"
+
+ dodoc AUTHORS ChangeLog README
+
+ prepgamesdirs
+}