summaryrefslogtreecommitdiff
path: root/games-puzzle/tint
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/tint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/tint')
-rw-r--r--games-puzzle/tint/Manifest1
-rw-r--r--games-puzzle/tint/files/tint-0.03b-ovflfix.patch33
-rw-r--r--games-puzzle/tint/metadata.xml5
-rw-r--r--games-puzzle/tint/tint-0.03b.ebuild39
4 files changed, 78 insertions, 0 deletions
diff --git a/games-puzzle/tint/Manifest b/games-puzzle/tint/Manifest
new file mode 100644
index 00000000000..737ef7a9c8d
--- /dev/null
+++ b/games-puzzle/tint/Manifest
@@ -0,0 +1 @@
+DIST tint_0.03b.tar.gz 16909 SHA256 f43fc82c5d16954a85ef532b0771599902cea86d8d9eea044e5b7454db91419c SHA512 f442122248987a4f2843e0abe3ed4b3fcecbb6024aad2b486087468c84d80f94310dcf4a37a3d93a647d0abe9aaf10e7d957c88ec6314c25a9fd90d4dfc16ec1 WHIRLPOOL 0828a78940d54070d7d5199d49a13dd61132c06e2ed54645a9d278cc9bc78ef7cbcfe26d0a700ebd500d3828ea6376b4170fb63593fca2b8c537d603127d18eb
diff --git a/games-puzzle/tint/files/tint-0.03b-ovflfix.patch b/games-puzzle/tint/files/tint-0.03b-ovflfix.patch
new file mode 100644
index 00000000000..341f027999c
--- /dev/null
+++ b/games-puzzle/tint/files/tint-0.03b-ovflfix.patch
@@ -0,0 +1,33 @@
+diff -ru tint-0.03b.orig/io.c tint-0.03b/io.c
+--- tint-0.03b.orig/io.c 2001-12-07 10:48:20.000000000 -0500
++++ tint-0.03b/io.c 2010-11-08 13:40:16.786841434 -0500
+@@ -39,7 +39,7 @@
+ #define NUM_COLORS 8
+
+ /* Number of attributes defined in io.h */
+-#define NUM_ATTRS 7
++#define NUM_ATTRS 9
+
+ /* Cursor definitions */
+ #define CURSOR_INVISIBLE 0
+diff -ru tint-0.03b.orig/tint.c tint-0.03b/tint.c
+--- tint-0.03b.orig/tint.c 2005-07-17 07:26:43.000000000 -0400
++++ tint-0.03b/tint.c 2010-11-08 13:40:04.225203170 -0500
+@@ -365,7 +365,7 @@
+ FILE *handle;
+ int i,j;
+ score_t scores[NUMSCORES];
+- char header[strlen (SCORE_HEADER)];
++ char header[strlen(SCORE_HEADER) + 1];
+ if (score == 0) return; /* No need saving this */
+ for (i = 1; i < NUMSCORES; i++)
+ {
+@@ -418,7 +418,7 @@
+ FILE *handle;
+ int i,j,ch;
+ score_t scores[NUMSCORES];
+- char header[strlen (SCORE_HEADER)];
++ char header[strlen(SCORE_HEADER) + 1];
+ time_t tmp = 0;
+ if ((handle = fopen (scorefile,"r")) == NULL)
+ {
diff --git a/games-puzzle/tint/metadata.xml b/games-puzzle/tint/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-puzzle/tint/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/tint/tint-0.03b.ebuild b/games-puzzle/tint/tint-0.03b.ebuild
new file mode 100644
index 00000000000..0c5d6923dd1
--- /dev/null
+++ b/games-puzzle/tint/tint-0.03b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_P=${P/-/_}
+DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
+HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.4-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
+
+src_compile() {
+ emake \
+ STRIP=true \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ localstatedir="${GAMES_STATEDIR}"
+}
+
+src_install() {
+ dogamesbin tint
+ doman tint.6
+ dodoc CREDITS NOTES
+ insopts -m 0664
+ insinto "${GAMES_STATEDIR}"
+ doins tint.scores
+ prepgamesdirs
+}