summaryrefslogtreecommitdiff
path: root/games-puzzle/tod
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/tod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/tod')
-rw-r--r--games-puzzle/tod/Manifest1
-rw-r--r--games-puzzle/tod/files/tod-0-makefile.patch13
-rw-r--r--games-puzzle/tod/metadata.xml5
-rw-r--r--games-puzzle/tod/tod-0.ebuild36
4 files changed, 55 insertions, 0 deletions
diff --git a/games-puzzle/tod/Manifest b/games-puzzle/tod/Manifest
new file mode 100644
index 00000000000..82a6bc41581
--- /dev/null
+++ b/games-puzzle/tod/Manifest
@@ -0,0 +1 @@
+DIST wintod.zip 115653 SHA256 92265cd3266f5deecca8aba1f00bd68af2e758e9b00cd97f92ff487d05524686 SHA512 8cc203d9745cc4855c58c2f9119d06a1f02e1ecb9c1cc2c1dc1f1c77e5aa0553925bdcba3d744db462bbc77f3637a42e35a579a8807c8098aa2fde7452cc30cc WHIRLPOOL 4a3c2dd4d7a787d7b22c74ddf8db331a776677c2b32546d6f237df0bf46970404018edb6d1beb9865db2f1e6d91e6648a421e10ebd58d9f3c8466abcc88c2f83
diff --git a/games-puzzle/tod/files/tod-0-makefile.patch b/games-puzzle/tod/files/tod-0-makefile.patch
new file mode 100644
index 00000000000..cd17d1cce42
--- /dev/null
+++ b/games-puzzle/tod/files/tod-0-makefile.patch
@@ -0,0 +1,13 @@
+--- makefile
++++ makefile
+@@ -1,8 +1,7 @@
+ OBJ = hiscore rec scrctl tetanus crc allegdlg hgrcos
+ HEADS = tod.h allegdlg.h crc.h hgrcos.h hiscore.h
+-LIBS = -lalleg
+-CFLAGS = -Wall -march=i486 -mcpu=i686 -O3 -ffast-math
+-LDFLAGS = -mwindows
++LIBS = `allegro-config --libs`
++CFLAGS += `allegro-config --cflags`
+ CC = gcc
+
+
diff --git a/games-puzzle/tod/metadata.xml b/games-puzzle/tod/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-puzzle/tod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
new file mode 100644
index 00000000000..aa7d99fa087
--- /dev/null
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tetanus On Drugs simulates playing a Tetris clone under the influence of hallucinogenic drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/allegro:0[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_install() {
+ newgamesbin tod-debug.exe tod
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins idltd.dat
+ dodoc readme.txt
+ prepgamesdirs
+}