summaryrefslogtreecommitdiff
path: root/games-puzzle/xye
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-29 23:43:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-12-29 23:45:54 +0200
commit979beea22f428225b0fccf740f0db25013c5948b (patch)
tree4dacc3e0e919524c42d7d8778249d56dda3d467a /games-puzzle/xye
parent0e23b9b8a512616e60193fbd3dc1499867ec05c5 (diff)
downloadgentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.gz
gentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.xz
games-puzzle/xye: Version bump to 0.12.2
Gentoo-bug: 600298 * EAPI=6 * Remove games.eclass Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-puzzle/xye')
-rw-r--r--games-puzzle/xye/Manifest1
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch45
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch14
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch18
-rw-r--r--games-puzzle/xye/xye-0.12.2.ebuild43
5 files changed, 121 insertions, 0 deletions
diff --git a/games-puzzle/xye/Manifest b/games-puzzle/xye/Manifest
index 135c83d77e0..179165bae00 100644
--- a/games-puzzle/xye/Manifest
+++ b/games-puzzle/xye/Manifest
@@ -1 +1,2 @@
DIST xye-0.12.1.tar.gz 2850776 SHA256 bbeb3265b0795f14deb2851b4a3bda7dde9b07d624a7ca5fb88cd7acabcf3967 SHA512 aadafdb7b8e0546435838279c2929803be8dde00f3f3c08668c35d0a8ccf5bad511e65629e3f7261140edcf0980d19fda2be1401593ac4c0410beede542e857b WHIRLPOOL 7a1aa2708361b4eddb266037af35e6915852ba1a5037fcfebd95c0a8caab54209ca1c9e3827acecff64772fd15b077f5cded64a50b5820abd7b3cde937bbc2e0
+DIST xye-0.12.2.tar.gz 2860290 SHA256 5d7c04f37d6b4a1821594512c7ddbc8189f968e08ecfd5af55231302f2f917d8 SHA512 a31d922e0a0660d269d30430fbaf1d00924b0271db697f3cbc89b78815e597e11743bd9018fbf3f2f9e7561ad3469e9cca28687efaae7fc6dcba40ada2b5effa WHIRLPOOL 0f4d9105435adab0055cdd8966aa542fd0a231203562bd96ff8b2dff275675233ec1ca541f93e23787d8bf610cb29430f0b97e9f447ba63a695127e670788fc4
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch b/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch
new file mode 100644
index 00000000000..c96d42e3468
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch
@@ -0,0 +1,45 @@
+Fix build system to respect correct paths
+and install files in correct paths.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,13 +4,11 @@
+
+
+ bin_PROGRAMS = xye
+-xye_LDFLAGS =
+
++doc_DATA = NEWS ChangeLog AUTHORS
++html_DATA = ReadMe.html
+
+-docedir = $(datadir)/@PACKAGE@
+-doce_DATA = ReadMe.html NEWS ChangeLog AUTHORS
+-
+-levelsdir= $(datadir)/@PACKAGE@/levels
++levelsdir= $(datadir)/$(PACKAGE)/levels
+ levels_DATA = levels/5levels.xye \
+ levels/levels.xye \
+ levels/logo.xye \
+@@ -25,12 +23,10 @@
+ levels/xyester.xye \
+ levels/SuperJustin.xye
+
+-resdir= $(datadir)/@PACKAGE@/res
++resdir= $(datadir)/$(PACKAGE)/res
+ res_DATA = res/default.xml \
+ res/xye.png \
+ res/xye_luminosity.png \
+-res/DejaVuSans.ttf \
+-res/DejaVuSans-Bold.ttf \
+ res/fon.bmp \
+ res/fon_bold.bmp \
+ res/clean40.xml \
+@@ -103,7 +99,7 @@
+ src/skins.cpp \
+ src/skins.h
+
+-EXTRA_DIST = ${EXTRA_DIST1} ${xye_SOURCES} ${res_DATA} ${levels_DATA} ${doce_DATA}
++EXTRA_DIST = ${EXTRA_DIST1} ${xye_SOURCES} ${res_DATA} ${levels_DATA}
+
+ DEFS=@data_path_flag@
+
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch b/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch
new file mode 100644
index 00000000000..f2083b871a8
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch
@@ -0,0 +1,14 @@
+Add explicit cast to silence C++14 -Wnarrowing conversion warnings.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=600298
+
+--- a/src/xsb_level.cpp
++++ b/src/xsb_level.cpp
+@@ -784,7 +784,7 @@
+
+ bool FromXyeDFS(int* mem, unsigned char x, unsigned char y)
+ {
+- static const unsigned char dx[4] = {0,0,-1,1}, dy[4] = {-1,1,0,0};
++ static const unsigned char dx[4] = {0,0,(unsigned char)-1,1}, dy[4] = {(unsigned char)-1,1,0,0};
+ int &res = mem[y*XYE_HORZ+x];
+ if( res==0)
+ {
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch b/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch
new file mode 100644
index 00000000000..99558ef2873
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch
@@ -0,0 +1,18 @@
+Fix .desktop file to comply with FDO specifications.
+
+--- a/xye.desktop
++++ b/xye.desktop
+@@ -4,11 +4,11 @@
+ Encoding=UTF-8
+ Exec=xye
+ Type=Application
+-Categories=Application;Game;PuzzleGame
++Categories=Game
+ Name=Xye
+ GenericName=Xye
+ Comment=Solve puzzles and action challenges in order to get all the gems in the room.
+ Terminal=false
+ StartupNotify=false
+-Icon=xye.png
++Icon=xye
+ MimeType=application/xye-xml
diff --git a/games-puzzle/xye/xye-0.12.2.ebuild b/games-puzzle/xye/xye-0.12.2.ebuild
new file mode 100644
index 00000000000..375906276fc
--- /dev/null
+++ b/games-puzzle/xye/xye-0.12.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-fonts/dejavu
+ media-libs/libsdl[video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.2-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-c++14.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-desktop-file.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # create symlinks for previously bundled fonts
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf /usr/share/${PN}/res/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf /usr/share/${PN}/res/DejaVuSans-Bold.ttf
+}