summaryrefslogtreecommitdiff
path: root/games-puzzle
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-18 21:30:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-18 21:37:45 +0100
commit8a948d0c4e00bbf87fcc96c78b00d0e6385b9ef9 (patch)
tree2522ad5a6b59afb11a6bf7e86f816086f16111e6 /games-puzzle
parentbc9e094930d5ffb2fdc8f722848ca9227409159b (diff)
downloadgentoo-8a948d0c4e00bbf87fcc96c78b00d0e6385b9ef9.tar.gz
gentoo-8a948d0c4e00bbf87fcc96c78b00d0e6385b9ef9.tar.xz
games-puzzle/kiki: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r2.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
deleted file mode 100644
index ae20f256767..00000000000
--- a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_DEPEND="2"
-inherit eutils python toolchain-funcs games
-
-DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
-HOMEPAGE="http://kiki.sourceforge.net/"
-SRC_URI="mirror://sourceforge/kiki/${P}-src.tgz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[opengl]
- media-libs/sdl-image
- media-libs/sdl-mixer
- virtual/opengl
- virtual/glu
- media-libs/freeglut"
-DEPEND="${RDEPEND}
- dev-lang/swig"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-freeglut.patch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-build.patch
- ecvs_clean
- rm -f py/runkiki
-
- # Change the hard-coded data dir for sounds, etc...
- sed -i \
- -e "s:kiki_home += \"/\";:kiki_home = \"${GAMES_DATADIR}/${PN}/\";:g" \
- -e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
- -e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
- src/main/KikiController.cpp || die
-
- # Bug 139570
- cd SWIG
- swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i || die
- cp -f kiki.py ../py
- epatch "${FILESDIR}"/${P}-gcc46.patch
-}
-
-src_compile() {
- emake -C kodilib/linux AR="$(tc-getAR)"
- emake -C linux PYTHON_VERSION="$(python_get_version)"
-}
-
-src_install() {
- dogamesbin linux/kiki
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r py sound
-
- dodoc Readme.txt Thanks.txt
- prepgamesdirs
-}
-
-pkg_setup() {
- python_pkg_setup
- python_set_active_version 2
- games_pkg_setup
-}