summaryrefslogtreecommitdiff
path: root/games-roguelike/rogue
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/rogue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/rogue')
-rw-r--r--games-roguelike/rogue/Manifest1
-rw-r--r--games-roguelike/rogue/metadata.xml5
-rw-r--r--games-roguelike/rogue/rogue-5.4.4.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-roguelike/rogue/Manifest b/games-roguelike/rogue/Manifest
new file mode 100644
index 00000000000..d32fbf45420
--- /dev/null
+++ b/games-roguelike/rogue/Manifest
@@ -0,0 +1 @@
+DIST rogue5.4.4-src.tar.gz 209839 SHA256 7d37a61fc098bda0e6fac30799da347294067e8e079e4b40d6c781468e08e8a1 SHA512 d83f6f953ca8e18630cd8e459b7219393969ab1d6b56c2c0d1fd18d5e2a48e3964300916bcf968d52700973bab60811b73183df1ec89b4e37145a0848586402f WHIRLPOOL 09f63827df6378fb2568824bf0cc8381594831f1a26995449567d9a947d34803a4e33e8526c06f7b2c3a04640181cbe1cd4cd663f089e43fd1c45830994b9952
diff --git a/games-roguelike/rogue/metadata.xml b/games-roguelike/rogue/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-roguelike/rogue/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-roguelike/rogue/rogue-5.4.4.ebuild b/games-roguelike/rogue/rogue-5.4.4.ebuild
new file mode 100644
index 00000000000..b002abe626e
--- /dev/null
+++ b/games-roguelike/rogue/rogue-5.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_P=${PN}${PV}
+DESCRIPTION="The original graphical adventure game that spawned an entire genre"
+HOMEPAGE="http://rogue.rogueforge.net/"
+SRC_URI="http://rogue.rogueforge.net/files/rogue5.4/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses[-tinfo]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf \
+ --enable-scorefile="${GAMES_STATEDIR}/${PN}/${PN}.scr" \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}