summaryrefslogtreecommitdiff
path: root/games-rpg/dungeon-defenders
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/dungeon-defenders
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/dungeon-defenders')
-rw-r--r--games-rpg/dungeon-defenders/Manifest1
-rw-r--r--games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild102
-rw-r--r--games-rpg/dungeon-defenders/metadata.xml11
3 files changed, 114 insertions, 0 deletions
diff --git a/games-rpg/dungeon-defenders/Manifest b/games-rpg/dungeon-defenders/Manifest
new file mode 100644
index 00000000000..f09fc5970a8
--- /dev/null
+++ b/games-rpg/dungeon-defenders/Manifest
@@ -0,0 +1 @@
+DIST dundef-linux-03052013.mojo.run 5384683543 SHA256 bc81021859871169285111ef7b1806952dcc17b128f3e387d9b5072918490c61 SHA512 911d1691411d870cee62d08b0c559ac80588edc9ba0c9d622c7528f7f8635d86eae962f7a2b1bfed27be1d780c033216374f69072ed7828e8624855e9b0b9aca WHIRLPOOL a5d75261ad542cf182829d6bd9cb053696d2228e44a6560a400e26f0697d9993037410cb9a2311e882b5076aefc612ba4b490d709ee281a6422b122e2a644402
diff --git a/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild b/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild
new file mode 100644
index 00000000000..d196226f1db
--- /dev/null
+++ b/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle SDL-2 when it gets released
+
+EAPI=5
+inherit check-reqs eutils gnome2-utils unpacker games
+
+TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
+MY_PN="DungeonDefenders"
+DESCRIPTION="A hybrid of two hot genres: Tower Defense and cooperative online Action-RPG"
+HOMEPAGE="http://dungeondefenders.com/"
+SRC_URI="dundef-linux-${TIMESTAMP}.mojo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/UDKGame/Binaries/${MY_PN}-x86
+ ${MYGAMEDIR#/}/UDKGame/Binaries/libSDL2-2.0.so.0"
+CHECKREQS_DISK_BUILD="5916M"
+
+# linked against pulseaudio
+# without SDL-2 only linkage: opengl, openal
+DEPEND="app-arch/unzip"
+RDEPEND="
+ x11-misc/xdg-utils
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=media-sound/pulseaudio-5.0[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXScrnSaver[abi_x86_32(-)]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXinerama[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ !bundled-libs? ( >=media-libs/openal-1.15.1[abi_x86_32(-)] )"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ # https://bugzilla.icculus.org/show_bug.cgi?id=5894
+ sed -i \
+ -e 's/LobbyLevel_Valentines2013.udk/LobbyLevel.udk/' \
+ UDKGame/Config/DefaultDunDef.ini || die
+
+ # Remove the binaries that we're unbundling and unnecessary stuff
+ rm -v UDKGame/Binaries/xdg-open || die
+ if ! use bundled-libs ; then
+ einfo "Removing bundled libs..."
+ rm -v UDKGame/Binaries/libopenal.so.1 || die
+ fi
+}
+
+src_install() {
+ # Move the data rather than copying. The game consumes over 5GB so
+ # a needless copy should really be avoided!
+ dodir "${MYGAMEDIR}"
+ mv -v Engine UDKGame "${D}${MYGAMEDIR}" || die
+
+ # use system xdg-open script, location is hardcoded
+ dosym /usr/bin/xdg-open "${MYGAMEDIR}"/UDKGame/Binaries/xdg-open
+
+ newicon -s 48 DunDefIcon.png ${PN}.png
+ make_desktop_entry "${PN}" "Dungeon Defenders"
+ games_make_wrapper ${PN} "./${MY_PN}-x86" "${MYGAMEDIR}/UDKGame/Binaries"
+
+ dodoc README-linux.txt
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/dungeon-defenders/metadata.xml b/games-rpg/dungeon-defenders/metadata.xml
new file mode 100644
index 00000000000..d13413d31d9
--- /dev/null
+++ b/games-rpg/dungeon-defenders/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+