summaryrefslogtreecommitdiff
path: root/games-rpg/nwn-shadowlordsdreamcatcherdemon
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/nwn-shadowlordsdreamcatcherdemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/nwn-shadowlordsdreamcatcherdemon')
-rw-r--r--games-rpg/nwn-shadowlordsdreamcatcherdemon/Manifest1
-rw-r--r--games-rpg/nwn-shadowlordsdreamcatcherdemon/metadata.xml9
-rw-r--r--games-rpg/nwn-shadowlordsdreamcatcherdemon/nwn-shadowlordsdreamcatcherdemon-1.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/games-rpg/nwn-shadowlordsdreamcatcherdemon/Manifest b/games-rpg/nwn-shadowlordsdreamcatcherdemon/Manifest
new file mode 100644
index 00000000000..623b744f9bf
--- /dev/null
+++ b/games-rpg/nwn-shadowlordsdreamcatcherdemon/Manifest
@@ -0,0 +1 @@
+DIST ShadowlordsDreamcatcherDemon.exe 157055254 SHA256 6f1197ae79da447e72d1d894d51265c534f5406583e1e8905907396a488cf62c SHA512 8ac3b47df35c2ee3baba6ca27e027cf5f8f83e7583e342725741a4721462621bf6b8f65d8337cfefc51cc0420d0d0d8d2acc2255793a7705f35b3d56d3a933dd WHIRLPOOL e23fb9ff3112e0514d36d59ee9405f6d635facfd206db86ee9bb668333b2a9ac68fe2a7ab766dce6d3987fac4a6696173abb33583cff8c7cf49a75c1af2908e1
diff --git a/games-rpg/nwn-shadowlordsdreamcatcherdemon/metadata.xml b/games-rpg/nwn-shadowlordsdreamcatcherdemon/metadata.xml
new file mode 100644
index 00000000000..95d7ea2ffa6
--- /dev/null
+++ b/games-rpg/nwn-shadowlordsdreamcatcherdemon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/nwn-shadowlordsdreamcatcherdemon/nwn-shadowlordsdreamcatcherdemon-1.ebuild b/games-rpg/nwn-shadowlordsdreamcatcherdemon/nwn-shadowlordsdreamcatcherdemon-1.ebuild
new file mode 100644
index 00000000000..04ba9e84246
--- /dev/null
+++ b/games-rpg/nwn-shadowlordsdreamcatcherdemon/nwn-shadowlordsdreamcatcherdemon-1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit games
+
+DESCRIPTION="The bundled Shadowlords, Dreamcatcher, and Demon campaigns by Hall-of-Famer Adam Miller"
+HOMEPAGE="http://www.adamandjamie.com/mod/nwn_campaign.aspx"
+SRC_URI="http://vnfiles.ign.com/nwvault.ign.com/fms/files/modules/4273/ShadowlordsDreamcatcherDemon.exe"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/p7zip"
+RDEPEND="games-rpg/nwn"
+
+src_unpack() {
+ 7z x "${DISTDIR}/ShadowlordsDreamcatcherDemon.exe" || die "Unpacking failed"
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}"/nwn/modules
+ doins *.mod || die "Installing modules failed"
+
+ insinto "${GAMES_PREFIX_OPT}"/nwn/hak
+ doins *.hak || die "Installing hak files failed"
+
+ insinto "${GAMES_PREFIX_OPT}"/nwn/music
+ doins *.bmu || die "Installing music failed"
+
+ insinto "${GAMES_PREFIX_OPT}"/nwn/movies
+ doins *.bik || die "Installing movies failed"
+
+ insinto "${GAMES_PREFIX_OPT}"/nwn/shadowlords_dreamcatcher_demon
+ doins *.txt || die "Installing documentation failed"
+
+ prepgamesdirs
+}