summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/corsix-th
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/corsix-th')
-rw-r--r--games-simulation/corsix-th/Manifest2
-rw-r--r--games-simulation/corsix-th/corsix-th-0.21-r1.ebuild62
-rw-r--r--games-simulation/corsix-th/corsix-th-0.30.ebuild92
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.21-naming.patch17
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.30-install.patch40
-rw-r--r--games-simulation/corsix-th/files/corsix-th-nodoc.patch11
-rw-r--r--games-simulation/corsix-th/metadata.xml24
7 files changed, 248 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
new file mode 100644
index 00000000000..53f07f34557
--- /dev/null
+++ b/games-simulation/corsix-th/Manifest
@@ -0,0 +1,2 @@
+DIST CorsixTH-0.21-Source.tar.gz 3908197 SHA256 9a8b54644e614dc13d4b5d97bf023b8e023e0186f931695b8f4ec7e4577a4ead SHA512 6f75772a7af0a09d216f042eda437e4159061637b404c0282472dab4751b7d515e25c6a922bb51051cfe7c351396491ac68d7969e3f37dafb1862fb6c85b6b52 WHIRLPOOL 69e3a57581e0a7446fda839284d2200ed8be559403504a42cfa187c8180689b175a96fb7b15b2b124ac3605dd936190f8ee882f4ea464acdc81157f598b0b20a
+DIST corsix-th-0.30.tar.gz 4345385 SHA256 4947ebdc50b01fde0aca797250d50b9806b9e6f3f4323872fd914f033f4c92e7 SHA512 1afd9d68dd6db82393e454e2c234179029902b701aafe4d2ca76381be195acba55f0ee062ce071a78cf3f5e8762e25452f386276aecc1af816553532b870964a WHIRLPOOL b01a1d72c0408c1d7d7d0a72e55c9b9f0863acfe064c07f4920c3f66bfb29fb0acf0a7e4e1d80e214b2e81d073e070427fbd8fca9cd34e14cda561159a88d4d0
diff --git a/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild b/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
new file mode 100644
index 00000000000..e0a87fb1a91
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils games
+
+MY_P="CorsixTH-${PV}-Source"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="http://code.google.com/p/corsix-th/"
+SRC_URI="http://corsix-th.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg truetype opengl +sdl +sound +midi"
+REQUIRED_USE="|| ( sdl opengl )"
+
+RDEPEND=">=dev-lang/lua-5.1
+ media-libs/libsdl[X]
+ ffmpeg? ( virtual/ffmpeg )
+ truetype? ( media-libs/freetype:2 )
+ opengl? ( virtual/opengl )
+ sound? ( media-libs/sdl-mixer )
+ midi? ( media-libs/sdl-mixer[timidity] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-nodoc.patch"
+
+ # Use a coherent naming for installation dir
+ epatch "${FILESDIR}/${P}-naming.patch"
+}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_with opengl OPENGL) \
+ $(cmake-utils_use_with sdl SDL) \
+ $(cmake-utils_use_with sound AUDIO) \
+ $(cmake-utils_use_with truetype FREETYPE2) \
+ $(cmake-utils_use_with ffmpeg MOVIES) \
+ -DCMAKE_INSTALL_PREFIX=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ DOCS="CorsixTH/README.txt CorsixTH/changelog.txt" cmake-utils_src_install
+ games_make_wrapper ${PN} "${GAMES_DATADIR}/${PN}/CorsixTH" || die
+ make_desktop_entry ${PN} ${PN} \
+ "${GAMES_DATADIR}/${PN}/CorsixTH.ico"
+ prepgamesdirs
+}
diff --git a/games-simulation/corsix-th/corsix-th-0.30.ebuild b/games-simulation/corsix-th/corsix-th-0.30.ebuild
new file mode 100644
index 00000000000..b62d08cd16c
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.30.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+WX_GTK_VER="3.0"
+inherit eutils cmake-utils gnome2-utils wxwidgets games
+
+MY_P="CorsixTH-${PV}-Source"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="https://github.com/CorsixTH/CorsixTH"
+SRC_URI="https://github.com/CorsixTH/CorsixTH/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg mapeditor truetype opengl +sound"
+
+RDEPEND=">=dev-lang/lua-5.1
+ media-libs/libsdl[X]
+ ffmpeg? ( virtual/ffmpeg )
+ mapeditor? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ truetype? ( media-libs/freetype:2 )
+ opengl? ( virtual/opengl )
+ sound? ( media-libs/sdl-mixer )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/CorsixTH-${PV}
+
+pkg_setup() {
+ games_pkg_setup
+
+ if use mapeditor && use !opengl ; then
+ eerror "need opengl enabled for mapeditor to work!"
+ die "need opengl enabled for mapeditor to work!"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OPENGL)
+ $(cmake-utils_use_with sound AUDIO)
+ $(cmake-utils_use_with truetype FREETYPE2)
+ $(cmake-utils_use_with ffmpeg MOVIES)
+ $(cmake-utils_use_build mapeditor MAPEDITOR)
+ -DCMAKE_INSTALL_PREFIX="${GAMES_DATADIR}"
+ -DBINDIR="$(games_get_libdir)/${PN}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ DOCS="CorsixTH/changelog.txt" cmake-utils_src_install
+ games_make_wrapper ${PN} "$(games_get_libdir)/${PN}/CorsixTH" \
+ "${GAMES_DATADIR}/CorsixTH"
+ games_make_wrapper ${PN}-mapedit "$(games_get_libdir)/${PN}/MapEdit" \
+ "${GAMES_DATADIR}/CorsixTH"
+ newicon -s scalable CorsixTH/Original_Logo.svg ${PN}.svg
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " media-libs/sdl-mixer[timidity] (MIDI sound support)"
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch b/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch
new file mode 100644
index 00000000000..b82b5fa9129
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch
@@ -0,0 +1,17 @@
+--- CorsixTH/CMakeLists.txt 2013-07-26 19:35:30.463506153 +0200
++++ CorsixTH/CMakeLists.txt.new 2013-07-26 19:38:07.944473631 +0200
+@@ -222,10 +222,10 @@
+ ENDIF()
+
+ ELSE()
+- install(TARGETS CorsixTH RUNTIME DESTINATION CorsixTH)
+- install(DIRECTORY Lua Levels DESTINATION CorsixTH PATTERN "*.svn" EXCLUDE)
+- install(DIRECTORY Bitmap DESTINATION CorsixTH
++ install(TARGETS CorsixTH RUNTIME DESTINATION corsix-th)
++ install(DIRECTORY Lua Levels DESTINATION corsix-th PATTERN "*.svn" EXCLUDE)
++ install(DIRECTORY Bitmap DESTINATION corsix-th
+ FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
+ PATTERN "*.svn" EXCLUDE)
+- install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
++ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION corsix-th )
+ ENDIF()
diff --git a/games-simulation/corsix-th/files/corsix-th-0.30-install.patch b/games-simulation/corsix-th/files/corsix-th-0.30-install.patch
new file mode 100644
index 00000000000..6c84bb09870
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.30-install.patch
@@ -0,0 +1,40 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 12 21:30:07 UTC 2014
+Subject:
+
+--- MapEdit/CMakeLists.txt
++++ MapEdit/CMakeLists.txt
+@@ -207,5 +207,5 @@
+ ENDIF()
+
+ ELSE()
+- install(TARGETS MapEdit RUNTIME DESTINATION CorsixTH)
++ install(TARGETS MapEdit RUNTIME DESTINATION ${BINDIR})
+ ENDIF()
+--- CorsixTH/CMakeLists.txt
++++ CorsixTH/CMakeLists.txt
+@@ -223,10 +223,10 @@
+ ENDIF()
+
+ ELSE()
+- install(TARGETS CorsixTH RUNTIME DESTINATION CorsixTH)
++ install(TARGETS CorsixTH RUNTIME DESTINATION ${BINDIR})
+ install(DIRECTORY Lua Levels DESTINATION CorsixTH PATTERN "*.svn" EXCLUDE)
+ install(DIRECTORY Bitmap DESTINATION CorsixTH
+ FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
+ PATTERN "*.svn" EXCLUDE)
+- install(FILES CorsixTH.lua LICENSE.txt CorsixTH.ico DESTINATION CorsixTH )
++ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
+ ENDIF()
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -25,6 +25,9 @@
+ SET(CMAKE_OSX_DEPLOYMENT_TARGET 10.5)
+ ENDIF()
+
++# paths
++set(BINDIR bin CACHE PATH "where to install binaries")
++
+ # Define our options
+ OPTION(WITH_OPENGL "Activate OpenGL Renderer" OFF)
+ OPTION(WITH_DIRECTX "Activate DirectX Renderer" OFF)
diff --git a/games-simulation/corsix-th/files/corsix-th-nodoc.patch b/games-simulation/corsix-th/files/corsix-th-nodoc.patch
new file mode 100644
index 00000000000..0fcae9bcd70
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-nodoc.patch
@@ -0,0 +1,11 @@
+diff --git a/CorsixTH/CMakeLists.txt b/CorsixTH/CMakeLists.txt
+index dfdb59e..9b97b3c 100755
+--- a/CorsixTH/CMakeLists.txt
++++ b/CorsixTH/CMakeLists.txt
+@@ -191,5 +191,5 @@ ELSE()
+ install(DIRECTORY Bitmap DESTINATION CorsixTH
+ FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
+ PATTERN "*.svn" EXCLUDE)
+- install(FILES CorsixTH.lua LICENSE.txt CorsixTH.ico DESTINATION CorsixTH )
++ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
+ ENDIF()
diff --git a/games-simulation/corsix-th/metadata.xml b/games-simulation/corsix-th/metadata.xml
new file mode 100644
index 00000000000..4adeb5616a3
--- /dev/null
+++ b/games-simulation/corsix-th/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>miknix@gentoo.org</email>
+ <name>Angelo Arrifano</name>
+ </maintainer>
+ <use>
+ <flag name="ffmpeg">Use ffmpeg for playing in-game cutscenes.</flag>
+ <flag name="opengl">Use OpenGL for rendering.</flag>
+ <flag name="sdl">Use SDL for rendering.</flag>
+ <flag name="sound">Use SDL mixer for in-game sound.</flag>
+ <flag name="mapeditor">Build the map editor (needs opengl enabled!).
+ </flag>
+ <flag name="midi">Use SDL mixer and timidity for in-game music.</flag>
+ <flag name="truetype">Use high quality fonts.</flag>
+ </use>
+ <longdescription>
+ CorsixTH aims to reimplement the game engine of Theme Hospital, with the capability of loading assets including graphics and levels from the original game. This means that you will need a purchased copy of Theme Hospital, or a copy of the demo, in order to use CorsixTH.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">CorsixTH/CorsixTH</remote-id>
+ </upstream>
+</pkgmetadata>