summaryrefslogtreecommitdiff
path: root/games-sports/stormbaancoureur
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/stormbaancoureur
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/stormbaancoureur')
-rw-r--r--games-sports/stormbaancoureur/Manifest1
-rw-r--r--games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch110
-rw-r--r--games-sports/stormbaancoureur/metadata.xml5
-rw-r--r--games-sports/stormbaancoureur/stormbaancoureur-2.1.6.ebuild39
4 files changed, 155 insertions, 0 deletions
diff --git a/games-sports/stormbaancoureur/Manifest b/games-sports/stormbaancoureur/Manifest
new file mode 100644
index 00000000000..616e3e26210
--- /dev/null
+++ b/games-sports/stormbaancoureur/Manifest
@@ -0,0 +1 @@
+DIST stormbaancoureur-2.1.6.tar.gz 3976459 SHA256 c6bd67695734fd430ce8e8d744710531ed4dae1bc78d5cd0529af930144e7903 SHA512 af949efc966aa088e75aadae27cd6b7e4e342d3fa00563a756ce6fb90b0ea64071f2e85087644fb6472db81c6a92584b485c5dcc71653cc54d90231e60bafd08 WHIRLPOOL 56917ebaa653ebb4271234f6e8fd0af96c246063e2f6eb4227055250b4e3f67ea6d4a64b1141b05a8546b4f6c4d085ba6935b77d48343921a87c8926e34a289a
diff --git a/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch
new file mode 100644
index 00000000000..07413ecb544
--- /dev/null
+++ b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch
@@ -0,0 +1,110 @@
+--- stormbaancoureur-2.1.6.orig/src-stormbaancoureur/Makefile
++++ stormbaancoureur-2.1.6/src-stormbaancoureur/Makefile
+@@ -5,21 +5,21 @@
+ GLPREFIX=/usr
+ PLIBPREFIX=/usr
+ ODEPREFIX=/usr
+-CXX=g++
+ LIBDIRNAME=lib
+
+ # END OF CUSTOM SETTINGS
+
+-CXXFLAGS=\
++LCXXFLAGS:=\
+ -I$(GLPREFIX)/include \
+ -I$(ODEPREFIX)/include \
+ -I$(PLIBPREFIX)/include \
+ -I../src-common \
+ -I. \
+ -DGAMEVERSION=$(VERSION) \
+- -O2 -g -Wall
++ $(shell ode-config --cflags) \
++ $(CXXFLAGS)
+
+-LFLAGS=\
++LFLAGS= $(LDFLAGS) \
+ -L$(PLIBPREFIX)/$(LIBDIRNAME) \
+ -L/usr/X11R6/$(LIBDIRNAME)
+
+@@ -39,7 +38,7 @@
+
+
+ LIBS=\
+- $(ODEPREFIX)/$(LIBDIRNAME)/libode.a \
++ -lode \
+ -lplibssgaux -lplibssg -lplibsg -lplibpu -lplibfnt -lplibul \
+ -lglut -lGLU -lGL -lasound
+
+@@ -47,41 +46,41 @@
+ all: stormbaancoureur
+
+
+-stormbaancoureur: $(OBJS) $(ODEPREFIX)/$(LIBDIRNAME)/libode.a
++stormbaancoureur: $(OBJS)
+ $(CXX) -o stormbaancoureur $(OBJS) $(LFLAGS) $(LIBS)
+
+ staticworldobject.o: ../src-common/staticworldobject.cxx ../src-common/staticworldobject.h ../src-common/worldobject.h
+- $(CXX) -c $(CXXFLAGS) ../src-common/staticworldobject.cxx
++ $(CXX) -c $(LCXXFLAGS) ../src-common/staticworldobject.cxx
+
+ dynamicobject.o: ../src-common/dynamicobject.cxx ../src-common/dynamicobject.h ../src-common/worldobject.h
+- $(CXX) -c $(CXXFLAGS) ../src-common/dynamicobject.cxx
++ $(CXX) -c $(LCXXFLAGS) ../src-common/dynamicobject.cxx
+
+ carobject.o: carobject.cxx carobject.h
+- $(CXX) -c $(CXXFLAGS) carobject.cxx
++ $(CXX) -c $(LCXXFLAGS) carobject.cxx
+
+ controllerpad.o: controllerpad.cxx controller.h ../src-common/joydb.h
+- $(CXX) -c $(CXXFLAGS) controllerpad.cxx
++ $(CXX) -c $(LCXXFLAGS) controllerpad.cxx
+
+ controllerkey.o: controllerkey.cxx
+- $(CXX) -c $(CXXFLAGS) controllerkey.cxx
++ $(CXX) -c $(LCXXFLAGS) controllerkey.cxx
+
+ intro.o: intro.cxx intro.h
+- $(CXX) -c $(CXXFLAGS) intro.cxx
++ $(CXX) -c $(LCXXFLAGS) intro.cxx
+
+ vectortext.o: ../src-common/vectortext.cxx ../src-common/vectortext.h
+- $(CXX) -c $(CXXFLAGS) ../src-common/vectortext.cxx
++ $(CXX) -c $(LCXXFLAGS) ../src-common/vectortext.cxx
+
+ postscore.o: postscore.cxx postscore.h
+- $(CXX) -c $(CXXFLAGS) postscore.cxx
++ $(CXX) -c $(LCXXFLAGS) postscore.cxx
+
+ soundenginealsa.o: ../src-common/soundenginealsa.cxx ../src-common/soundenginealsa.h ../src-common/soundfeed.h ../src-common/soundclip.h
+- $(CXX) -c $(CXXFLAGS) ../src-common/soundenginealsa.cxx
++ $(CXX) -c $(LCXXFLAGS) ../src-common/soundenginealsa.cxx
+
+ ogl.o: ../src-common/ogl.cxx
+- $(CXX) -c $(CXXFLAGS) ../src-common/ogl.cxx
++ $(CXX) -c $(LCXXFLAGS) ../src-common/ogl.cxx
+
+ main.o: main.cxx ../src-common/usercam.h ../src-common/trackingcam.h ../src-common/soundenginealsa.h cratewall.h controller.h intro.h plodegui.h doorstand.h carpettrack.h spikejump.h ferriswheel.h turntable.h sturmbahn.h ../src-common/modelmap.h starsky.h carobject.h respawnpoint.h
+- $(CXX) -c $(CXXFLAGS) main.cxx
++ $(CXX) -c $(LCXXFLAGS) main.cxx
+
+ debugrun: stormbaancoureur
+ PLODE_DATADIR=`pwd` gdb ./stormbaancoureur
+--- stormbaancoureur-2.1.6.orig/src-stormbaancoureur/main.cxx
++++ stormbaancoureur-2.1.6/src-stormbaancoureur/main.cxx
+@@ -836,15 +836,7 @@
+ fprintf(stderr,"plib is (c) by Steve Baker\n");
+ fprintf(stderr,"OpenDE is (c) by Russel L. Smith\n");
+
+- char *bindirname = dirname(argv[0]);
+- if (!strcmp(bindirname,"."))
+- dirprefix="/usr/share/games/stormbaancoureur";
+- else
+- {
+- dirprefix = dirname(bindirname) + std::string("/share/games/stormbaancoureur");
+- }
+- if (getenv("PLODE_DATADIR"))
+- dirprefix = getenv("PLODE_DATADIR");
++ dirprefix="GENTOODIR";
+ if (getenv("PLODE_DISPLAYMODE"))
+ displaymode = getenv("PLODE_DISPLAYMODE");
+ assert(displaymode == "monoscopic" || displaymode == "quadbufferstereoscopic" || displaymode == "passivestereoscopic");
diff --git a/games-sports/stormbaancoureur/metadata.xml b/games-sports/stormbaancoureur/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-sports/stormbaancoureur/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-sports/stormbaancoureur/stormbaancoureur-2.1.6.ebuild b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6.ebuild
new file mode 100644
index 00000000000..6541d22fb01
--- /dev/null
+++ b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Simulated obstacle course for automobiles"
+HOMEPAGE="http://www.stolk.org/stormbaancoureur/"
+SRC_URI="http://www.stolk.org/stormbaancoureur/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ >=dev-games/ode-0.8
+ >=media-libs/plib-1.8.4
+ media-libs/alsa-lib"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P}/src-${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -ie "s:GENTOODIR:${GAMES_DATADIR}/${PN}:" main.cxx || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images/ models/ sounds/ shaders/
+ dodoc JOYSTICKS README TODO
+ make_desktop_entry ${PN} "Stormbaan Coureur"
+ prepgamesdirs
+}