summaryrefslogtreecommitdiff
path: root/games-sports/torcs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/torcs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/torcs')
-rw-r--r--games-sports/torcs/Manifest1
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-as-needed.patch96
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-flags.patch14
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-no-automake.patch21
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch15
-rw-r--r--games-sports/torcs/metadata.xml8
-rw-r--r--games-sports/torcs/torcs-1.3.6.ebuild63
7 files changed, 218 insertions, 0 deletions
diff --git a/games-sports/torcs/Manifest b/games-sports/torcs/Manifest
new file mode 100644
index 00000000000..d1defc2be57
--- /dev/null
+++ b/games-sports/torcs/Manifest
@@ -0,0 +1 @@
+DIST torcs-1.3.6.tar.bz2 477954437 SHA256 193cb1820170eb18335dffeaa345499229a4b7972a78acbfaca197597a3075af SHA512 4116c920b92ecbf5dcd3f14a137e86685651167f68725f2ad4549b2d3d20e3dc54569685925e08ffff6e7e19e532ecb1a95ec77dfe22a542a26c9e006b0c8c0d WHIRLPOOL 41579dc91f3df9950a9808d7c858f736b0218a781bf8565914097edca4ba2918ea6f5434335f5f6fae488d391bbce2f7c68be613fbd95825575497d093124f10
diff --git a/games-sports/torcs/files/torcs-1.3.6-as-needed.patch b/games-sports/torcs/files/torcs-1.3.6-as-needed.patch
new file mode 100644
index 00000000000..d848538c07e
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-as-needed.patch
@@ -0,0 +1,96 @@
+--- torcs-1.3.6.orig/Make-default.mk
++++ torcs-1.3.6/Make-default.mk
+@@ -402,7 +402,7 @@
+ ifdef PROGRAM
+
+ ${PROGRAM}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${SOLIBS} ${EXT_LIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installprogram: ${PROGRAM}
+ @ createdir="${INSTLIBBASE}" ; \
+@@ -420,14 +420,14 @@
+ ifdef LOCALTOOLS
+
+ ${LOCALTOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ endif
+
+ ifdef TOOLS
+
+ ${TOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installtools: ${TOOLS}
+ @createdir="${INSTBINBASE}/${TOOLSDIR}" ; \
+@@ -478,7 +478,7 @@
+ ifdef SOLIBRARY
+
+ ${SOLIBRARY}: ${OBJECTS}
+- ${CXX} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LDFLAGS} ${LIBSPATH} ${LIBS} ${DEBUG_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/lib" ; \
+ $(mkinstalldirs) $$createdir ; \
+@@ -509,7 +509,7 @@
+ ifdef MODULE
+
+ ${MODULE}: ${OBJECTS}
+- ${CXX} -shared -o ${MODULE} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${MODULE} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/${MODULEDIR}" ; \
+ $(mkinstalldirs) $$createdir ; \
+--- torcs-1.3.6.orig/configure.in
++++ torcs-1.3.6/configure.in
+@@ -123,11 +123,11 @@
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSetViewPort,,AC_MSG_ERROR([Can't find libXxf86vm. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrender, XRenderSetSubpixelOrder,,AC_MSG_ERROR([Can't find libXrender. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-AC_CHECK_LIB(openal, alEnable, LDFLAGS="$LDFLAGS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
++AC_CHECK_LIB(openal, alEnable, LIBS="$LIBS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
+ AC_CHECK_LIB(alut, alutLoadWAVFile,
+- LDFLAGS="$LDFLAGS -lalut",
+- LDFLAGS="$LDFLAGS")
+-AC_CHECK_LIB(vorbisfile, ov_fopen, LDFLAGS="$LDFLAGS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
++ LIBS="$LIBS -lalut", )
++AC_CHECK_LIB(vorbisfile, ov_fopen, LIBS="$LIBS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
++
+
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_FUNC(dlopen,,AC_MSG_ERROR([Can't find dlopen function. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+--- torcs-1.3.6.orig/src/libs/Makefile
++++ torcs-1.3.6/src/libs/Makefile
+@@ -23,7 +23,7 @@
+
+ TOOLSUBDIRS = txml
+
+-SUBDIRS = confscreens racescreens robottools txml tgf tgfclient client raceengineclient learning \
++SUBDIRS = confscreens racescreens robottools txml tgf tgfclient raceengineclient client learning \
+ portability math musicplayer
+
+ PKGSUBDIRS = $(SUBDIRS)
+--- torcs-1.3.6.orig/src/libs/client/Makefile
++++ torcs-1.3.6/src/libs/client/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = entry.cpp mainmenu.cpp splash.cpp exitmenu.cpp \
+ optionmenu.cpp
+
++SOLIBS = -lconfscreens -lraceengine
++
+ LIBS = -lplibssg -lplibsg -lplibul
+
+ EXPDIR = include
+--- torcs-1.3.6.orig/src/libs/tgf/Makefile
++++ torcs-1.3.6/src/libs/tgf/Makefile
+@@ -29,6 +29,7 @@
+ profiler.cpp \
+ hash.cpp
+
++SOLIBS = -ltxml
+
+ EXPDIR = include
+
diff --git a/games-sports/torcs/files/torcs-1.3.6-flags.patch b/games-sports/torcs/files/torcs-1.3.6-flags.patch
new file mode 100644
index 00000000000..5f11fd270ef
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-flags.patch
@@ -0,0 +1,14 @@
+respect cflags
+
+--- torcs-1.3.6/configure.in
++++ torcs-1.3.6/configure.in
+@@ -50,8 +50,7 @@
+ ADDCFLAGS="-Wall -fPIC -fno-strict-aliasing"
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug set the debug mode],
+- ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT",
+- ADDCFLAGS="$ADDCFLAGS -O2")
++ ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT")
+
+ AC_ARG_ENABLE(xrandr,
+ [ --disable-xrandr reset the XRANDR mode],
diff --git a/games-sports/torcs/files/torcs-1.3.6-no-automake.patch b/games-sports/torcs/files/torcs-1.3.6-no-automake.patch
new file mode 100644
index 00000000000..9b47bfb9a64
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-no-automake.patch
@@ -0,0 +1,21 @@
+torcs doesn't use automake, so it shouldn't be calling the macro
+
+http://bugs.gentoo.org/408473
+
+--- torcs-1.3.6.orig/configure.in
++++ torcs-1.3.6/configure.in
+@@ -15,9 +15,12 @@
+ #
+ ##############################################################################
+
+-AC_INIT(Make-config.in)
++AC_INIT(torcs, 1.3.6)
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE(torcs, 1.3.6)
++dnl Workaround code using old VERSION instead of new PACKAGE_VERSION
++VERSION=$PACKAGE_VERSION
++AC_DEFINE_UNQUOTED([VERSION], "$VERSION", [old VERSION workaround])
++AC_SUBST(VERSION)
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch b/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch
new file mode 100644
index 00000000000..6f4a2e40622
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch
@@ -0,0 +1,15 @@
+--- configure.in.old
++++ configure.in
+@@ -116,12 +116,8 @@
+ AC_CHECK_LIB(ICE, IceSetIOErrorHandler,,AC_MSG_ERROR([Can't find libICE. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ dnl Replace `main' with a function in -lSM:
+ AC_CHECK_LIB(SM, SmsSetErrorHandler,,AC_MSG_ERROR([Can't find libSM. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-dnl Replace `main' with a function in -lXt:
+-AC_CHECK_LIB(Xt, XtDisplay,,AC_MSG_ERROR([Can't find libXt. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ dnl Replace `main' with a function in -lXi:
+ AC_CHECK_LIB(Xi, XOpenDevice,,AC_MSG_ERROR([Can't find libXi. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-dnl Replace `main' with a function in -lXmu:
+-AC_CHECK_LIB(Xmu, XmuSimpleErrorHandler,,AC_MSG_ERROR([Can't find libXmu. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSetViewPort,,AC_MSG_ERROR([Can't find libXxf86vm. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrender, XRenderSetSubpixelOrder,,AC_MSG_ERROR([Can't find libXrender. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
diff --git a/games-sports/torcs/metadata.xml b/games-sports/torcs/metadata.xml
new file mode 100644
index 00000000000..383b10b59a6
--- /dev/null
+++ b/games-sports/torcs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">torcs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-sports/torcs/torcs-1.3.6.ebuild b/games-sports/torcs/torcs-1.3.6.ebuild
new file mode 100644
index 00000000000..4c01238e299
--- /dev/null
+++ b/games-sports/torcs/torcs-1.3.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib games
+
+DESCRIPTION="The Open Racing Car Simulator"
+HOMEPAGE="http://torcs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/torcs/${P}.tar.bz2"
+
+LICENSE="GPL-2 FreeArt"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/freealut
+ media-libs/freeglut
+ media-libs/libpng:0
+ media-libs/libvorbis:=
+ media-libs/openal
+ >=media-libs/plib-1.8.5
+ sys-libs/zlib:0=
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-no-automake.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-noXmuXt.patch
+ eautoreconf
+ ecvs_clean
+}
+
+src_configure() {
+ addpredict $(echo /dev/snd/controlC? | sed 's/ /:/g')
+ [[ -e /dev/dsp ]] && addpredict /dev/dsp
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ --x-libraries=/usr/$(get_libdir) \
+ --enable-xrandr
+}
+
+src_compile() {
+ # So ugly... patches welcome.
+ emake -j1
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install datainstall
+ newicon Ticon.png ${PN}.png
+ make_desktop_entry ${PN} TORCS
+ dodoc README doc/history/history.txt
+ doman doc/man/*.6
+ dohtml -r doc/faq/faq.html doc/tutorials doc/userman
+ prepgamesdirs
+}