summaryrefslogtreecommitdiff
path: root/games-sports
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-03-30 20:25:35 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-04 23:33:40 +0200
commit12df4e984cec6f375feacf528c44ae00c4c4e6b2 (patch)
tree265f286b999b0527df432c578d7e16fa8ce33a7c /games-sports
parentf602ce29a225b52165cf735a263c65a6a8774f36 (diff)
downloadgentoo-12df4e984cec6f375feacf528c44ae00c4c4e6b2.tar.gz
gentoo-12df4e984cec6f375feacf528c44ae00c4c4e6b2.tar.xz
games-sports/torcs: Fix building with GCC-7
Closes: https://bugs.gentoo.org/631542 Package-Manager: Portage-2.3.16, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7728
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-gcc7.patch11
-rw-r--r--games-sports/torcs/torcs-1.3.6-r1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc7.patch b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
new file mode 100644
index 00000000000..af139ad509d
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
@@ -0,0 +1,11 @@
+--- a/src/libs/musicplayer/OpenALMusicPlayer.cpp
++++ b/src/libs/musicplayer/OpenALMusicPlayer.cpp
+@@ -161,7 +161,7 @@
+ {
+ char pcm[BUFFERSIZE];
+ int size = 0;
+- const char* error = '\0';
++ const char* error = "";
+
+ if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
+ GfError("OpenALMusicPlayer: Stream read error: %s\n", error);
diff --git a/games-sports/torcs/torcs-1.3.6-r1.ebuild b/games-sports/torcs/torcs-1.3.6-r1.ebuild
index c92083f6cbc..6b7ba9ad578 100644
--- a/games-sports/torcs/torcs-1.3.6-r1.ebuild
+++ b/games-sports/torcs/torcs-1.3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/${P}-format.patch
"${FILESDIR}"/${P}-noXmuXt.patch
"${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-gcc7.patch
)
src_prepare() {