summaryrefslogtreecommitdiff
path: root/games-sports
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-20 01:10:03 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-20 01:10:11 -0400
commit23aeb75ade5d9f9399cd4c89e85053ce15dc9acb (patch)
tree41b915482fbd9422baf49ecad0d6e36326b62423 /games-sports
parent2141097950010892990c644812fcea51fd270950 (diff)
downloadgentoo-23aeb75ade5d9f9399cd4c89e85053ce15dc9acb.tar.gz
gentoo-23aeb75ade5d9f9399cd4c89e85053ce15dc9acb.tar.xz
games-sports/speed-dreams: fix build w/newer glibc #580054
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/speed-dreams/files/speed-dreams-1.4.0-math-hack.patch25
-rw-r--r--games-sports/speed-dreams/speed-dreams-1.4.0.ebuild4
2 files changed, 28 insertions, 1 deletions
diff --git a/games-sports/speed-dreams/files/speed-dreams-1.4.0-math-hack.patch b/games-sports/speed-dreams/files/speed-dreams-1.4.0-math-hack.patch
new file mode 100644
index 00000000000..32b4f85a200
--- /dev/null
+++ b/games-sports/speed-dreams/files/speed-dreams-1.4.0-math-hack.patch
@@ -0,0 +1,25 @@
+https://sourceforge.net/p/speed-dreams/tickets/952/
+https://bugs.gentoo.org/580054
+
+--- a/src/modules/simu/simuv2/simu.cpp
++++ b/src/modules/simu/simuv2/simu.cpp
+@@ -61,7 +61,7 @@
+ if (isnan(car->ctrl->brakeCmd) || isinf(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
+ if (isnan(car->ctrl->clutchCmd) || isinf(car->ctrl->clutchCmd)) car->ctrl->clutchCmd = 0;
+ if (isnan(car->ctrl->steer) || isinf(car->ctrl->steer)) car->ctrl->steer = 0;
+- if (isnan(car->ctrl->gear) || isinf(car->ctrl->gear)) car->ctrl->gear = 0;
++ if (isnan((float)car->ctrl->gear) || isinf((float)car->ctrl->gear)) car->ctrl->gear = 0;
+ #else
+ if (isnan(car->ctrl->accelCmd)) car->ctrl->accelCmd = 0;
+ if (isnan(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
+--- a/src/modules/simu/simuv3/simu.cpp
++++ b/src/modules/simu/simuv3/simu.cpp
+@@ -61,7 +61,7 @@
+ if (isnan(car->ctrl->brakeCmd) || isinf(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
+ if (isnan(car->ctrl->clutchCmd) || isinf(car->ctrl->clutchCmd)) car->ctrl->clutchCmd = 0;
+ if (isnan(car->ctrl->steer) || isinf(car->ctrl->steer)) car->ctrl->steer = 0;
+- if (isnan(car->ctrl->gear) || isinf(car->ctrl->gear)) car->ctrl->gear = 0;
++ if (isnan((float)car->ctrl->gear) || isinf((float)car->ctrl->gear)) car->ctrl->gear = 0;
+ #else
+ if (isnan(car->ctrl->accelCmd)) car->ctrl->accelCmd = 0;
+ if (isnan(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
diff --git a/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
index 835908ebe8a..cee94c8cce3 100644
--- a/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
+++ b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
@@ -45,7 +45,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-asneeded.patch \
"${FILESDIR}"/${P}-automake.patch \
- "${FILESDIR}"/${P}-libpng15.patch
+ "${FILESDIR}"/${P}-libpng15.patch \
+ "${FILESDIR}"/${P}-math-hack.patch
sed -i \
-e '/ADDCFLAGS/s: -O2::' \
@@ -54,6 +55,7 @@ src_prepare() {
-e '/COPYING/s:=.*:= \\:' \
Makefile || die
sed -i \
+ -e '/LDFLAGS/s:-L/usr/lib::' \
-e "/^datadir/s:=.*:= ${GAMES_DATADIR}/${PN}:" \
Make-config.in || die