summaryrefslogtreecommitdiff
path: root/games-strategy/coldwar-demo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/coldwar-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/coldwar-demo')
-rw-r--r--games-strategy/coldwar-demo/Manifest1
-rw-r--r--games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild69
-rw-r--r--games-strategy/coldwar-demo/metadata.xml5
3 files changed, 75 insertions, 0 deletions
diff --git a/games-strategy/coldwar-demo/Manifest b/games-strategy/coldwar-demo/Manifest
new file mode 100644
index 00000000000..f0a92cdf7b7
--- /dev/null
+++ b/games-strategy/coldwar-demo/Manifest
@@ -0,0 +1 @@
+DIST coldwar-demo.run 354684447 SHA256 769ca25da2f095e85e594ee09343ea20bf353e75f3bce362b937c2fae04c52aa SHA512 12fb0b482d7914c0f04256e5daefd287f1b172106de756c486e92341beb1d85332ba29941be0ba9711dabd2f2e7332c05034103c5a2a979743901b4eeb13b4a3 WHIRLPOOL 7df09173069969d2e7f7b50896058ae1553ef58eaa528db83c294adfad41c2b27ba4c7d1ff335a3901c66f1ea4bbb70f126f4f0cbcc369dab656d4ad93eacc9b
diff --git a/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild b/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild
new file mode 100644
index 00000000000..8c9d6545165
--- /dev/null
+++ b/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PN=${PN%-demo}
+
+DESCRIPTION="Third-person sneaker like Splinter Cell"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=coldwar"
+SRC_URI="http://demofiles.linuxgamepublishing.com/coldwar/coldwar-demo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/smpeg-0.4.4-r10[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/lib/*
+ ${dir:1}/bin/meng"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./data/data.tar.gz
+
+ mv bin/Linux/x86/${MY_PN}_demo .
+ mv bin/Linux/x86/bin/meng bin
+
+ rm -r bin/{Linux,*BSD} lgp_* setup.* data/data.tar.gz
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r *
+ rm "${D}/${dir}"/{${MY_PN}_demo,bin/{launcher,meng}}
+
+ exeinto "${dir}"
+ doexe ${MY_PN}_demo
+ exeinto "${dir}/bin"
+ doexe bin/{launcher,meng}
+
+ games_make_wrapper ${PN} ./${MY_PN}_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Cold War (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "The instruction manual is available as:"
+ elog " http://demofiles.linuxgamepublishing.com/coldwar/manual.pdf"
+ echo
+ einfo "To play the game, run: ${PN}"
+}
diff --git a/games-strategy/coldwar-demo/metadata.xml b/games-strategy/coldwar-demo/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-strategy/coldwar-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>