summaryrefslogtreecommitdiff
path: root/games-strategy/crimson
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/crimson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/crimson')
-rw-r--r--games-strategy/crimson/Manifest1
-rw-r--r--games-strategy/crimson/crimson-0.5.3.ebuild59
-rw-r--r--games-strategy/crimson/metadata.xml5
3 files changed, 65 insertions, 0 deletions
diff --git a/games-strategy/crimson/Manifest b/games-strategy/crimson/Manifest
new file mode 100644
index 00000000000..53b52d74d75
--- /dev/null
+++ b/games-strategy/crimson/Manifest
@@ -0,0 +1 @@
+DIST crimson-0.5.3.tar.bz2 882366 SHA256 d59858c05e340367c61c8ca1dd00c36642a0c56d10d1d9a1626c5ba7d88b40d6 SHA512 9632317c4b258ed5e501ad1d058706ed654fc621b07099f65d93e29fe92e53fc8f6bbffa13c70fc2129f30695d3f10e85174234dc96cc171631b3465d2b7cffc WHIRLPOOL 89ddb776b86de245004f69af3421803a8bceb30499b416612a52f3203eaeb98013cf1fe8af027f24756d77a05d3fa23a20a2c361cded41c19279f402498022f3
diff --git a/games-strategy/crimson/crimson-0.5.3.ebuild b/games-strategy/crimson/crimson-0.5.3.ebuild
new file mode 100644
index 00000000000..f18edcbbf5e
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.5.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="test zlib"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? (
+ =app-text/docbook-xml-dtd-4.2*
+ dev-libs/libxml2
+ )"
+
+src_configure() {
+ egamesconf \
+ --enable-sound \
+ --enable-network \
+ $(use_with zlib) \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ --enable-cf2bmp
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pixmapsdir="/usr/share/pixmaps" \
+ install
+ dodoc NEWS README* THANKS TODO
+ rm -rf "${D}/${GAMES_DATADIR}/applications"
+ make_desktop_entry crimson "Crimson Fields"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "Crimson Fields ${PV} is not necessarily save-game compatible with previous versions."
+ echo
+ elog "If you have older save files and you wish to continue those games,"
+ elog "you'll need to remerge the version with which you started"
+ elog "those save-games."
+}
diff --git a/games-strategy/crimson/metadata.xml b/games-strategy/crimson/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-strategy/crimson/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>