summaryrefslogtreecommitdiff
path: root/games-strategy/heroes3-demo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/heroes3-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/heroes3-demo')
-rw-r--r--games-strategy/heroes3-demo/Manifest1
-rw-r--r--games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild66
-rw-r--r--games-strategy/heroes3-demo/metadata.xml5
3 files changed, 72 insertions, 0 deletions
diff --git a/games-strategy/heroes3-demo/Manifest b/games-strategy/heroes3-demo/Manifest
new file mode 100644
index 00000000000..2eddd25fc44
--- /dev/null
+++ b/games-strategy/heroes3-demo/Manifest
@@ -0,0 +1 @@
+DIST heroes3-demo.run 99026773 SHA256 15de1efce09839013b5e85eddc57364167c46776b181b124299362a79e6ce735 SHA512 a3f60f12f7ce8ea0f160ec211e1f077693ff2f5e4b8b85ae0e31f1230a910b4df7c8c6a340762d4f09c9845d6141d235307f933305557a75fc63f409e077ac71 WHIRLPOOL 7afbd806f6e91dbbf2481723ae36b23c3ada9b7093bed815091ea76a8045623b4d52319b319a928537698e8cc89dce0cfedb8ad5b3cf75ce9ec6421631442a8a
diff --git a/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild b/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild
new file mode 100644
index 00000000000..311417d02f4
--- /dev/null
+++ b/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PN=${PN%-demo}
+
+DESCRIPTION="turn-based 2D medieval combat"
+HOMEPAGE="http://www.lokigames.com/products/heroes3/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+# Should also work on ppc
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND=">=sys-libs/lib-compat-loki-0.2
+ || (
+ ppc? (
+ x11-libs/libX11
+ )
+ !ppc? (
+ x11-libs/libX11[abi_x86_32(-)]
+ )
+ )"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/*"
+
+S=${WORKDIR}
+
+src_install() {
+ # Apply patch
+ loki_patch patch.dat data/ || die
+
+ local demo="data/demos/${MY_PN}_demo"
+
+ local exe_stub="${MY_PN}_demo"
+ if use ppc ; then
+ exe="${exe_stub}.ppc"
+ else
+ exe="${exe_stub}.x86"
+ fi
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ rm "${D}/${dir}"/{${exe_stub}*,*.sh} || die
+ doexe "${demo}/${exe}"
+
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}"
+ newicon "${demo}/icon.xpm" ${PN}.png
+ make_desktop_entry ${PN} "Heroes of Might and Magic III (Demo)" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-strategy/heroes3-demo/metadata.xml b/games-strategy/heroes3-demo/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-strategy/heroes3-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>