summaryrefslogtreecommitdiff
path: root/games-strategy
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-28 22:58:16 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-29 02:40:40 -0500
commit24cfdd5230eeaf7413f8028a7a8dd2393d55aa59 (patch)
tree0eaecf6ba91a085d64176bed62e6f942e1e8f0e1 /games-strategy
parent9f0b4b642b64cd5c97ef465fbf5a091ab4dba8dd (diff)
downloadgentoo-24cfdd5230eeaf7413f8028a7a8dd2393d55aa59.tar.gz
gentoo-24cfdd5230eeaf7413f8028a7a8dd2393d55aa59.tar.xz
old
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.12.4.ebuild118
2 files changed, 0 insertions, 119 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 03d4eb7708b..2c2c5b310ef 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,2 +1 @@
-DIST wesnoth-1.12.4.tar.bz2 392278313 SHA256 bf525060da4201f1e62f861ed021f13175766e074a8a490b995052453df51ea7 SHA512 d8ea6d8c14b69318f4458d7e6dcace28979230ea13b76d07635ae9be7f2c675d4aa9822ff376a9617fe9fc1560999afdcf3165319842a5c2f0a4f87a31c170e9 WHIRLPOOL d4767d809f6085ef979c02928482b4bb16d3a1bdf34246bdb8b9eae0c8a7650f9d7160a851318c24b969fef777064ab7fda7c7687aab09c49a52f08327f4af0f
DIST wesnoth-1.12.5.tar.bz2 387726941 SHA256 599aad40da4b271c5138ac5a4391d9ff9c367ee51f5c30ca138f6baf92aea81d SHA512 1a785c02389cd4bdc79b61f62c5bb98f01fde61c3923527195a5a8e8f8986349fcda3d40a4fb14248626ea8e79eba12b8232e39cce08bfea7fbdf3d9627d53b4 WHIRLPOOL 7afbbf28de36ce3a55a177bc5b6de7f635c4e18de5934378fce6ea6a1da7ab95c55ff6c35b4a3166927efc17138fb18ef600e08969b29001455e21a260c8f6b6
diff --git a/games-strategy/wesnoth/wesnoth-1.12.4.ebuild b/games-strategy/wesnoth/wesnoth-1.12.4.ebuild
deleted file mode 100644
index 59bb840074e..00000000000
--- a/games-strategy/wesnoth/wesnoth-1.12.4.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc fribidi nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7:0[joystick,video,X]
- media-libs/sdl-net
- !dedicated? (
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- fribidi? ( dev-libs/fribidi )
- dbus? ( sys-apps/dbus )
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua:0
- media-libs/fontconfig
- )
- >=dev-libs/boost-1.48:=[nls,threads]
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd || die
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt || die
- fi
- # bug #472994
- mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
- mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
-
- # respect LINGUAS (bug #483316)
- if [[ ${LINGUAS+set} ]] ; then
- local langs
- for lang in $(cat po/LINGUAS)
- do
- has $lang $LINGUAS && langs+="$lang "
- done
- echo "$langs" > po/LINGUAS || die
- fi
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- # Work around eclass
- append-flags -UNDEBUG
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- $(cmake-utils_use_enable fribidi FRIBIDI)
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DLOCALEDIR=/usr/share/locale"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README.md changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd
- fi
- prepgamesdirs
-}