summaryrefslogtreecommitdiff
path: root/games-util/joystick
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-07 15:05:10 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-07 15:05:29 +0200
commitee032c8a90d4ce9cc06824539afc8abe96a54dee (patch)
treede1f42ab70d492e4b7aa1a19f68fa7ebc260532f /games-util/joystick
parentcf5db2ecc75acb3894ba86efd594cf4e8d03538a (diff)
downloadgentoo-ee032c8a90d4ce9cc06824539afc8abe96a54dee.tar.gz
gentoo-ee032c8a90d4ce9cc06824539afc8abe96a54dee.tar.xz
games-util/joystick: Bump to version 1.4.9
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/Manifest1
-rw-r--r--games-util/joystick/files/joystick-1.4.9-build.patch34
-rw-r--r--games-util/joystick/joystick-1.4.9.ebuild43
3 files changed, 78 insertions, 0 deletions
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index 2b49efbca52..6f2f3138316 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1 +1,2 @@
DIST linuxconsoletools-1.4.8.tar.bz2 43964 SHA256 23c4ac595f608e25f472d947c4193233f763f37ae0cf6b48141d33443a4cee6a SHA512 ea3a0baa3f163e10a4c76f58977a96d91d91bddb1a75cea5195b0a631c11ca55e40730aaa0d1965404837595c4a7fd8b75c3dd7785fe0e47ee2c90021341f262 WHIRLPOOL c02960d5e171efef3739f440a903ae9b14bec8b6ab4de2181ea691aa78c870f81b291ac98e313d234778fb59c4be8e53242cb46db019f3dffdbd8f26ddcbb113
+DIST linuxconsoletools-1.4.9.tar.bz2 45430 SHA256 fa9c64f98cd991e71e23fa9b673635e23f0b69f0325593c0a56b8960bb139b67 SHA512 c2ea4f8f868b3d616bb0a4b84d6a051ed444251cc5d40c775863a5163359c9c34ee9647ff1c74e8659f7fef10d8722b4431b2e1706cf5052505731c1a1232ddd WHIRLPOOL 5939e606d5d8775d801dd93e5b4ca398218168f3ef56961a81b588ebfd0548d2ee03af8e5a3436fe6ed4ad60f972cdd74bed78b30cee949cc77c3fa64a3dd3a6
diff --git a/games-util/joystick/files/joystick-1.4.9-build.patch b/games-util/joystick/files/joystick-1.4.9-build.patch
new file mode 100644
index 00000000000..ce951cb5d5b
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.9-build.patch
@@ -0,0 +1,34 @@
+--- linuxconsoletools-1.4.9/docs/Makefile
++++ linuxconsoletools-1.4.9/docs/Makefile
+@@ -20,9 +20,13 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+--- linuxconsoletools-1.4.9/utils/Makefile
++++ linuxconsoletools-1.4.9/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)
diff --git a/games-util/joystick/joystick-1.4.9.ebuild b/games-util/joystick/joystick-1.4.9.ebuild
new file mode 100644
index 00000000000..6a415b92f90
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.9-build.patch
+ "${FILESDIR}"/${PN}-1.4.8-udev.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if use !udev ; then
+ rm "${D}"/usr/bin/jscal-{re,}store || die
+ fi
+}