summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch')
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch
new file mode 100644
index 00000000000..876148b891f
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.20.0-automagic-deps.patch
@@ -0,0 +1,68 @@
+Index: configure.in
+===================================================================
+--- configure.in (révision 5413)
++++ configure.in (copie de travail)
+@@ -448,9 +448,13 @@
+ dnl GSSAPI
+ dnl Check for Kerberos installation
+ have_gssapi=no
++
++AC_ARG_ENABLE(krb5,
++ AS_HELP_STRING([--enable-krb5],[Enable Kerberos 5 support]),
++ [],[enable_krb5=yes])
+ AC_PATH_PROG([KRB5_CONFIG], krb5-config, none, $PATH:/usr/kerberos/bin)
+-
+-if test "x$KRB5_CONFIG" != "xnone"; then
++
++if test "x$KRB5_CONFIG" != "xnone" -a "x$enable_krb5" = "xyes"; then
+ GSSAPI_LIBS="`${KRB5_CONFIG} --libs gssapi`"
+ GSSAPI_CFLAGS="`${KRB5_CONFIG} --cflags gssapi`"
+
+@@ -481,8 +485,12 @@
+ break
+ ])
+ LIBS="$saved_LIBS"
+- CPPFLAGS="$saved_CPPFLAGS"
+-fi
++ CPPFLAGS="$saved_CPPFLAGS"
++fi
++
++if test "x$KRB5_CONFIG" = "xnone" -a "x$enable_krb5" = "xyes"; then
++ AC_MSG_ERROR([*** kerberos 5 support enabled but krb5-config not found ***])
++fi
+ AC_SUBST(GSSAPI_LIBS)
+ AC_SUBST(GSSAPI_CFLAGS)
+
+@@ -1077,9 +1085,13 @@
+ dnl =====================
+ dnl ACL checks
+ dnl =====================
+-acl_backends=""
++acl_backends="none"
+ ACL_LIBS=""
+
++AC_ARG_ENABLE(acl,
++ AS_HELP_STRING([--disable-acl],[Don't use libacl support]),
++ [],[enable_acl=yes])
++
+ AC_CHECK_LIB(attr,getxattr,[ACL_LIBS="$ACL_LIBS -lattr"])
+ AC_CHECK_LIB(acl,acl_get_file,[ACL_LIBS="$ACL_LIBS -lacl"])
+ AC_CHECK_LIB(sec,acl,[ACL_LIBS="$ACL_LIBS -lsec"])
+@@ -1102,7 +1114,7 @@
+ gvfs_cv_HAVE_POSIX_ACLS=yes, gvfs_cv_HAVE_POSIX_ACLS=no)
+ LIBS=$acl_LIBS])
+
+-if test x"$gvfs_cv_HAVE_SOLARIS_ACLS" = x"yes" ; then
++if test x"$gvfs_cv_HAVE_SOLARIS_ACLS" = x"yes" -a x"$enable_acl" = x"yes"; then
+ have_solaris_acl_support=yes
+ acl_backends="solaris"
+
+@@ -1110,7 +1122,7 @@
+ AC_CHECK_HEADERS([pwd.h grp.h])
+ fi
+
+-if test x"$gvfs_cv_HAVE_POSIX_ACLS" = x"yes" ; then
++if test x"$gvfs_cv_HAVE_POSIX_ACLS" = x"yes" -a x"$enable_acl" = x"yes"; then
+ have_posix_acl_support=yes
+ acl_backends="posix"
+