summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-calculator
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-06 09:13:53 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-06 09:40:50 +0200
commitf002a70ce959cc715cffb29f06c61b3fc14722cc (patch)
tree95e18bb43afe94d7ba4bf3bd9dc1ac314ab7aa4c /gnome-extra/gnome-calculator
parentc3507534a383a16a6aac32cbc6050e814d26c9be (diff)
downloadgentoo-f002a70ce959cc715cffb29f06c61b3fc14722cc.tar.gz
gentoo-f002a70ce959cc715cffb29f06c61b3fc14722cc.tar.xz
gnome-extra/gnome-calculator: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'gnome-extra/gnome-calculator')
-rw-r--r--gnome-extra/gnome-calculator/Manifest1
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.20.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
index c46f409eedf..064c271d80c 100644
--- a/gnome-extra/gnome-calculator/Manifest
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -1,2 +1,3 @@
DIST gnome-calculator-3.18.3.tar.xz 1339496 SHA256 c376a4a14a3f7946b799b8458ac4cf2694735fc7c20e90cfda29e209439e32ff SHA512 74ee2e22dc199a1beb8526bfa11174caaaeed0c2568f5e122f1c1c7f09b75926d30b5bdfa61a1e8495de9c2a449ee632e62fbbc11c04d5c44c83f819a6c409b5 WHIRLPOOL c371233a98ec28a3aa2a956d69b834a97508e0d6a58a43f918ca1d992b7efb434533926cd2d72a610c1c00cfbb101139c1db44a7771549da463c882cc0702c98
DIST gnome-calculator-3.20.1.tar.xz 1454768 SHA256 02edcf99857599ac10ecd2faaf33ad20a9f11f7c5a89a52ee1b511d99b594b90 SHA512 28198343422d61eec40938e35659e92bec1a67c4a6f16bdafd7a13f0b3a449d884f33daa9cf6c61bd56e9859ae3554522a02c0650ffcfaf64fb69b69671e347e WHIRLPOOL 51940f923548c9a262d03dea1d263e4b11112e6f92e1b0616947ca10fb8e50ce2425abff2baf76b934585e22ca5f81e3a99e433ca535949ed2121975a5415230
+DIST gnome-calculator-3.20.2.tar.xz 1347584 SHA256 2af1c12a12a230f90fc221ff908efd80fe7eebfeaad56cd698c393d2fc34a8fb SHA512 c850d252a5d5505e6e32ec4db2299479a1ea35144ddd1fafb10b0acdfb840fd9d25b073eb6f9bfe0a29c9c8483a76a40c53c5bce1db4ed3c80ed963d2f35093b WHIRLPOOL f1facf603c75e616c36754b03b0225909c0d660e2285f1f3077fc3b393fc6e589ef16c9352f84762290459b533a338988cbbff25acdf8b7d9a2ce8d67846debc
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.20.2.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.20.2.ebuild
new file mode 100644
index 00000000000..230f3711c8d
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.20.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/gtksourceview-3.15.1:3.0
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-utils-2.3
+ !gnome-extra/gcalctool
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ VALAC=$(type -P true)
+}