summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-clocks
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-clocks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-clocks')
-rw-r--r--gnome-extra/gnome-clocks/Manifest2
-rw-r--r--gnome-extra/gnome-clocks/gnome-clocks-3.14.1.ebuild42
-rw-r--r--gnome-extra/gnome-clocks/gnome-clocks-3.16.1.ebuild42
-rw-r--r--gnome-extra/gnome-clocks/metadata.xml5
4 files changed, 91 insertions, 0 deletions
diff --git a/gnome-extra/gnome-clocks/Manifest b/gnome-extra/gnome-clocks/Manifest
new file mode 100644
index 00000000000..dd34fa42a66
--- /dev/null
+++ b/gnome-extra/gnome-clocks/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-clocks-3.14.1.tar.xz 872276 SHA256 9d6a6fe22e3e4569da44bb93e5e26eb3d3faf2b2edadfd45b088cea0e2c94b4b SHA512 6265f768dc6d87624c8f92690bdddc1b318bc97e7d18cad8654cc4ba75ec3265dabdbecf3c25cd8273e300f7febc2d07efa29d174425bb4d62905ead1bc391b2 WHIRLPOOL 95028888cfc9c79018085e49659a690b1ba8620e3de96e9e7c017e2cb0cfd09fc12c13cc63031e591e36c1c55f5a6e79f837d07a0041b3f6599a1f7fa360ce71
+DIST gnome-clocks-3.16.1.tar.xz 871648 SHA256 1804bac40d95044d43d6c04762dd2a0785f8783b38d9393290c31face083f3cc SHA512 bb41051259786f30e96c4551473f789c980ddcd39f10a7921c727068778464590c459a8a129740d1bc89a080c615e16429aa5287ee7b2570f3ce1fd4905a1853 WHIRLPOOL d21f9261e149c4f3a4ade4dcfc4e95bbbc7a3c11f3c899ab19ae6c5987d2cba599a35506005f93e08e6d19fac9e2ad4f21d2787faa73ff4e84d87c9c479c39c0
diff --git a/gnome-extra/gnome-clocks/gnome-clocks-3.14.1.ebuild b/gnome-extra/gnome-clocks/gnome-clocks-3.14.1.ebuild
new file mode 100644
index 00000000000..91a53749319
--- /dev/null
+++ b/gnome-extra/gnome-clocks/gnome-clocks-3.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="Clocks application for GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeClocks"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.39:2
+ >=x11-libs/gtk+-3.12:3
+ >=media-libs/libcanberra-0.30
+ >=dev-libs/libgweather-3.13.91:2=
+ >=gnome-base/gnome-desktop-3.7.90:3=
+ >=sci-geosciences/geocode-glib-0.99.4
+ >=app-misc/geoclue-1.99.3:2.0
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure ITSTOOL=$(type -P true)
+}
diff --git a/gnome-extra/gnome-clocks/gnome-clocks-3.16.1.ebuild b/gnome-extra/gnome-clocks/gnome-clocks-3.16.1.ebuild
new file mode 100644
index 00000000000..6b5f9e3b728
--- /dev/null
+++ b/gnome-extra/gnome-clocks/gnome-clocks-3.16.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="Clocks application for GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeClocks"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-misc/geoclue-1.99.3:2.0
+ >=dev-libs/glib-2.39:2
+ >=dev-libs/libgweather-3.13.91:2=
+ >=gnome-base/gnome-desktop-3.7.90:3=
+ >=media-libs/gsound-0.98
+ >=sci-geosciences/geocode-glib-0.99.4
+ >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/intltool-0.50.1
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure ITSTOOL=$(type -P true)
+}
diff --git a/gnome-extra/gnome-clocks/metadata.xml b/gnome-extra/gnome-clocks/metadata.xml
new file mode 100644
index 00000000000..6e0e2ecb48c
--- /dev/null
+++ b/gnome-extra/gnome-clocks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>