summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-packagekit
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-packagekit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-packagekit')
-rw-r--r--gnome-extra/gnome-packagekit/Manifest1
-rw-r--r--gnome-extra/gnome-packagekit/gnome-packagekit-3.12.2.ebuild98
-rw-r--r--gnome-extra/gnome-packagekit/metadata.xml5
3 files changed, 104 insertions, 0 deletions
diff --git a/gnome-extra/gnome-packagekit/Manifest b/gnome-extra/gnome-packagekit/Manifest
new file mode 100644
index 00000000000..37eb36aee31
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/Manifest
@@ -0,0 +1 @@
+DIST gnome-packagekit-3.12.2.tar.xz 4596908 SHA256 a4d5fca6f9481b48202f996c8a3835051c98b6e6df0929394704c3c41e28afb2 SHA512 e1e5cd296e4bc99c13d71805de530be644b4ac3a9bd5580d36ebd880a22292ec91ce9ad28a8ff66f0cb2285a5bc0c80f1b47421c9bbf7b2c9e2c1c17131bc21d WHIRLPOOL 66f23046d3fd262b5a5fbc470d762baaafbb75fb1c9e832f408672b8c399580a1ad2a9e7b03acd81c00c6a486074b224eed4b15d1377354f557823f6282013de
diff --git a/gnome-extra/gnome-packagekit/gnome-packagekit-3.12.2.ebuild b/gnome-extra/gnome-packagekit/gnome-packagekit-3.12.2.ebuild
new file mode 100644
index 00000000000..7169668a8bc
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/gnome-packagekit-3.12.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="PackageKit client for the GNOME desktop"
+HOMEPAGE="http://www.freedesktop.org/software/PackageKit/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls systemd test udev"
+
+# gdk-pixbuf used in gpk-animated-icon
+# pango used on gpk-common
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.91.0:3
+ >=x11-libs/libnotify-0.7.0:=
+ x11-libs/pango
+ >=dev-libs/dbus-glib-0.73
+
+ >=app-admin/packagekit-base-0.7.2[udev]
+ >=app-admin/packagekit-gtk-0.7.2
+ >=media-libs/libcanberra-0.10[gtk3]
+ >=sys-apps/dbus-1.1.2
+
+ media-libs/fontconfig
+ x11-libs/libX11
+
+ systemd? ( >=sys-apps/systemd-42 )
+ !systemd? ( sys-auth/consolekit )
+ udev? ( virtual/libgudev:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-utils
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# NOTES:
+# app-text/docbook-sgml-utils required for man pages
+# app-text/gnome-doc-utils and dev-libs/libxslt required for gnome help files
+# gtk-doc is generating a useless file, don't need it
+
+# UPSTREAM:
+# misuse of CPPFLAGS/CXXFLAGS ?
+# see if tests can forget about display (use eclass for that ?)
+# intltool and gettext only with +nls
+
+src_prepare() {
+ # Regenerate marshalers for <glib-2.31 compat
+ rm -v src/gpk-marshal.{c,h} || die
+
+ # * disable tests with graphical dialogs and that require packagekitd
+ # to be run with the dummy backend and installed .ui files
+ # * disable tests that fails every time packagekit developers make a
+ # tiny change to headers
+ sed -e '/g_test_add_func.*gpk_test_enum_func/d' \
+ -e '/g_test_add_func.*gpk_test_dbus_task_func/d' \
+ -e '/g_test_add_func.*gpk_test_error_func/d' \
+ -e '/g_test_add_func.*gpk_test_modal_dialog/d' \
+ -e '/g_test_add_func.*gpk_test_task_func/d' \
+ -i src/gpk-self-test.c || die
+
+ # Disable stupid flags
+ # FIXME: touching configure.ac triggers maintainer-mode
+ sed -e '/CPPFLAGS="$CPPFLAGS -g"/d' -i configure || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --localstatedir=/var \
+ --enable-iso-c \
+ $(use_enable nls) \
+ $(use_enable systemd) \
+ $(use_enable test tests) \
+ $(use_enable udev gudev) \
+ ITSTOOL="$(type -P true)"
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
diff --git a/gnome-extra/gnome-packagekit/metadata.xml b/gnome-extra/gnome-packagekit/metadata.xml
new file mode 100644
index 00000000000..da6fd63d008
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>