summaryrefslogtreecommitdiff
path: root/gnome-extra/libgsf/libgsf-1.14.36.ebuild
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-20 14:39:07 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-20 14:53:12 +0100
commit4ae2c13221897e3c09fd319f7397daa2b3afc872 (patch)
tree24f69dc597903ab78fa1403f92cb5c1e1aa57938 /gnome-extra/libgsf/libgsf-1.14.36.ebuild
parentf2237b797e0800c83ca6bc1682b7fa984e4c91fe (diff)
downloadgentoo-4ae2c13221897e3c09fd319f7397daa2b3afc872.tar.gz
gentoo-4ae2c13221897e3c09fd319f7397daa2b3afc872.tar.xz
gnome-extra/libgsf: Version bump, fix gdk pixbuf dependencies (#570854 by Marinus Schraal)
Package-Manager: portage-2.2.27
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.14.36.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.36.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.14.36.ebuild b/gnome-extra/libgsf/libgsf-1.14.36.ebuild
new file mode 100644
index 00000000000..79bee5c3498
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.36.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}