summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-09 22:17:45 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-09 22:51:02 +0100
commit1f75807a8a0ae926c4ae9b8f60cbb855b40ed379 (patch)
tree76ad5c4b4a445c70cc3003bb9e99836f61c3a793 /gnome-extra
parentd4f482700cfb96ef9f429ececacbaf8c4e3e5a9d (diff)
downloadgentoo-1f75807a8a0ae926c4ae9b8f60cbb855b40ed379.tar.gz
gentoo-1f75807a8a0ae926c4ae9b8f60cbb855b40ed379.tar.xz
gnome-extra/gucharmap: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.18.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 1afa62e3f07..75d4dc81c45 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -2,3 +2,4 @@ DIST gucharmap-3.0.1.tar.bz2 3275481 SHA256 948a376f13af98ffe6be29c73f1d89d2dbc2
DIST gucharmap-3.12.1.tar.xz 1918188 SHA256 5e260767da43f6dc31a8be33ca363da56781349b367464fa9c478bca66aa18d9 SHA512 47d5a85cd6941ea5698442658d7aa91ac9e2b86b861f2fa9fd2a397caddc81c89df550cd635c5cf080bb31e7f2f0968d4bd36c23dc231799af533736fe66bf6b WHIRLPOOL cd2986dc7070f94c66a61e51db7eca7fd5c4cd7cfcb13178e05446a5ea7a240f1b4d38a9b66ccabb60503e1b2c7ff7ca748248d0a31715fe7b0c09b37bae0c92
DIST gucharmap-3.14.2.tar.xz 1986052 SHA256 fdc3e1889c48c0835d349e2910000f62946ee9f2735d7f64d6a3ad5869c87872 SHA512 e1678ce27dbf0d316bb3b25655323dca071141800a1f0d35f354093a2126c72758a8d004fcc95e7d4221f2cd5c1b0328b35a2ff43eb76e2338d165c5bc32744b WHIRLPOOL 3d100c39c123e8cac43769d50c9fd48088181a07efcd50ae977f9370a1312a134a27f1f544c06a282be0251c6bf29637cfef43b16ba7bcafd2b6e11e84a501cc
DIST gucharmap-3.16.2.tar.xz 1996036 SHA256 0a3fa996ae271c8f4812a7d8dc573ece0c000d63185b4865fa99387455e1b13d SHA512 b20bf0d4a79bd926b0863b7451c6eaa3bba2741231c3719e4799df17aec86798362862ab0a7b19d0fa76d5f05e5fa34f0c516e76e5c0d0bf8e87d15f6e868662 WHIRLPOOL 285d9091d3a7281b84dc96e009a26eb0f154d63f9b222b3d5ae34d9fd6c3c14d7febaf110d26e5b8168b5be93a6d5f01bd70459606b563faf496a78e28b7c3b5
+DIST gucharmap-3.18.2.tar.xz 2031560 SHA256 80141d3e892c3c4812c1a8fad8f89978559ef19e933843267e6e9a5524c09ec9 SHA512 d12eefb56272192762086271aa65bfa8b9a8843ac68a6affa1af3d2c891227b0fdae1c274976ceb883ecce26b7d9a2b28c2712155650c0969d6da77b1ff482b5 WHIRLPOOL 176e29627e33e28e965d07efe94aac1c1110bc2c44603c7220d34e520b36a443f73bfc823a395f48760023e137980a822e49c701910813e9deb280b8be115d38
diff --git a/gnome-extra/gucharmap/gucharmap-3.18.2.ebuild b/gnome-extra/gucharmap/gucharmap-3.18.2.ebuild
new file mode 100644
index 00000000000..a9efc98ef1e
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-3.18.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE="cjk +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gucharmap-3:0
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # prevent file collisions with slot 0
+ sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Do not add ITSTOOL=$(type -P true); yelp-tools is a true required
+ # dependency here for some LINGUAS.
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable cjk unihan) \
+ $(use_enable vala)
+}