summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-06 17:54:59 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-06 17:54:59 -0400
commitc676e623a8b7c3e3f3e3b133c92bcb92316faf18 (patch)
treeec1961a7061e65f47ddb278911ee0f5b9963a051 /gnome-extra
parent6de4e36846c583f1188325c6a424c5acadee8c4a (diff)
downloadgentoo-c676e623a8b7c3e3f3e3b133c92bcb92316faf18.tar.gz
gentoo-c676e623a8b7c3e3f3e3b133c92bcb92316faf18.tar.xz
gnome-extra/cinnamon: fix build with clutter[-gtk]
Gentoo-Bug: 559794 Reported-by: Lara Maia Upstream-Bug-url: https://github.com/linuxmint/Cinnamon/pull/4600 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/cinnamon-2.6.13.ebuild4
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch36
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/cinnamon-2.6.13.ebuild b/gnome-extra/cinnamon/cinnamon-2.6.13.ebuild
index 76f706b0a8e..5f1d5367920 100644
--- a/gnome-extra/cinnamon/cinnamon-2.6.13.ebuild
+++ b/gnome-extra/cinnamon/cinnamon-2.6.13.ebuild
@@ -160,6 +160,10 @@ src_prepare() {
# https://github.com/linuxmint/Cinnamon/issues/3577
epatch "${FILESDIR}"/${PN}-2.4.5-gnome-3.14.patch
+ # Fix build with clutter[-gtk]
+ # https://github.com/linuxmint/Cinnamon/pull/4600
+ epatch "${FILESDIR}"/${PN}-2.6.13-test-recorder-includes.patch
+
# Use pkexec instead of gksu (from Arch)
# https://github.com/linuxmint/Cinnamon/issues/3565
sed -i 's/gksu/pkexec/' files/usr/bin/cinnamon-settings-users || die
diff --git a/gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch b/gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch
new file mode 100644
index 00000000000..3ed2c3a93f0
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch
@@ -0,0 +1,36 @@
+From cf960f096e426521fc898733580d47c725e52953 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 6 Sep 2015 14:53:48 -0400
+Subject: [PATCH] build: append ST_CFLAGS when building test-recorder
+
+test-recorder #includes st.h, which pulls in lots of headers, some of which
+might not be in TEST_CINNAMON_RECORDER_CFLAGS, depending on how clutter and
+gstreamer were configured.
+
+Fixes build failure reported at https://bugs.gentoo.org/559794 :
+
+In file included from ./st/st-bin.h:27:0,
+ from st.h:4,
+ from cinnamon-recorder.c:19:
+./st/st-types.h:26:21: fatal error: gtk/gtk.h: No such file or directory
+---
+ src/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3d8fdd3..e6e54a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -199,7 +199,8 @@ libcinnamon_la_SOURCES += $(cinnamon_recorder_sources) $(cinnamon_recorder_non_g
+
+ noinst_PROGRAMS += test-recorder
+
+-test_recorder_CPPFLAGS = $(TEST_CINNAMON_RECORDER_CFLAGS)
++test_recorder_CPPFLAGS = $(TEST_CINNAMON_RECORDER_CFLAGS) \
++ $(ST_CFLAGS)
+ test_recorder_LDADD = $(TEST_CINNAMON_RECORDER_LIBS) \
+ libst-1.0.la
+
+--
+2.5.1
+