summaryrefslogtreecommitdiff
path: root/gnustep-libs/sope
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-02-17 14:41:42 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-02-17 14:44:26 +0100
commitdd7690073ce365209734a3cd68784e1882a70485 (patch)
tree3117b0e556743380cb0502672e235f2af4ffc582 /gnustep-libs/sope
parent6cb7a9ce7b51dbc2eab4c13c538a343b27c68d9f (diff)
downloadgentoo-dd7690073ce365209734a3cd68784e1882a70485.tar.gz
gentoo-dd7690073ce365209734a3cd68784e1882a70485.tar.xz
gnustep-libs/sope: version bump, trim description
Package-Manager: portage-2.2.27
Diffstat (limited to 'gnustep-libs/sope')
-rw-r--r--gnustep-libs/sope/Manifest1
-rw-r--r--gnustep-libs/sope/sope-2.3.2.ebuild4
-rw-r--r--gnustep-libs/sope/sope-3.0.1.ebuild63
3 files changed, 66 insertions, 2 deletions
diff --git a/gnustep-libs/sope/Manifest b/gnustep-libs/sope/Manifest
index c2ec7f4d9b1..3bb267e8a59 100644
--- a/gnustep-libs/sope/Manifest
+++ b/gnustep-libs/sope/Manifest
@@ -1 +1,2 @@
DIST sope-2.3.2.tar.gz 2184555 SHA256 f37877eb5915d5a6a3bc831a4d38ef2bd60e7fdaa40354056b10c4cfbc0ecdc1 SHA512 17d0ee6474410692c6b81bf32b730f4352e7d9c367f18c4a53d7aebbbe65aa2ca2f6eeaea8c722c8367835973b96395b932c9fdb81f08fdf79f299a926e14c9d WHIRLPOOL 17ca7912056d6d6a33c70af56c44819eaff8f640a87de76aa8858f2cd85114026ce108d6d424d50b6fa4085649c1873aee1854482379708785a9162fdc94daf1
+DIST sope-3.0.1.tar.gz 2190373 SHA256 83dd4568ecc1ce25e31eab90d672b43051c35713b36dcfd3d06282ca4288f98e SHA512 d94c40a425a16e04d1b841b0845e8cd3f4a960978464affaa846a8ef5c2540234ced655069b25a31221af31b3febc9b8c887a89ef43b3129e2a886c1b8fc2f50 WHIRLPOOL 1346684d22a644e95b0fccf59649ad79dc0f9f15eeb37903b056354d561278f2aacae996805f653bd17485c34a13aa447f9b2d67a50f9a65e8d63dcdee772922
diff --git a/gnustep-libs/sope/sope-2.3.2.ebuild b/gnustep-libs/sope/sope-2.3.2.ebuild
index b06ce6194ef..5706ac2c132 100644
--- a/gnustep-libs/sope/sope-2.3.2.ebuild
+++ b/gnustep-libs/sope/sope-2.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI="5"
inherit eutils gnustep-2 vcs-snapshot
-DESCRIPTION="An extensive set of frameworks which form a complete Web application server environment"
+DESCRIPTION="A set of frameworks forming a complete Web application server environment"
HOMEPAGE="http://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
diff --git a/gnustep-libs/sope/sope-3.0.1.ebuild b/gnustep-libs/sope/sope-3.0.1.ebuild
new file mode 100644
index 00000000000..06fd5e2bfbf
--- /dev/null
+++ b/gnustep-libs/sope/sope-3.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils gnustep-2 vcs-snapshot
+
+DESCRIPTION="A set of frameworks forming a complete Web application server environment"
+HOMEPAGE="http://www.sogo.nu/"
+SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
+
+RDEPEND="
+ sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ mysql? ( virtual/libmysqlclient:= )
+ postgres? ( dev-db/postgresql:= )
+ xml? ( dev-libs/libxml2:2 )
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ # Non-standard configure script
+ ./configure \
+ --disable-strip \
+ $(use_enable debug) \
+ $(use_enable ldap openldap) \
+ $(use_enable mysql) \
+ $(use_enable postgres postgresql) \
+ $(use_enable xml) \
+ --with-ssl="${ssl_provider}" \
+ --with-gnustep || die "configure failed"
+}