summaryrefslogtreecommitdiff
path: root/kde-apps/kdepim-runtime
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-11 10:49:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-11 22:34:49 +0100
commit75cbd8e3abe4e81fa1288ef2ecab51a86dfdbb05 (patch)
tree914c30ed6d142517c106b29b0581f022f2d5f65c /kde-apps/kdepim-runtime
parent6ffd5fa657a7fa35f4ac561d294f5722c9dc1a50 (diff)
downloadgentoo-75cbd8e3abe4e81fa1288ef2ecab51a86dfdbb05.tar.gz
gentoo-75cbd8e3abe4e81fa1288ef2ecab51a86dfdbb05.tar.xz
kde-apps/kdepim-runtime: Fix GMail resource runtime crash
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=400400 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/files/kdepim-runtime-18.08.3-gmail-resource-crash.patch25
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-18.08.3-r1.ebuild91
2 files changed, 116 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/files/kdepim-runtime-18.08.3-gmail-resource-crash.patch b/kde-apps/kdepim-runtime/files/kdepim-runtime-18.08.3-gmail-resource-crash.patch
new file mode 100644
index 00000000000..37b67fd180f
--- /dev/null
+++ b/kde-apps/kdepim-runtime/files/kdepim-runtime-18.08.3-gmail-resource-crash.patch
@@ -0,0 +1,25 @@
+From a4316a290e243fd71a565a9b936012d27f116029 Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Date: Sun, 28 Oct 2018 20:38:49 +0100
+Subject: Fix crash in failing GMail resource
+
+BUG: 400400
+---
+ resources/imap/gmailpasswordrequester.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/resources/imap/gmailpasswordrequester.h b/resources/imap/gmailpasswordrequester.h
+index b5b8aa8..6f013c9 100644
+--- a/resources/imap/gmailpasswordrequester.h
++++ b/resources/imap/gmailpasswordrequester.h
+@@ -45,7 +45,7 @@ private Q_SLOTS:
+
+ private:
+ ImapResourceBase *mResource = nullptr;
+- KGAPI2::AccountPromise *mPendingPromise = nullptr;
++ QPointer<KGAPI2::AccountPromise> mPendingPromise;
+ };
+
+ #endif
+--
+cgit v0.11.2
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-18.08.3-r1.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-18.08.3-r1.ebuild
new file mode 100644
index 00000000000..87481aeb56d
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-18.08.3-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+# TODO kolab
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kimap 'test') )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-misc/akonadi-ews
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-gmail-resource-crash.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+ # We don't build kolab, so we can disable this
+ punt_bogus_dep KF5 KDELibs4Support
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}