summaryrefslogtreecommitdiff
path: root/kde-apps/kdepim-runtime
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:36:38 +0100
commitc1941078fbe8744f0710332dee5705d3a95a800b (patch)
tree2fbace875e510011c2845a85071b60cf371926d5 /kde-apps/kdepim-runtime
parent5d66f516d1a7e2a387429f8e4f28c2ed4ea166b4 (diff)
downloadgentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.gz
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.xz
kde-apps: Add KDE Applications 18.12.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest1
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-18.12.3.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
index e5d258c2291..61ef17289dc 100644
--- a/kde-apps/kdepim-runtime/Manifest
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -1,2 +1,3 @@
DIST kdepim-runtime-18.08.3.tar.xz 1752272 BLAKE2B b3bdac2cdd6a741d1af60881b7e923485272edd8a0edb6c1dcc51cf961e0c25e005946467d7fa467d4ee266fd08bf2e7de5878a990ef88c19a614f9c4cc28a7f SHA512 b2520e1eab7f722eeaf8c34a554db86aa5ee7bbfdf11e31c471f06c67c50426327fae1319f747ae240d8919ee12259c34ecdee0ce0a83cbee5df5c3b481b76ec
DIST kdepim-runtime-18.12.2.tar.xz 1773748 BLAKE2B 9644641a8207303c071b065448344927d8c43039ce997f4ef8f65e7826127c0bffffee9057f4839cdf6eee6b510c33b671cd116f2be0379617f690c73cd66f99 SHA512 450c8d3edb7f74d632d063013c8999fbab3a1e6789732ce50effff5b2cdb77df0bd51ba1dbd255a7d50a4bf01d96052b89d828df42e4ca210a941bddc76c5228
+DIST kdepim-runtime-18.12.3.tar.xz 1773576 BLAKE2B a8ed822a507380fbfcb48a60765370f108d9468ca0be406b29b4c0b0a2e3424cf58928c6913d517e2c05f8f8d85b7b47dcabf4e520d77c38a9c83f0c51e141dc SHA512 cf65ac59519fc37f4b52025a07271fb655b746446a97299675a289a96bcb9fd94080c224bd231c40c45fe81fd5dcc1cf8a0ed60ddce1bb4750c598715bd27279
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-18.12.3.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-18.12.3.ebuild
new file mode 100644
index 00000000000..ee891f62e8a
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-18.12.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+oauth"
+
+# TODO kolab
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtspeech)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ oauth? ( $(add_qt_dep qtnetworkauth) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ test? ( $(add_kdeapps_dep kimap 'test') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-misc/akonadi-ews
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package oauth Qt5NetworkAuth)
+ )
+
+ kde5_src_configure
+}