summaryrefslogtreecommitdiff
path: root/kde-apps/kopete
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-27 04:38:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-27 04:40:29 +1000
commit515252d3151a71f7463a9c9e4a4c567a33c72c75 (patch)
tree496f222914153a86070724093aea5f9a824bad5b /kde-apps/kopete
parent2517fdd3419568d51b7b34f82be2228fadc69373 (diff)
downloadgentoo-515252d3151a71f7463a9c9e4a4c567a33c72c75.tar.gz
gentoo-515252d3151a71f7463a9c9e4a4c567a33c72c75.tar.xz
kde-apps: version bump 16.04.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-16.04.2.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index a2ac22a95e2..fcf8bf84649 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,3 +1,4 @@
DIST kopete-15.12.3.tar.xz 6327696 SHA256 c81de37fa01f03805e6209b14030b41aca00fa3ad14a3ff87dde6f3510351be5 SHA512 0fececf549d40974a70fe415bdd67d144d082364ceffc01907395abc4b30285487f1d117d7114911ea8a7e7f82a76724eb96d0b41fa791b1471332c2380c907d WHIRLPOOL c240c6d8aa20552f4f663d7858b0fcae53c82f780d0b8e4584565b1f27b55cbafaae9a728b9a1b2bb4b540cf8c9b6337d575a8d39e669799a1e9cbf18217daa6
DIST kopete-16.04.1.tar.xz 6327828 SHA256 f081d5a53dc0593b906ae965480293942238c9a3db01cf55da8e860c323480c4 SHA512 01429f1a1372453bde0d646b1a22fd9d8b05146042107aa36168969c50ee99af166fb72ac1e09d84d5f6719cf9d935eed497d1fe78e9719d18dcb48c23ab7d21 WHIRLPOOL 38080e193d10a6029ff3462bfc5616f576766ce9ec699fc6546bff421fbdf5fe2e20189487718e6bf84842fb2b6d01d6da570d927189372202c8ee94c1a5b655
+DIST kopete-16.04.2.tar.xz 6329484 SHA256 ce0e6124aac67faba68817029ba3ef3193668be23bd5c748cdb8e608be91439a SHA512 52f1ff4b5186c45b7b209eda8df99474a46347f61841fdce3e6b9a43e9f394947f37dd08e52dbf07c116a7a470a985c47f678061cceadfd24e78aed48a8a1478 WHIRLPOOL 22a170c736f0778843667153f50dae06190f1180ad61f1683839d1cb2df1566c4512df8fc9e4035f73a8df995ab122b702f4a8fc38767fa47c8b452ec5269764
DIST kopete-4.14.3.tar.xz 6317288 SHA256 ba23c6dea57233e0861865a1d76c356b0d3f7037f95e2166d0daef14e6c13845 SHA512 33a433da426e7a4a519f033bb14635f31c92954f8e6c46b41759f4e1e41197aed9d07894b163a1e484648ac0e9f92914afe20dfbaa8ddff56b8751d426afd9fc WHIRLPOOL 62d8df47f3214b8cf05fc9ffab3662cc10a1402fd2d33339adb91cd91651c2652dc1dd637130f9e77bf77825b23e19c813f5c43614160cd4dcec945c19e3542e
diff --git a/kde-apps/kopete/kopete-16.04.2.ebuild b/kde-apps/kopete/kopete-16.04.2.ebuild
new file mode 100644
index 00000000000..2ae65ae42fb
--- /dev/null
+++ b/kde-apps/kopete/kopete-16.04.2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+sms testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kdelibs 'zeroconf?')
+ $(add_kdeapps_dep kdepimlibs)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca:2[openssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_GOOGLETALK=$(usex jingle)
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DWITH_Speex=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ zeroconf) x2=bonjour ;;
+ xmpp) x2=jabber ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[openssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=openssl."
+ fi
+ fi
+ fi
+}