summaryrefslogtreecommitdiff
path: root/kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-20 19:44:19 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-20 19:45:51 +0200
commit2c5b2a40455b7e8b68c317f7d782edd294a9f9bd (patch)
tree7a95405cd3322e1a7b957f5ad6eee90622124434 /kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild
parent7cd05a3946ad74ca363fdb31183aaa21c4170c70 (diff)
downloadgentoo-2c5b2a40455b7e8b68c317f7d782edd294a9f9bd.tar.gz
gentoo-2c5b2a40455b7e8b68c317f7d782edd294a9f9bd.tar.xz
kde-apps: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild')
-rw-r--r--kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild b/kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild
new file mode 100644
index 00000000000..76d961c74f7
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-15.08.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}