summaryrefslogtreecommitdiff
path: root/kde-apps/nsplugins
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/nsplugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/nsplugins')
-rw-r--r--kde-apps/nsplugins/Manifest1
-rw-r--r--kde-apps/nsplugins/metadata.xml5
-rw-r--r--kde-apps/nsplugins/nsplugins-4.14.3.ebuild30
3 files changed, 36 insertions, 0 deletions
diff --git a/kde-apps/nsplugins/Manifest b/kde-apps/nsplugins/Manifest
new file mode 100644
index 00000000000..f17829a584a
--- /dev/null
+++ b/kde-apps/nsplugins/Manifest
@@ -0,0 +1 @@
+DIST kde-baseapps-4.14.3.tar.xz 2548152 SHA256 125baf42a7ab8c255b5829d12837f54c1791498f79593a9b09a9e55344ade6db SHA512 d422c1ee5cd2e1dc15b5baa2199bb85441196bc3048b9bfa443f898c3a1cfbc7f66087edf016fb594b9e48340517beef54b4429b4fde664374e75486c7cb0f9e WHIRLPOOL b22a98d140bb66ea47aeb5607e606c7a531c82787e27204f5eabb7d29d763b2bfe1456d85242d3e05e7ab4d2366fc622ef1cc624dd1954e276fb36c49840998a
diff --git a/kde-apps/nsplugins/metadata.xml b/kde-apps/nsplugins/metadata.xml
new file mode 100644
index 00000000000..a23f444b67d
--- /dev/null
+++ b/kde-apps/nsplugins/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-apps/nsplugins/nsplugins-4.14.3.ebuild b/kde-apps/nsplugins/nsplugins-4.14.3.ebuild
new file mode 100644
index 00000000000..ed1a4c19973
--- /dev/null
+++ b/kde-apps/nsplugins/nsplugins-4.14.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-baseapps"
+inherit kde4-meta pax-utils
+
+DESCRIPTION="Netscape plugins support for Konqueror"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ x11-libs/libXt
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep konqueror)
+"
+
+KMEXTRACTONLY="
+ konqueror/settings/
+"
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 419513
+ pax-mark m "${ED}"/usr/bin/nspluginviewer
+}