summaryrefslogtreecommitdiff
path: root/kde-apps/rocs/rocs-16.12.0.ebuild
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 19:38:26 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 19:38:38 +0100
commit31645664f42a588800ba68febd89a9c9e6afc76f (patch)
treeccc391e5d2b2b2255adcafe060246a5ddf9a3396 /kde-apps/rocs/rocs-16.12.0.ebuild
parent7b312d591b5ad4a742ec3d17d0237eb25c6fe24b (diff)
downloadgentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.gz
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.xz
kde-apps: Version bump KDE Applications 16.12.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/rocs/rocs-16.12.0.ebuild')
-rw-r--r--kde-apps/rocs/rocs-16.12.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/rocs/rocs-16.12.0.ebuild b/kde-apps/rocs/rocs-16.12.0.ebuild
new file mode 100644
index 00000000000..b00943e5846
--- /dev/null
+++ b/kde-apps/rocs/rocs-16.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0.0"
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Interface to work with Graph Theory"
+HOMEPAGE="https://www.kde.org/applications/education/rocs
+https://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/grantlee:5
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT+=" test" # 1/10 tests currently fails