summaryrefslogtreecommitdiff
path: root/kde-apps
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-11 22:03:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-12 00:34:44 +0100
commit9be309db2b2c026522ff84601e8cef1c8a1eb9d3 (patch)
treed3e908eb7a02452ab861c8fde8137598b0ab0fff /kde-apps
parent91df9cfebbc0ac58b663856f13a087305738c4a7 (diff)
downloadgentoo-9be309db2b2c026522ff84601e8cef1c8a1eb9d3.tar.gz
gentoo-9be309db2b2c026522ff84601e8cef1c8a1eb9d3.tar.xz
kde-apps/cantor: Fix bashism
Gentoo-bug: 596940 Thanks-to: Michael Palimaka (kensington) Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/cantor/cantor-16.12.2.ebuild2
-rw-r--r--kde-apps/cantor/files/cantor-16.12.2-bashism.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/kde-apps/cantor/cantor-16.12.2.ebuild b/kde-apps/cantor/cantor-16.12.2.ebuild
index 96540cab7f5..a1f359a35ed 100644
--- a/kde-apps/cantor/cantor-16.12.2.ebuild
+++ b/kde-apps/cantor/cantor-16.12.2.ebuild
@@ -56,6 +56,8 @@ RDEPEND="${RDEPEND}"
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}"/${P}-bashism.patch )
+
pkg_pretend() {
kde5_pkg_pretend
diff --git a/kde-apps/cantor/files/cantor-16.12.2-bashism.patch b/kde-apps/cantor/files/cantor-16.12.2-bashism.patch
new file mode 100644
index 00000000000..424ca4d15aa
--- /dev/null
+++ b/kde-apps/cantor/files/cantor-16.12.2-bashism.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/FindR.cmake b/cmake/FindR.cmake
+index 6303417..6494884 100644
+--- a/cmake/FindR.cmake
++++ b/cmake/FindR.cmake
+@@ -31,7 +31,7 @@ IF(R_EXECUTABLE)
+ OUTPUT_VARIABLE R_INCLUDE_DIR)
+ ELSE(WIN32)
+ EXECUTE_PROCESS(
+- COMMAND ${R_EXECUTABLE} CMD sh -c "echo -n $R_INCLUDE_DIR"
++ COMMAND ${R_EXECUTABLE} CMD sh -c "printf $R_INCLUDE_DIR"
+ OUTPUT_VARIABLE R_INCLUDE_DIR)
+ ENDIF(WIN32)
+ ENDIF(NOT R_INCLUDE_DIR)